Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

If an orange triangle appears on an e-mail message, what can be done to protect?

  • 24 svar
  • 3 har dette problem
  • 1 visning
  • Seneste svar af Boudica

more options

Only IN THE LAST DAY OR 2, since I updated to version 42.0 did I start seeing this orange triangle on some e-mails. What action can I take to make the message content secure?? I never had this occur previously. My e-mail program is Yahoo.

Alle svar (20)

more options

Where is the orange triangle?

If you see an orange triangle in the address bar where you normally expect to see the gray or green padlock, it indicates a problem with the security of the content of the page. If you click the triangle, does it give any more information about the problem or allow you to take any action on it?

If the orange triangle is in the web page, it may be a feature of the site or of one of your add-ons. Could you provide more information about it?

more options


jscher 2000: This is something that just started after I updated to FF version 42 yesterday. I use Yahoo for e-mail. Here is the scenario:

When opening a message, the padlock is grey, and there is an orange triangle over part of it. I click on that, and it says:



Connection is not secure.

"Parts of this page are not secure (such as images). Then I click on an ">", and it says:

Your connection is not private and information you share with the site could be viewed by others.

This website contains content that is not secure (such as images)

Then there is a box for MORE INFORMATION: I click on that, and it states: Connection Partially Encrypted. Parts of the page you are viewing were not encrypted before being transmitted over the Internet. Information sent over the Internet without encryption can be seen by other people while it is in transit..


This comes up on all messages, unless I go to the "in" box and "reload" the page. Otherwise the orange triangle comes up on all of the messages, even the one I received from Mozilla Firefox.

I use Yahoo for my e-mail. The only other action I took yesterday was to use the Google translation site and I copied and transferred some information to an e-mail i was working on. I suspected that could be a problem so I blocked the cookies on that website. It didn't change anything. There is one message that could have set this off too, and I think I should delete it. This is where I first noted the orange triangle. I don't think it will help, however I can only try it to see.

I have had Yahoo for more years than I can remember and have never seen this problem before. I don't know if unblocking the Google translation site cookies would help or not. I may try it, however I don't think it will help.

Thank you very much for your reply.

Ændret af Boudica den

more options

If there is mixed passive content (e.g. images) then Firefox shows an exclamation mark instead of "Site Identity Button" (globe/padlock) on the location/address bar.

more options


cor-el: I notice there are a few times when I am accessing this question, that there is a VERY quick message on a light yellow background. It is so fast that I have not been able to get it all, however I did get this much of it:

"Update your version of Firefox"......

I will continue to try to get the rest of the msg., however it is so quick that it's almost impossible.

I do appreciate the links you have provided, however my problem with the e-mails continues. It comes up as a grey padlock with the ORANGE triangle, and as I noted above there is no way to change this. The only way I can get back to normal with the UNAFFECTED e-mails is to reload the current page (which takes me to the In Box). This is on Yahoo.

I feel that this was possibly a bad download which may have caused the problem (especially after noting the msg. about "Update your version of Firefox (remainder of msg. is too quick thus far for me to catch). I do not know how I can update when I already have the new Version 42.0

I am REALLY upset. Thank you very much for your reply.

Ændret af Boudica den

more options



more options

The warning triangle only means that Firefox is detecting mixed passive content. Firefox doesn't block such mixed passive content (security.mixed_content.block_display_content defaults to false). Maybe you can identify this content in the Web Console or Network Monitor (Firefox menu button or Tools > Web Developer)

more options

In earlier versions, the orange (vs. gray) triangle would appear if you approved Firefox to load active content that has an HTTP URL into a page that has an HTTPS URL. Perhaps there is a new scenario where you get an orange shield that I'm not aware of.

Could you test opening some of the same email messages in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

more options

Oops, the icons changed: How do I tell if my connection to a website is secure?

If the orange-yellow exclamation triangle is superimposed on the gray lock, then some display content in the email or maybe an advertisement is HTTP instead of HTTPS, most likely an image.

I think cor-el already mentioned that before I understood it...

more options
  • chrome://browser/skin/identity-mixed-active-blocked.svg
  • chrome://browser/skin/identity-mixed-active-loaded.svg
  • chrome://browser/skin/identity-mixed-passive-loaded.svg


  • chrome://browser/skin/browser.css
more options

cor-ell: I do not know what the last message means (I am not computer literate). Thank you for you recommendations.

jscher2000: Thank you for your recommendations too.

Update: An IT Pro was here yesterday for quite a long time, and was unable to find the problem. This "partially unencrypted" icon has been appearing on all incoming messages with images, and some of the e-mails themselves are corrupted in some manner (e.g. images, sans dialogue, or BLANK. etc.). The senders are sending, however these messages are arriving corrupted in some manner. It may be as long as a week before I can get help again.

      • One bright spot is that I did receive one message early today that had the green "security lock" on it, and it dd have 2 images. I will report back if there are any other changes. ***
more options

What I posted above are internal links to the images that you see at the left end of the location/address bar in case other want to check out the CSS rules for the various cases.

It is likely that the links to images that were embedded in the email were http:// type of links and the email itself was served via https://. If you no longer see this special triangle then that means that now all media links (images) are coming via a secure https:// link.

more options

cor-el, using the Internet Explorer all messages come through as being "secure".

Using Firefox, the problem continues to exist.

I never had this problem until the (quick as a flash) update to Version 42.0. There is a serious problem here, and I don't know when I will have time to try some of the recommendations. I wonder if a "refresh" to the Firefox would correct the problem. I don't know when I will have time to try some of the recommendations you and jscher2000 have provided.

I will do my best. Thank you once again.

more options

For cor-el:

I had only a few moments, and i went back and clicked on the following link in one of your messages:


When I clicked on this link the little message in a light yellow background stated (very quickly):

"Please update your version of Firefox to enjoy these latest features."

I already have Version 42.0 according to what the browser shows, however I still feel that the update was flawed in some manner. I am baffled by this message.

   Thank you again for all of your recommendations.
more options

cor-el, and jscher 2000:

More information on the Firefox problems.

I noted that even though I have had "auto update" and "use 3rd party to install", I have still been getting the prompt to "allow Firefox to make changes to the computer" question when updating.

This has been occurring for the last several times I updated. There is something definitely wrong with my version of Firefox. Is there any recourse to "refresh" that could possibly help? I hate to lose my Firefox.

The problems are still existing with the e-mail.

more options

I think when an update is installed through the Mozilla Maintenance Service, it should bypass the UAC prompt. If that isn't working on your system, I'm not sure how best to diagnose that.

If you see something on a site that flashes away quickly, it's possible that it was default text that a script updated. If you check your user agent string on my test page, do both of the lines in red show Firefox 42?


more options

If the MMS service isn't working properly then you can uninstall this service via the Windows Control Panel and reinstall it by running the installer in the Firefox program folder.

more options

My apologies to you both for being unable to respond sooner. I was away all day yesterday. I tried to copy what I found on your link jscher however it does not want to "stay" in a message.

I will copy one of the links now: It was in "red":

Browser "User Agent" string: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

I will try to send the other link in a new message. Thank you for the recommendation.

more options

Here is the other part of the information. The parts in "red" begin with the words: Mozilla.

Here is what I copied:

navigator.userAgent = Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

I hope this is the information you were looking for jscher 2000.

more options

cor-el, I will look at the information you posted as well. I hope that I can extricate myself from this difficult problem, as I am reluctant to forward any messages that have the "warning" on them.

Thank you, as always, for your willingness to help.

more options

Hi Boudica, your Firefox is properly reporting itself as Firefox 42, so if there was a brief message about updating, it must have been removed when the site realized you are already up-to-date. So I think you can set that aside as not being part of the problem.

  1. 1
  2. 2