Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Somehow I got Yandex loaded and can't get rid of it. Russian browser or something. Help

  • 3 svar
  • 6 har dette problem
  • 11020 visninger
  • Seneste svar af Hansm333

more options

I was in the middle of some downloads from the Internet and all of a sudden I got some Russian looking boxes that popped in and it basically looks like I loaded a Russian program called Yandex. It appears to be a browser. I got rid of everything that was visible in my programs with uninstall commands. However, when I am in Firefox and want to add a new tab, it automatically opens this Yandex browser. It doesn't appear to be doing anything bad to my system, but i still want to get rid of it. I've deleted cookies and everything else i can think of. The only evidence that tells me that it's still in my computer is a search that reveals it's a shortcut to the browser. But why it activates when I try to open a new tab in Firefox, and why i can't get rid of it is a mystery.

Valgt løsning

You do have an extension named Yandex Elements that would be a logical candidate for removal.

Open Firefox's Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. Bear in mind that all extensions are optional, none come with Firefox, and you can learn more about them by checking their reviews on the Add-ons site.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Success?

If necessary here's how you can change your new tab page to your preferred display:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

Læs dette svar i sammenhæng 👍 5

Alle svar (3)

more options

Valgt løsning

You do have an extension named Yandex Elements that would be a logical candidate for removal.

Open Firefox's Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. Bear in mind that all extensions are optional, none come with Firefox, and you can learn more about them by checking their reviews on the Add-ons site.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Success?

If necessary here's how you can change your new tab page to your preferred display:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

more options

Yes, thanks! This fix worked just fine. I Appreciate the fast return.

more options

Thank you very much. This fix worked just fine!!!!!! No more Russian browsers or anything like it.