Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

copy/paste not working

  • 10 svar
  • 5 har dette problem
  • 12 visninger
  • Seneste svar af cor-el

more options

I can copy from FF 39.0 and paste into a word document, or into notapad, etc. However, I cannot paste into FF. I've used the mouse to copy and when I try to paste something else pops up, not the paste options. I've tried Ctrl -C, which does copy as I can then Ctrl + P into another program, but I cannot Ctrl + P into FF.

I can copy from FF 39.0 and paste into a word document, or into notapad, etc. However, I cannot paste into FF. I've used the mouse to copy and when I try to paste something else pops up, not the paste options. I've tried Ctrl -C, which does copy as I can then Ctrl + P into another program, but I cannot Ctrl + P into FF.

Alle svar (10)

more options

I am not using Windows 8, but pasting into Firefox works ok for me.

Of course it may depend on what you are trying to do it would not be possible for instance to paste an image into this webpage.

What about simply when writing your replies to this forum. Are you able to select and copy then paste text from one part of the answer you are writing to another ?

What about simply when writing your replies to this forum. Are you able to select and copy then paste text from one part of the answer you are writing to another ?

What sort of thing is it you are trying to do ? You mention notepad. Are you able to write an answer in notepad then paste it into here ? That works for me (Or at least it did last time I tried it).

more options

In Firefox you need to use Ctrl+V to paste.

Use keyboard shortcuts if the buttons on the web page or other methods aren't working.

  • Copy: Ctrl+C or Ctrl+Insert (Mac: Command + C)
  • Paste: Ctrl+V or Shift+Insert (Mac: Command + V)
  • Cut: Ctrl+X or Shift+Delete (Mac: Command + X)
more options

What pops up? Is it an error message?

When you refer to Paste Options, I think of the little floating Paste Options tool that comes up in Word, with buttons for source formatting, destination formatting, and plain text. Firefox doesn't have anything like that built-in, although individual websites might have a way to emulate it. Were you used to seeing Paste Options in Internet Explorer on particular websites?

more options

OOPS, I overlooked you were trying Ctrl+P In Windows and many other situations it is Ctrl+V as cor-el has already mentioned.

more options

de copy and paste don't work on this site http://www.vertalen.nu/zinnen/

more options

Hi IngridMG, on that site, I cannot copy when I select the translation result, but if I use the button, then the translation is copied automatically. I have attached a screen shot showing the button I mean. Is that button not working for you?

more options

yes al so that button not working for my

more options

Hi IngridMG, on the translation text, there is a script which intercepts your copy request to "clean" it but for some reason, it just stops the copying from working correctly.

I think using their copy button is the best solution, but there are two other possible workarounds if you do not like using the copy button:

(1) Disable all sites from reacting to cut, copy, and paste

The problem with this is that it will break some features of sites.

(2) Override the script by injecting your own script into the page

You can do this using a "bookmarklet", which is a brief script that you save on the Bookmarks Menu or Bookmarks Toolbar so you can click it when you want to modify the currently displayed page.


For #1:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste clip and pause while the list is filtered

(3) Double-click the dom.event.clipboardevents.enabled preference to switch it from true to false (it should turn bold)

If some sites seem to stop working correctly when you use cut, copy, or paste, you probably will need to switch this setting back to normal.


For #2:

(1) Select and copy this script:

javascript:void(addEventListener('copy', function (e){e.stopPropagation();}, true));

What that does is detect when you copy, and block other scripts in the page from detecting it.

(2) Right-click a convenient location on the Bookmarks Menu or Bookmarks Toolbar and choose New Bookmark

(3) Paste the script into the Location line

(4) Give a name like "AllowCopy"

(5) Click the Add button

When you select the translation and you notice that you can't copy, click the button to add your script and hopefully this will solve the problem.

more options

Hi, now is to much for me to do this, I don't wont to do more problems

more options

You can create a new bookmark on the Bookmarks Toolbar via the right-click context menu and paste this JavaScript code in the location field:

javascript:txt=document.querySelector("#resulttxt").innerHTML;void(prompt(txt,txt));