Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

MP4 videos play with no sound

  • 15 svar
  • 11 har dette problem
  • 6448 visninger
  • Seneste svar af duncan_roe

more options

When I play MP4 videos, I get picture but no sound (and no volume control) Example URL: https://vimeo.com/123291819 Also on “Video For Everybody” Test Page http://camendesign.com/code/video_for_everybody/test.html by default the video is silent. Switch to OGG - get sound. Back to MP4 - no sound.

Valgt løsning

I have it working now. Someone from the local LUG kindly sent me the output as I requested above. Slackware does not come with package gst-plugins-bad, which provides libgstfaad.so (for the AAC decoder). I had previously installed the faad2 package which provides libfaad.so which I see FF now using so maybe is required as well. I also installed and see FF using libraries from pulseaudio & json-c. While my sound started after installing gst-plugins-bad, it may be that the other 3 are also required, but I cannot be sure of that.

Læs dette svar i sammenhæng 👍 4

Alle svar (15)

more options

H.264 is needed for both to work. Make sure the extension is enabled: https://developer.mozilla.org/en-US/A.../H.264_support_in_Firefox

Please also try these troubleshooting steps:

Ændret af guigs den

more options

Many thanks for your reply. Unfortunately I am no further forward. I already have the plugin "OpenH264 Video Codec provided by Cisco Systems, Inc. 1.4", and it is set to "Always Activate". I have an ix86 desktop, so can't turn on H.264 support in Linux (for ARM architecture only). The Big Bucks Bunny video clip from the link you provided plays silent.

What could I be missing?

more options

Some more thoughts:

In that last link it says that is relies on GStreamer codecs, do you have gstreamer installed 32bit version?

more options

Thanks for your ongoing suggestions: - I did have shumway installed but I deleted it in case it was getting in the way. Should I re-install? - Sorry, I don't understand how the sound card can not be up to date. I am using ALSA like most Linux users I guess. lspci says it's AMD/ATI [Advanced Micro Devices, Inc.] SBx00 Azalia (Intel HDA) - I have gstreamer that came with my distribution (Slackware 14.1) but it's version 0.10.36 which dates it 20-Feb-2012. Too old? - The website says "Do not compile from source yourself unless you are certain you have to or want to" but I'm happy to give it a go. They're up to 1.5.2 of 24-Jun-2015 (that's only 2 days ago). Or is there a particular revision you would recommend?

more options

I am not an expert in this, so I apologize. I did find that gstreamer 1.0+ should work: https://bugzilla.mozilla.org/show_bug.cgi?id=806917 That version you have should be fine? would it be easy to replace the previous version if we were to try the change?

Also, I believe Shumway works with mp4s.

Ændret af guigs den

more options

What does it say about the volume if you click "Show Statistics" in the right-click context menu?

more options

I upgraded gstreamer to 1.4.4 (from Slackware -current: i.e. this will be the version in the next Slackware release). Now FF does not try to play MP4 files. Instead it offers to play via VLC (where the sound works). I see in bug 806917 lots of discussion as to whether support gstreamer 1.0 or stay with 0.10. From the bug report I understand this is a compile-time option and that the two are not compatible. Any progress on this?

I guess I can live with using VLC for now, so I can close this if you would like. Or I can try other software (including switch gstreamer back to 0.10.36) in the meantime if there is anything you'd like me to test.

@cor-el I upgraded before I saw your post so can't do your test. But ... the volume control did not display: does that answer your Q?

Ændret af duncan_roe den

more options

I actually do not have more information on this (gstreamer version) but I think corel is on to something: Since its not displaying is it possible to show/hide the controls?

more options

I wasn't talking about the volume control on the control bar, but about information about the current value of the volume setting that you see in the "Show Statics" information that you get when you click this item in the right-click menu of the HTML5 media player window.

more options

OK I switched back to gstreamer-0.10.36. MP4 files play silently. "Show Statistics" says volume is 100%. Is that the answer you were looking for?

more options

Yes. That would confirm that you aren't muting the sound in the player, but possibly that Firefox isn't able to decode the sound stream.

VLC shows this information for the audio stream of the Big Buck Bunny video

Codec: MPEG AAC Audio (mp4a)
more options

FF 39.0 just arrived but the silent playing persists. A colleague at the Melbourne Linux User Group (MLUG) has it working under FF 35.0. I can see the same codec info in a short test video he sent me [Codec: MPEG AAC Audio (mp4a)] His Linux distribution is Debian / Jessie whereas I have Slackware 14.1 (with kernel upgraded and reconfigured). Could it be that AAC needs some kernel support for gstreamer to play it?

more options

I do not know, but I do know you need the ability to decode the codec.

more options

It seems to me that Firefox uses the gstreamer share library directly, rather than the command-line interface discussed in the stackoverflow question. When I have gstreamer-0.10.36 installed, lsof FF_pid shows me (spaces compressed):

firefox 4450 dunc mem REG 8,2 738736 21397934 /usr/lib/libgstreamer-0.10.so.0.30.0

lsof also shows libgstvideo-0.10.so and libgstvideo-0.10.so (from package gst-plugins-base-0.10.36). When It plays a video, FF opens more libraries, including e.g. libgstaudio-0.10.so.0.25.0 and libgstaudioparsers.so.25.0.

I would post the entire lsof but the Browse button won't let me upload a .txt file. I could edit it down and post inline - would that be helpful?

Or maybe someone with a Linux system with sound could do that please? Run this command:

lsof -p $(pgrep firefox) | grep -w mem | rev | cut -f1 -d' ' | rev > lsof.txt

post lsof.txt inline

I am thinking that maybe my revisions are a tad too old or I am missing a component.

Ændret af duncan_roe den

more options

Valgt løsning

I have it working now. Someone from the local LUG kindly sent me the output as I requested above. Slackware does not come with package gst-plugins-bad, which provides libgstfaad.so (for the AAC decoder). I had previously installed the faad2 package which provides libfaad.so which I see FF now using so maybe is required as well. I also installed and see FF using libraries from pulseaudio & json-c. While my sound started after installing gst-plugins-bad, it may be that the other 3 are also required, but I cannot be sure of that.