Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No sound or audio in flash.

  • 8 svar
  • 4 har dette problem
  • 8281 visninger
  • Seneste svar af Cypherial

more options

I have: Firefox 38.0.5 Shockwave Flash 18.0.0.160

Problem is that when I watch a video that is NOT in youtube, there seems to be no sound. This happens on sites such as: twitch.com kissanime.com (In this site the have the option to play videos in HTML5, which works fine) and website with flash games like: kongregate.com

Valgt løsning

I think I have found the problem. Turns out it wasn't the Firefox. I found out that it was my headset. I use a Logitech G35, there was volume in youtube but not other flash player on other website.

I found this out when I used earphones and switched the playback from my G35 to Realtek HD Audio.

The problem is still there, but now I know it is my headset that is the problem. I'll just have to play around with settings more.

Læs dette svar i sammenhæng 👍 0

Alle svar (8)

more options
more options

FredMcD said

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

My graphics driver is up to date and still the problem persist.

more options
more options

FredMcD said

http://kb.mozillazine.org/Images_or_animations_do_not_load https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues?redirectlocale=en-US&redirectslug=Video+or+audio+does+not+play https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

If these do not help, I wll call the big guys.

Thank you for the quick replies.

I tried most of the solutions in those sites. Problem is still here. Youtube works fine, but twitch plays the videos with no sound.

I tried: making sure volume is up, turning off firewall and Adblock, disabling and enabling various Plugins and made sure they are up to date, clearing cache and cookies and making sure they are enabled, running firefox in safe mode, reinstalling firefox and flash.

None of these methods worked.

more options

I've called the big guys to help you. Good luck.

more options

I tested a twitch channel and the volume showed up for a Window 7 vm with the former version of Flash installed.

I also tried these settings in Flash Global settings:

  • Clear the browsing cache in Advanced
  • Clear the storage after I updated

The speed increased, but I never had any issue with the sound.I also understand that none of these tried, but did anything change?

Does the twitch player use the DRM plugin? Check to see if this is enabled: https://support.mozilla.org/en-US/kb/enable-drm

more options

guigs2 said

I tested a twitch channel and the volume showed up for a Window 7 vm with the former version of Flash installed. I also tried these settings in Flash Global settings:
  • Clear the browsing cache in Advanced
  • Clear the storage after I updated

I did the flash global settings, like instructed, and the problem is still the same.

The speed increased, but I never had any issue with the sound.I also understand that none of these tried, but did anything change?

I tried to do everything in these 2 links again. Problem is the same, and I didn't notice any changes, even if I try other twitch channels that were streaming at the time.

Does the twitch player use the DRM plugin? Check to see if this is enabled: https://support.mozilla.org/en-US/kb/enable-drm

It is enabled when I checked, I also tried disabling it and results did not change. Video still played without no audio.

more options

Valgt løsning

I think I have found the problem. Turns out it wasn't the Firefox. I found out that it was my headset. I use a Logitech G35, there was volume in youtube but not other flash player on other website.

I found this out when I used earphones and switched the playback from my G35 to Realtek HD Audio.

The problem is still there, but now I know it is my headset that is the problem. I'll just have to play around with settings more.