X
Tryk her for at gå til webstedets mobilversion.

Supportforum

Firefox crash on youtube. Safe mode works, reinstall doesn't

Skrevet

I've been having a lot of trouble with youtube in FF on and off for a while now. I noticed if I run FF in safe mode, it works without any problem, but normally playing a youtube vid (even embedded in another site) can cause my display driver or even my pc to crash. My driver is fully updated, and was reinstalled cleanly. I tried refreshing FF and it didn't help. I uninstalled FF completely, even manually erasing any trace of any file/folder that had firefox or mozilla in it. Reinstalled and still the same problem continues.

Any suggestions?

I've been having a lot of trouble with youtube in FF on and off for a while now. I noticed if I run FF in safe mode, it works without any problem, but normally playing a youtube vid (even embedded in another site) can cause my display driver or even my pc to crash. My driver is fully updated, and was reinstalled cleanly. I tried refreshing FF and it didn't help. I uninstalled FF completely, even manually erasing any trace of any file/folder that had firefox or mozilla in it. Reinstalled and still the same problem continues. Any suggestions?

Yderligere systemdetaljer

Installerede plugins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.9
  • Foxit Reader Plug-In For Firefox and Netscape
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • Unity Player 3.5.6f4
  • VLC media player Web Plugin 2.1.3
  • NPWLPG

Program

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

Yderligere information

Luk
FredMcD
  • Top 10 Contributor
4245 løsninger 59390 svar

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''
FredMcD
  • Top 10 Contributor
4245 løsninger 59390 svar

One of your add-ons may be the trouble maker.

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective

One of your add-ons may be the trouble maker. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Disable a few add-ons, then '''Restart Firefox.''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All of them.''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective
cor-el
  • Top 10 Contributor
  • Moderator
17467 løsninger 157838 svar

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

Also make sure that you have the latest updates of the graphics display driver.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Also make sure that you have the latest updates of the graphics display driver. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Spørgsmålsstiller

Its an HTML5 player not flash one, although it happened with the flash player as well. Hardware acceleration on/off doesn't help, and like i already said all my drivers are updated.

Also like i said, i refreshed FF, so I have no extention, no themes, no nothing. Besides Plugins, which some I can't uninstall, its as clean as it can possibly be.

Its an HTML5 player not flash one, although it happened with the flash player as well. Hardware acceleration on/off doesn't help, and like i already said all my drivers are updated. Also like i said, i refreshed FF, so I have no extention, no themes, no nothing. Besides Plugins, which some I can't uninstall, its as clean as it can possibly be.
FredMcD
  • Top 10 Contributor
4245 løsninger 59390 svar

You could try disabling Flash plugin's protected mode. The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this: (A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste flash and pause while the list is filtered (C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.


1) Enter the config by typing about:config in the address bar. 2) Enter media.mediasource.webm.enabled and press enter. 3) Right click on it and change to true, for some reason it is set as "false" which makes MSE & WebM VP9 not work properly. 4) Visit: https://www.youtube.com/html5 and check that everything is OK. 5) Try to watch a video. It should work now.

You could try disabling Flash plugin's protected mode. The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a new hidden setting for this: (A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste flash and pause while the list is filtered (C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox. ------------------------------------- 1) Enter the config by typing about:config in the address bar. 2) Enter media.mediasource.webm.enabled and press enter. 3) Right click on it and change to true, for some reason it is set as "false" which makes MSE & WebM VP9 not work properly. 4) Visit: https://www.youtube.com/html5 and check that everything is OK. 5) Try to watch a video. It should work now.

Spørgsmålsstiller

well I tried enabling MSE & WebM VP9 like you said, and its like it makes it work on every other vid.... I try a random vid and it seems to work fine, then i go to my sub-box and try a vid there, and it crashes before it even loads a single frame.... :(

well I tried enabling MSE & WebM VP9 like you said, and its like it makes it work on every other vid.... I try a random vid and it seems to work fine, then i go to my sub-box and try a vid there, and it crashes before it even loads a single frame.... :(
FredMcD
  • Top 10 Contributor
4245 løsninger 59390 svar

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.