Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Using webrtc no sound is recorded on Windows 8.1

  • 6 svar
  • 4 har dette problem
  • 370 visninger
  • Seneste svar af Ascarion

more options

Trying to use webrtc on either Firefox Hello or another website making use of webrtc features (such as https://tokbox.com/opentok/quick-start/demo.html) for communication will make Firefox show the dropdown to select a microphone and authorize it's use. The connection is established just fine, I can hear other people talk (or myself if I connect with another browser), but my own microphone is not picked up. I am very confident that my windows settings as well as those in driver's application are correct, but I'm happy to try aynthing out.

I'm thankful for any help you can provide.

Valgt løsning

After the problem persisted with Windows 10 and FF 40, I completely deleted the sound-drivers several times and re-installed them and it now works.

Thanks for your help!

Læs dette svar i sammenhæng 👍 0

Alle svar (6)

more options

Can you try your audio on the page I've given below? Its a test page and will echo the audio back to you in real time.

When you click a button, e.g. Audio, do you then get the permission prompt with your microphone listed? Note that depending on your setup, there may be more than one microphone listed so you might have to select the right one.

https://mozilla.github.io/webrtc-landing/gum_test.html

more options

Thanks for your reply.

Yes, I do get the permission prompt as usual. However no matter which input device I select (which are my microphone and stereo mix), there is no sound other than a short noise bump in the beginning sometimes (not always).

I've made a short demonstration here: https://youtu.be/rGeQDdkq-Dc

Ændret af Ascarion den

more options

Unfortunately the problem persists with 38.0

more options

Can you check what the sample rate of the input device is set to?

If you go into the Sound part of the control panel, select Recording, and then Properties on the default mic you'll get a properties dialog up.

On the properties dialog, go to Advanced, and check what the Default Format is.

Check that the Hz is either 48000Hz or less (the channel and bits shouldn't matter).

Please let us know if that helps or not.

more options

It was already set to 48000 Hz, which should be the default setting, so unfortunately that didn't help.

more options

Valgt løsning

After the problem persisted with Windows 10 and FF 40, I completely deleted the sound-drivers several times and re-installed them and it now works.

Thanks for your help!

Ændret af Ascarion den