Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"This Connection is Untrusted" - My PC clock is correct, but...

  • 8 svar
  • 18 har dette problem
  • 3983 visninger
  • Seneste svar af FredMcD

more options

Earlier today, my PC clock set itself to tomorrow's date. I fixed it, didn't think anything of it. It is currently correct.

Now, I'm getting the "This Connection is Untrusted" on every site. If I change the PC clock to the INCORRECT date of tomorrow, it will start working again. My BIOS clock is correct.

The only thing I can think of that I've done between when Firefox was last working and now install Origin. I don't recall if it stopped working immediately after I set the clock to the correct date (I usually work in another browser save for a few sites -Opera, by the way, has no problems).

I'm stumped. Also, if it's relevant, I literally built this PC yesterday, clean installs of everything.

Valgt løsning

The error given is that the issuer certificate has expired (but it doesn't give a specific date).

(Error code: sec_error_expired_issuer_certificate)

Aha! It was issued by Avast... I disabled the HTTPS scanning and it worked! I don't know why it's having issues, I will still look around, but for now, I have a solution.

Thanks for your help, everyone who replied!

Læs dette svar i sammenhæng 👍 2

Alle svar (8)

more options

Check your clock again, but also check where the computer thins you are.

more options

I've checked many times (I thought I was going nuts), both manually and by having it sync with the Internet. The time zone is correct.

Oh, and I did a quick web check to see where Google thinks I'm located (in case that's what you meant). It doesn't have the right city, but it is in the right state (and same time zone).

Ændret af Awkward den

more options

I'm having this exact same problem, right down to "my usual browser Opera has no problems" - see my question here: https://support.mozilla.org/en-US/questions/1040604

Oh, well, I built the computer Wednesday, not Thursday, but other than that. I didn't install Origin though, so that's not it.

I'm stumped, unless someone here comes up with something I'm currently planning to wait until it's tomorrow and see if that fixes it.

Ændret af secatn den

more options

Hi Awkward, if the problem mainly affects sites you've visited before, could you try renaming Firefox's certificate store file, cert8.db, so Firefox starts a new one? Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename cert8.db to something like cert8.old (note: if your Windows does not show the .db extension, you can turn on display of file extensions following the steps in this article: http://windows.microsoft.com/en-us/wi.../show-hide-file-name-extensions)

Start Firefox back up again. Can you visit secure sites more normally?


I'm not familiar with Origin. Does it affect how you connect to the internet, in particular, does it proxy your connection or include anything like a private VPN? You can review and experiment with your Firefox connection settings here:

"3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

The default setting of "Use system proxy settings" should piggyback on the Windows/IE LAN settings. You could try "No proxy" and see whether that makes any difference.

more options

Hi, jscher2000

Thanks so much for the very detailed response. I tried everything you suggested, and I'm still getting the same messages.

I also made sure to visit a couple sites I know I hadn't before, and I am able to get to those. Unfortunately, the essential ones (like Google and Gmail and Outlook) are all still problematic.

I honestly don't know much about Origin, it's a game client like Steam, but I don't know many details.

I'm glad to hear I'm not the only one with the problem, but it still baffles me. (And by glad, I mean that I'm more likely to find an answer, I hope)

Ændret af Awkward den

more options

On the error page for one of those sites, if you expand the Technical Details section, what is the explanation given? Usually there is a code in parentheses toward the end of the description.

Does the page display the "I understand the risks" section which has an Add Exception button? I don't recommend adding an exception just yet, but if you start the process, you can inspect the certificate to see whether there's anything unusual about it. In the Add Exception dialog, click View (if View is grayed, click Get Certificate first). Then check the "Issued by" section and post what you find there (e.g., for google.com or login.live.com, etc.).

more options

Valgt løsning

The error given is that the issuer certificate has expired (but it doesn't give a specific date).

(Error code: sec_error_expired_issuer_certificate)

Aha! It was issued by Avast... I disabled the HTTPS scanning and it worked! I don't know why it's having issues, I will still look around, but for now, I have a solution.

Thanks for your help, everyone who replied!

more options

That was very good work. Well Done.