Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My firefox is blocking every website accusing them of having false certificates and I can't access anything (Even google!!)

  • 11 svar
  • 8 har dette problem
  • 47 visninger
  • Seneste svar af FredMcD

more options

The title basically says everything. Everything worked fine in my old computer, now I bought a Lenovo Y50-70 with Windows 8.1, and firefox is just COMPLETELY messed up!

It even blocks websites like Google, Mozilla!!!!, youtube, gmail, everything I use daily! I need a way to COMPLETELY deactivate this thing that blocks webpages through certificate failures, I want it to be off!!! I REALLY do not want to give up on firefox, it used to be amazing, but I can't fix this... Can anyone tell me how to deactivate this blocking????

Here is a screenshot of firefox blocking Google.com: http://i.gyazo.com/fd265a483c7031873d1db2d3b3fa7039.png

The title basically says everything. Everything worked fine in my old computer, now I bought a Lenovo Y50-70 with Windows 8.1, and firefox is just COMPLETELY messed up! It even blocks websites like Google, Mozilla!!!!, youtube, gmail, everything I use daily! I need a way to COMPLETELY deactivate this thing that blocks webpages through certificate failures, I want it to be off!!! I REALLY do not want to give up on firefox, it used to be amazing, but I can't fix this... Can anyone tell me how to deactivate this blocking???? Here is a screenshot of firefox blocking Google.com: http://i.gyazo.com/fd265a483c7031873d1db2d3b3fa7039.png

Alle svar (11)

more options

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

more options

What security software (firewall, anti-virus) do you have?

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer of the certificate.

You can see more Details like intermediate certificates that are used in the Details pane.

  • Note that some firewalls monitor (secure) connections and that programs like Sendori or FiddlerRoot can intercept connections and send their own certificate instead of the website's certificate.
  • Note that it is not recommended to add a permanent exception in cases like this, so only use it to inspect the certificate.
more options

The time / date settings are all correct, so that isn't problably the issue.

In terms of firewall and anti virus. The firewall is the default windows one that comes with windows 8.1. I tried 2 anti virus and it happened with both of them, being them bit defender and Avast. And Firefox even blocks Mozilla website saying its certificate can't be verified! I have no idea what to do, really, I already tried every option I found online. Isn't there just a way to stop Firefox from blocking websites and checking certificates? I am willing to risk my security in return of being able to actually use Firefox! Any way to do that?

more options

Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

That didn't work, it was all updated, and from what I see, removing firefox from the firewall list of permitted software doesn't do anything, because firefox still seems to run normally, even though it shows everything as blocked... Adding it back again didn't do anything either. I am pretty sure, and once more, that there is only one solution here, which is to STOP firefox from checking certificates or all this stuff. How can I do that?

Ændret af NepsName den

more options

hello NepsName, please follow cor-el's advice from above and inspect the issuer of the failing certificates - it is likely that some third-party program is interfering with secure connections which is causing those errors. from there on we could give you more detailed advice...

more options

Ok, here are 2 images of what I got. Unfortunately it is in portuguese, and I tried but didn't manage to change it to english, I hope you can still get the information you need.

1º: http://i.gyazo.com/91f6acbb368187e3ae9044d4ee4a4d7d.png 2º: http://i.gyazo.com/ee165bc5e1fa2dd86773d24982286067.png

What now?

more options

Ændret af cor-el den

more options

Is that a virus? How can I possibly have it if this pc is brand new and all I installed was firefox? Anyway, I will try to remove it then.

more options
more options

Pre-installed mal-ware - - - - Wow - - - - What will they think of next ?