Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hi, thank you for get me signed in - at last. Now, after updating to the latest Firefox I can't play any videos. Addons & pluginns all activated and up to date.

  • 4 svar
  • 2 har dette problem
  • 67 visninger
  • Seneste svar af juanverano

more options

Hello, I was struggling to sign in into the Support site yesterday and while this problem was dealt with I was adviced to upgrade to the latest version of Firefox since the system noticed I was using an old one. I was using Firefox 33 with no problems or major issues at all. Nevertheless I went ahead with the update, which gave me version 34.0.5. So good so far until I went to play some of my usual TV series, which I had been following with the previous version, only now it would not play at all.

I know these TV series, comming from abroad might contain some harmful content to my machine or others, but I am well covered and as I say earlier they were playing fine in the previous version of Firefox. Just earlier the same day.

I'll be grateful if you could shed some ideas into this.

Regards

J.Verano

Valgt løsning

HI Juanverano, Not a problem, Safe Mode will disable addons and hardware acceleration. If this continues and it is not an add on this will be the next step to try to disable acceleration:

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
    • In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Læs dette svar i sammenhæng 👍 1

Alle svar (4)

more options

Please try disable Flash block to make sure that there is not interference with you default video player. To check to make sure that there is not another add on causing this as well please try Troubleshoot Firefox issues using Safe Mode to see if it is an add on.

more options

Hello,

Thank you for your prompt reply. Although it seemed to work initially as soon as I disabled the Flash Block extension, it was short-lived and mostly in Chrome. I also tried troubleshooting in Safe Mode, but only worked in Safe Mode.
I finally decided to Reset Firefox (for the second time in 3 days) and this is where I am.
Many thanks again for your interest and patience and for setting me up in the right path.
Best regards
J.V.
more options

Valgt løsning

HI Juanverano, Not a problem, Safe Mode will disable addons and hardware acceleration. If this continues and it is not an add on this will be the next step to try to disable acceleration:

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
    • In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

Hello, Well, yes. Although I could not pin point which one of all my extensions was causing the problem it looks like I'm back to normal with Firefox. I am so relieved... and it looks so much faster to me! I don't know. Maybe Chrome was making wait too long for everything. Well, that's done and thank you again.

J. V.