Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Neither "Bookmark this page" nor "Edit Bookmarks" appears in the Bookmarks dropdown menu. How do I restore it/them?

  • 17 svar
  • 2 har dette problem
  • 543 visninger
  • Seneste svar af franknlyn

more options

"Bookmark this page" disappeared from the Bookmarks dropdown menu after I added a bookmark. The help pages I have consulted say that "Bookmark this page" is sometimes replaced by "Edit bookmarks" but I have never seen this choice.

Valgt løsning

Yesterday, after not thinking about this problem for a couple of weeks, I wanted to create a bookmark. On automatic pilot, I clicked on “Bookmarks.” Lo and behold, “Bookmark This Page” was one of the choices on the dropdown list.

Perhaps the lesson is that if you ignore a problem for a while, it may go away on its own.

In any event, thanks to all who offered their help.

Læs dette svar i sammenhæng 👍 0

Alle svar (17)

more options

That is odd, are your bookmarks at least still intact? Do you have the bookmarks button in your 3 bar menu?

  • New Fx Menu > Bookmarks, or if it is not there, click Customize

What happens if you run in Safe Mode?Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

What bookmarks drop-down list do you mean? This "Bookmark This Page" item will only appear in the Bookmarks menu drop-down list on the Menu Bar and not in the list that opens if you click the "Show your bookmarks" icon next to the star on the Navigation Toolbar to bookmark the current tab. That star has a tooltip to show its current action and if highlighted changes to "Edit this bookmark".

You can click the highlighted star on the Navigation Toolbar instead to edit the bookmark.

more options

I am referring to the Bookmarks menu on the drop-down list on the Menu Bar.

I am able to use the star on the Navigation Toolbar to create a bookmark. Nevertheless, I would still like to get “Bookmark this page” back on the drop-down list.

more options

My bookmarks are intact. There is no Bookmarks button on my 3-bar menu and no such button is offered as a choice when I click on Customize. (Seven choices are offered: Open file, Sidebars, Subscribe, Character encoding, Email link, Sync, and Tab group.)

My problem is still present when I run in Safe Mode.

more options

The toolbar button doesn't have Bookmark This Page because it has the star button just to the left of it, which is very similar. The main difference is that the star button defaults to saving a new bookmark under Unsorted Bookmarks instead of on the Bookmarks Menu.

Your alternative ways to call up the classic Bookmark This Page dialog are:

  • Ctrl+d
  • right-click the page > Bookmark This Page star icon (avoid links, images, and form fields which have different right-click menus)
  • use the Bookmarks menu on the classic menu bar (if you display it)

Edit: Forgot about the recent change to the star icon on the right-click context menu

Ændret af jscher2000 den

more options

What do you see in the Bookmarks menu?

Does it make a difference of what is shown (it should) if you open the Bookmarks menu with the mouse or use the Alt+B shortcut?


You can try to reinstall Firefox in case something has gone wrong with an update.

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.


more options

This does not address my problem/question. Until two days ago, Bookmark This Page appeared on the dropdown menu when I clicked Bookmarks on the menu bar. Now it does not. How do I restore it? (I know how to create bookmarks by other means. Still, I would like to get Bookmark This Page back on the dropdown menu.)

more options

The only difference is that Bookmark All Tabs (= Ctrl+Shift+D) appears (but is grayed out) with Alt+B and does not appear at all with clicking on Bookmarks on the menu bar. In neither case does Bookmark This Page appear.

I am glad to have detailed instructions on uninstall-reinstall and will use them if I have to, but I am still hoping to find a way to restore the Bookmark This Page without going through uninstalling and reinstalling.

more options

Do you use any extensions that might be altering the menu? I'm not sure whether you ruled that out by trying the Safe Mode test.

Firefox's Safe Mode also would deactivate any custom style rules you might have created in a userChrome.css file, so if the item reappears in Safe Mode, that would be another thing to check in addition to extensions.


The chameleonic nature of "Bookmark All Tabs" has caused puzzlement before. My understanding it that since Bookmark All Tabs is available on the right-click context menu for each tab, it is not duplicated on the menu bar's Bookmarks Menu when you access it using the mouse. However, since there's no keyboard shortcut to right-click a tab, Bookmark All Tabs is added to the Bookmarks Menu for keyboard shortcut users.

more options

My question deals with “Bookmark This Page”, not with “Bookmark All Tabs.”

How do I tell what extensions (or, for that matter, custom style rules) I am using and which ones Safe Mode disables and which it doesn’t? I don’t remember adding any. (I hadn’t even heard of custom style rules.) Could some have been added without my permission?

more options

Hmm, sorry about responding to your comment about Bookmark All Tabs, I certainly didn't mean for you to think I had gotten confused about your question.

You can view any extensions you currently have installed on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions.

Regarding custom style rules, it is unlikely you have them if you didn't install them.

more options

My only extension is the Norton toolbar. Safe Mode disables it. My problem is still present when I run in Safe Mode.

more options

Do you see the other customary top-of-menu items (example screen shot from this page attached)? Note that the Bookmarks menu scrolls vertically, so if other top items are missing, try using either the scroll wheel or the very tiny triangle at the top to scroll it back up.

more options

The other top-of menu items are at the top. Scrolling all the way down does not help. “Bookmark This Page” is not present.

more options

"Bookmark This Page" should be present in the Bookmarks menu drop-down list, but you won't find it in the drop-down list of the "Show your bookmarks" button that is located next to the bookmarks star on the location/address bar as that star button has that create and edit action (check their tooltip on hover).

more options

I'm running out of ideas. Normally menu items do not simply disappear.

Sometimes the file that stores window layout and toolbar visibility information becomes corrupted with strange results. You can rename the file to see whether that helps.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button to launch a Windows Explorer file list

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename localstore.rdf to something like localstore.old

Start Firefox back up again. You can redisplay the Menu Bar using any of these methods:

  • right-click a blank area of the tab bar > Menu Bar
  • right-click the "+" button on the tab bar > Menu Bar
  • display the menu bar temporarily by tapping the Alt key, then View > Toolbars > Menu Bar
  • "3-bar" menu buttons > Customize, then "Show/Hide Toolbars"

Any improvement in the Bookmarks Menu?

more options

Valgt løsning

Yesterday, after not thinking about this problem for a couple of weeks, I wanted to create a bookmark. On automatic pilot, I clicked on “Bookmarks.” Lo and behold, “Bookmark This Page” was one of the choices on the dropdown list.

Perhaps the lesson is that if you ignore a problem for a while, it may go away on its own.

In any event, thanks to all who offered their help.