Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

more options

I wish I knew why Firefox has been crashing, but even in Safe Mode it dies. Here's what I do know:

1) Firefox was running fine in Fedora 17. Very rarely a crash even with 30 windows and 100+ tabs on multiple desktops.

2) I upgraded (as in: new install, but same home directory) from Fedora 17 to Fedora 20. No new hardware. Constant crashes - sometimes multiple times per hour. Sometimes multiple times per minute. Sometimes, crashing immediately on 'restart' of session while opening all my tabs back up & I have to do this a few times to get it working... usually, once it's up, it stays running for an hour or two.

3) Reduced windows to 12-15, and tabs to ~30. No effect.

4) Tried creating a new profile; tried different desktop environment (Cinnamon vs Gnome); tried uninstalling Flash plugin, other plugins, and then tried Safe Mode. Crash, crash crash.

I'm kind of at my wit's end. Fedora 20 is updated with latest packages. I am using the Nvidia proprietary drivers, but it crashes even in "Safe Mode", so hardware accel shouldn't be the cause.

I can run memtest86+ (which could take quite a while on a 16G RAM machine), but it would be quite a coincidence that I would have a memory failure right at the time I upgraded to Fedora 20, would it not?

Alle svar (20)

more options

In the address bar, type about:crashes. Note: If the report does not have BP in front of the numbers, click it and select Submit.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

more options

bp-718572e2-32c0-4bdc-8fc1-337562140919 09/19/2014 11:38 AM bp-dc733561-d3e9-4160-aea6-3a6a62140919 09/19/2014 10:01 AM bp-5137999b-8eb7-4620-b15e-f8e0c2140919 09/19/2014 09:49 AM bp-54bea4b3-3f4f-4357-9003-798b72140919 09/19/2014 09:48 AM bp-fc90cd5b-d600-48fa-8ee7-84f5a2140919 09/18/2014 07:42 PM bp-373e69ae-db4d-4194-baea-d2ef72140919 09/18/2014 07:19 PM bp-987d55c5-db2b-4648-947e-adfb92140918 09/18/2014 04:23 PM bp-204f99df-c75c-41fb-8326-e728e2140918 09/18/2014 04:21 PM bp-1259ed2d-9351-476e-8ea7-eb4312140918 09/18/2014 04:14 PM bp-bc7578ed-17fa-4f80-b619-c3fda2140918 09/18/2014 04:02 PM bp-b769d984-5c88-4280-9c62-7d2b12140918 09/18/2014 04:02 PM bp-2053c17d-6c74-4626-ab05-77a962140918 09/18/2014 04:02 PM bp-1d7106fa-021c-4f7d-ab68-adeff2140918 09/18/2014 03:41 PM bp-b9d35e0a-60e8-4e7d-9150-035a22140918 09/18/2014 03:11 PM bp-5db143af-ba3b-44b3-b80b-cf5bc2140918 09/18/2014 03:11 PM bp-dc411f4b-9690-46d7-b76a-5dcad2140918 09/18/2014 02:13 PM bp-f43e0b82-b1c5-4b7a-98a2-42d362140918 09/18/2014 02:06 PM bp-898ead7b-2a22-44ef-9d47-df5572140918 09/18/2014 02:05 PM bp-9b89a892-290e-4a90-96ac-3d08d2140918 09/18/2014 01:54 PM bp-e218228a-cce3-4ddd-9d1f-9bd782140918 09/18/2014 01:39 PM bp-89e4d1be-2941-43a8-b077-6da252140918 09/18/2014 11:54 AM

more options

Thanks for your reply!

more options

The crash reports say your problem is caused by;

libxul.so libgtk-x11-2.0.so libgobject-2.0.so libglib-2.0.so

Bing Search; http://www.bing.com/search?q=libxul.so

I don't know what they are for.

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences in the address bar and press enter

Select Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

libxul.so is the main Firefox file (on Windows xul.dll), so that doesn't mean much.

Try a clean reinstall and remove the Firefox installation directory.

You can find the full version of the current Firefox 32.0.1 release in all languages and for all Operating Systems here:

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

I did the above, and here are my subsequent crashes:

bp-e9ea20ae-9c7d-4595-9302-17b4c2140920 09/19/2014 05:49 PM bp-7caa76dd-9038-4947-9fe1-53a022140920 09/19/2014 05:47 PM bp-5c73f635-84f1-4354-9e60-145002140920 09/19/2014 05:46 PM bp-585a5a82-b2ca-4a56-8ebd-3ac632140920 09/19/2014 05:34 PM bp-86b58f95-7832-4d6d-8abf-730962140919 09/19/2014 03:30 PM bp-01795079-acc0-4478-8016-a7e432140919 09/19/2014 03:09 PM bp-101d5f48-a0a8-4ebf-89c8-3deb12140919 09/19/2014 02:50 PM

more options

To clarify, I did the turn off hardware accel and run in safe mode, and the above were my subsequent crashes.

Regarding the profile, I'm already running on a new profile which I created when i started experiencing crashes in Fedora 20 (mentioned in my initial problem report). I did not delete the directory, or uninstall-reinstall Firefox. I have experienced this problem through at least 1-2 Firefox updates via the YUM repository.

Should I still delete (move off) the .mozilla directory - is that going to address more than a new profile? Are there any other directories that need to be 'cleaned'?

more options

The new reports look like the others.

Found something

Crash Reason SIGSEGV


more options

OK, so I have since tried the following:

  • created a new UserID and logged in with everything at defaults, still crashes, though it seemed to crash less frequently (I had fewer windows open). I tried installing Adobe Flash and that crashed often, so I removed it.
  • ran memtest86+ for 12 hours, no errors. I can try running it longer but I needed to get work done.

It still crashes regularly - extremely often.

What can I do?

more options

Please post new crash reports. Maybe one of them will tell us something.

Start your Computer in safe mode. Then start Firefox. Try Safe web sites.

more options

I posted a lot of crash reports above & my computer runs Linux.

more options

You could try the Firefox version from the Mozilla server.

You can find the full version of the current Firefox 32.0.3 release in all languages and for all Operating Systems here:

more options

OK, I tried the latest Firefox version 32.0.3 - I disabled all extensions except for Session Manager (kind of necessary given the constant crashes).

Still crashing.

more options

In the address bar, type about:crashes. Note: If any reports do not have BP in front of the numbers, click it and select Submit.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

more options

bp-62cb0657-f7a5-4056-aa73-5e72b2141008 10/08/2014 02:03 PM bp-17794f7a-1c6b-48f6-9c31-faf0e2141008 10/08/2014 01:18 PM bp-9e4a8341-1add-484a-af5b-d346a2141008 10/08/2014 01:17 PM bp-033f9295-1bb1-4fca-9078-be9842141008 10/08/2014 10:40 AM bp-33f4e65c-3abe-491e-ae0c-cceb72141008 10/08/2014 10:15 AM bp-44b43cbc-c2f0-4956-a749-519bf2141008 10/08/2014 10:04 AM bp-1b2b6130-17f8-466e-8f1d-0af622141008 10/07/2014 05:22 PM bp-5f11b38f-a61e-4981-88f7-5dfdb2141008 10/07/2014 05:10 PM bp-3e9f9331-7a54-4588-944d-48e002141007 10/06/2014 10:05 PM bp-dd2e7d37-cfcf-4611-94cd-8d3062141007 10/06/2014 07:06 PM bp-35f2eb8c-f709-49dc-8e15-987662141007 10/06/2014 07:05 PM bp-0ad612d1-3783-4832-90ca-d3e712141007 10/06/2014 06:09 PM bp-366e304a-91e9-477c-907f-7dcb42141007 10/06/2014 06:06 PM bp-deb88941-d095-4369-8b22-e1b8f2141007 10/06/2014 06:01 PM bp-66594b43-3083-453c-9501-9ea882141007 10/06/2014 05:48 PM bp-d6d51ef2-e3ac-4da4-b7ed-621202141007 10/06/2014 05:43 PM bp-4d97b098-c19d-4ae4-b000-ac6d72141007 10/06/2014 05:41 PM bp-79aa2def-f8de-4239-a8b6-3e5e42141006 10/06/2014 04:39 PM bp-8e2ddea4-d644-4d12-a495-2a6ff2141006 10/06/2014 04:20 PM bp-26da6c5e-fb59-4deb-b6bf-76eda2141006 10/06/2014 04:10 PM bp-dc7ca916-8b4e-46e7-a222-c64202141006 10/06/2014 03:52 PM bp-2060708f-7e56-4211-82a3-41a672141006 10/06/2014 03:39 PM

more options

All of the reports are the same

Crash Reason SIGSEGV

I don't know what it means.

It also talks about;

libgtk-x11-2.0.so.0.2400.24 libxul.so libglib-2.0.so.0.3800.2

more options

So this is very much unresolved. I have to say it really must be a software issue.

After experiencing another 4-5 crashes in a two-hour period this morning I frustratingly booted into my old Fedora 17 disk and ran the old version of Firefox I had been using... Flawless, no issues all day thus far, all plugins enabled/working. There is no way my combination of Fedora 20 and the latest Firefox would have not crashed yet today, even with all plugins/extensions disabled.

Pulling my hair out guys. I can't stay on this old version of Fedora - it's no longer maintained. What can I do?

more options

Thanks for hanging in there. This sounds quite crazy.

First I'd recommend you install the official version of Firefox over the distro version. Just to see if there's any difference.

Link: https://download.mozilla.org/?product=firefox-32.0.3-SSL&os=linux&lang=en-US

Please check out this bug as well: https://bugzilla.mozilla.org/show_bug.cgi?id=986735#c4

Apparently a old version of the Google talk plugin is causing Firefox to crash on various linux distros. It's in the .mozilla/plugins directory. Deleting that plugin did the trick to fix the constant crashes.

If you have this file, please record the exact version number of the file. We can ask Mozilla to blocklist this plugin to prevent crashes for everyone. If you can send me a copy of the file, I can give it to the developers. Email: mozsupport@gmail.com

Also could you run an strace to see what file is causing the crash?

To run a strace (Thanks to David Eccles from the above bug): My general advice to others who are having similar issues relating to firefox/iceweasel crashing on startup would be to run strace and then look at the last few lines to see if anything looks odd:

$ strace firefox 2> firefox_strace_$(date +%Y-%b-%d_%H:%M:%S).txt

[date/time included so that you don't make the same mistake as I did and overwrite 'fail' files with working ones]

more options

Thanks for your reply.

If you scroll up a few entries you'll see I did try the official version, latest (33) and experienced the same problem.

I have not seen that bugID. I will try strace and remove the Google talk plugin - though I did try disabling all plugins/extensions. Thanks for that & I'll report back my results.

more options

In Fedora 17 I find the googletalk plugin under /usr/lib64/firefox/plugins, but in Fedora 20 there is no such directory. Under /usr/lib64/mozilla/plugins I find the usual collection of plugins, but no googletalk plugin as before in FC17.

It does not exist in my ~/.mozilla/plugins directory, either. So, where is this now? Does FF look into Google Chrome's plugin directory to find it?

$ find . -name \*plugin\* |grep -i google ./.config/google-googletalkplugin ./.config/google-googletalkplugin/o1dplugin.log ./.config/google-googletalkplugin/gtbppapiplugin.log ./.config/google-googletalkplugin/gtbplugin.log ./.config/google-chrome-off/Default/Extensions/gbchcmhmhahfdphkhkmpfmihenigjmpp/37.0.2062.61_0/plugin_settings.js ./.config/google-chrome-off/Default/Extensions/gbchcmhmhahfdphkhkmpfmihenigjmpp/37.0.2062.61_0/client_plugin.js

  1. 1
  2. 2