Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Flash Player crashes after recent update to Firefox 32

  • 34 svar
  • 145 har dette problem
  • 6827 visninger
  • Seneste svar af jscher2000

more options

After recent update to Firefox 32, Flash player crashes frequently whenever i open any flash video. I have latest Flash player installed (14).

I tried to uninstall Flash player and installed it again, also tried to instal flash player 15 beta and also tried to instal older flash player 13 but all in vain and problem is same.

Update: i have noticed that this problem occurs in Firefox only while lash Player works fine in Google Chrome..

Please help me to fix this problem.

Screenshot of the Error http://imgur.com/fekGD5v

Ændret af askfriends den

All Replies (20)

more options

Try disabling hardware acceleration in flash

The Flash plugin could be crashing because of an extension, theme or hardware acceleration in Firefox. To see if one of these is causing the problem, go through the steps in the article

https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

https://support.mozilla.org/en-US/kb/keep-flash-up-to-date-and-troubleshoot-problems

more options

This doesn't work although hardware acceleration was checked and i unchecked it and restarted my browser. here is the error that i get frequently in screenshot http://imgur.com/fekGD5v

more options

Update your Shockwave Flash v14.0 r0 http://get.adobe.com/shockwave/ The link for Flash Player v14.0.0.179 http://get.adobe.com/flashplayer/

more options

Unresponsive script errors with Flash can be related to the protected mode feature of the Flash plugin. That feature has security benefits, but is not compatible with all systems for some reason. You can disable it by creating or editing a settings file.

The following pages/posts provide different approaches for that:

Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.

more options

@FredMcD I have latest Flash player installed

more options

@jscher2000

Protected mode is disabled.

i have noticed that this problem occurs in Firefox only while lash Player works fine in Google Chrome..

more options

Hi askfriends, are you getting the Mozilla Crash Reporter? If you could provide some additional crash data that may help in identifying the problem.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and then go back to your forum question and paste that into the "Post a Reply" box. (Please don't take a screenshot of your crashes, just copy and paste the ID's. The below image is just an example of what your Firefox screen should look like)

aboutcrashesFx29 If the numbers do not start with bp- then please click them to view the page on the crash stats server, then copy/paste the URL from the address bar into your reply.

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

more options

Your System Details shows;

Installed Plug-ins Shockwave Flash 13.0 r0

Did you upgrade after posting your question?

more options

@jscher2000

here is the complete list of crash reports, only one starts with bp-

bp-71ac7c86-ee12-4c59-a94b-c75292140903 03-Sep-14 11:39 PM a06dc019-fa61-487f-8967-2003ee433d92 02-Sep-14 11:46 PM 6fbcf5e1-76ed-494a-a69a-fe7eb2289ac3 27-Aug-14 1:20 PM a3e1dfd5-b37c-4fe2-aa29-1635aae0cd8e 27-Aug-14 1:20 PM f1cf4323-34a9-47f0-bb34-f7c5819baa08 18-Aug-14 12:59 AM

more options

@FredMcD

i updated flash player after posting troubleshoot info. here is the latest troubleshooting info

Application Basics


Name: Firefox Version: 32.0 User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: Adblock Plus Version: 2.6.4 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Google Translator for Firefox Version: 2.1.0.3m Enabled: true ID: translator@zoli.bod

Name: Greasemonkey Version: 2.2 Enabled: true ID: {e4a8a97b-f2ed-450b-b12d-ee082ba24781}

Name: IDM CC Version: 7.3.85 Enabled: true ID: mozilla_cc@internetdownloadmanager.com

Name: LastPass Version: 3.1.54 Enabled: true ID: support@lastpass.com

Name: Bitdefender Wallet Version: 2.0 Enabled: false ID: bdwteff@bitdefender.com

Name: Link Gopher Version: 1.3.3 Enabled: false ID: linkgopher@oooninja.com

Graphics


Adapter Description: Intel(R) Q45/Q43 Express Chipset (Microsoft Corporation - WDDM 1.1) Adapter Drivers: igdumd64 igd10umd64 igdumd32 igd10umd32 Adapter RAM: Unknown Device ID: 0x2e12 DirectWrite Enabled: false (6.3.9600.17111) Driver Date: 3-11-2013 Driver Version: 8.15.10.2702 GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic Vendor ID: 0x8086 WebGL Renderer: Google Inc. -- ANGLE (Intel(R) Q45/Q43 Express Chipset (Microsoft Corporation - WDDM 1.1) Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: false AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 3 browser.places.smartBookmarksVersion: 7 browser.sessionstore.restore_on_demand: false browser.sessionstore.upgradeBackup.latestBuildID: 20140825202822 browser.startup.homepage_override.buildID: 20140825202822 browser.startup.homepage_override.mstone: 32.0 browser.tabs.warnOnClose: false dom.max_chrome_script_run_time: 0 dom.max_script_run_time: 0 dom.mozApps.used: true extensions.lastAppVersion: 32.0 font.internaluseonly.changed: true gfx.direct2d.disabled: true gfx.direct3d.last_used_feature_level_idx: 1 layers.acceleration.disabled: true network.cookie.prefsMigrated: true places.database.lastMaintenance: 1410029979 places.history.expiration.transient_current_max_pages: 49391 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.timeSpan: 0 storage.vacuum.last.index: 0 storage.vacuum.last.places.sqlite: 1407136259

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.6 Version in use: 4.10.6

NSS Expected minimum version: 3.16.4 Basic ECC Version in use: 3.16.4 Basic ECC

NSSSMIME Expected minimum version: 3.16.4 Basic ECC Version in use: 3.16.4 Basic ECC

NSSSSL Expected minimum version: 3.16.4 Basic ECC Version in use: 3.16.4 Basic ECC

NSSUTIL Expected minimum version: 3.16.4 Version in use: 3.16.4

Experimental Features


more options

Upgraded the player, good.

Open a new window or tab. In the address bar, type about:crashes. If the report does not have BP in front of the numbers, click it and select Submit.

After, please post all the recent reports.

more options

Signature hang | ntdll.dll@0x3d2ec

Help link; http://www.computerhope.com/issues/ch000960.htm

more options

Start Firefox in Safe Mode {web link} While you are in safe mode; Press the Alt or F10 key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

more options

@FredMcD

here are reports

bp-8235a842-d644-4d15-947e-5c2312140906 07-Sep-14 1:06 AM bp-9734f730-78e3-4617-abce-3c2b82140906 07-Sep-14 1:06 AM bp-d1fd4e23-692b-4496-be6b-e689c2140906 07-Sep-14 1:06 AM bp-71ac7c86-ee12-4c59-a94b-c75292140903 03-Sep-14 11:39 PM bp-2ec03376-e2dd-4dba-b0c4-adef62140906 18-Aug-14 12:59 AM

more options

Hi askfriends, you wrote:

Protected mode is disabled.

But your two most recent crash reports show instances of FlashPlayerPlugin_14_0_0_179.exe.

Could you check the Windows Task Manager, Details tab (I think; prior to Win8 it was the Processes tab), to see whether you can find that EXE running there when you are using Flash in Firefox (only in Firefox).

If you find one or more instances of that EXE, then disabling the protected mode feature did not work. Since you have 64-bit Windows, make sure you are changing the mms.cfg file in this folder:

C:\Windows\SysWOW64\Macromed\Flash
more options

One of the crash reports talks about; ntdll.dll

http://www.computerhope.com/issues/ch000960.htm What is the ntdll.dll file? - Computer Hope

more options

i checked it and no any .exe instance is present when i play the video in firefox.

I want to make a point here that when i play video firefox memory in task manager continuously increases and reaches upto 600mb (i have 2gb in total)

more options

@FredMcD

so what does it do??

i am not developer or expert i am here to get my problem solved not to research for..

more options

Basically, the article says;

The ntdll.dll file is a file created by Microsoft

Users who are encountering an error with this file while in Microsoft Internet Explorer can often resolve the issue by removing any third-party add-ons


Have you tried using Firefox in safe mode? https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

more options

I've been having similar issues using Windows 7 and Windows 8.1. In about:config I set browser.disk.cache.enable to false and have not had any issues since. Is there a good reason to have this enabled? Firefox 32 seems to be running very nice with it set to false.

  1. 1
  2. 2