Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox can't play videos in site

  • 13 svar
  • 62 har dette problem
  • 72078 visninger
  • Seneste svar af ly_nguyen

more options

Firefox can't display videos on that site http://socialcam.com/ While the others browser( opera 22, chrome 33, ie 11) can. I tried to restart with add -on disable but no help .

Valgt løsning

Is Firefox using the Flash player or possibly the HTML5 media player?

Do you see the Shockwave Flash plugin context menu if you right-click?


If Flash isn't used the you can try to disable the HTML5 media player by setting these prefs to false on the about:config page.

  • media.directshow.enabled
  • media.windows-media-foundation.enabled
Læs dette svar i sammenhæng 👍 5

Alle svar (13)

more options

I'm sorry, Internet explorer 11 also can't display videos in this page ,maybe only chromium-based browsers can .

more options

Works well with my Firefox V.30  :) What's your Firefox Version ??

more options

v.30, too , I tried with safe mode but still can' t play video on that site .

more options

I also try to create new profile and still got : "error loading media:File could not be played ".

more options

With the last Firefox upgrade, some plugins are no longer enabled until you enable it.

Open the Add-ons Manager. Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Tools Then Add-ons

Hot key; <Control> (Mac: <Command>) <Shift> A)

On the left side of the page, select Plugins.

BTW; At the top right is a link to check your plugins.

Ændret af James den

more options

I checked all plugins and they all up-to-date and work normally. Just Firefox and IE 11 can't display videos at this site , not opera/chrome.

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need close and restart Firefox after toggling this setting.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check for problems with current Shockwave Flash plugin versions and try this:

See also:

more options

I tried unchecking the "Use hardware acceleration when available" box already and still has problem. My graphic driver(Intel integrated card) also up-to-day .

more options

Start Firefox in Safe Mode. {web link} While you are in safe mode, Poke around safe web sites and see if there is still a problem. Then restart.

more options

Valgt løsning

Is Firefox using the Flash player or possibly the HTML5 media player?

Do you see the Shockwave Flash plugin context menu if you right-click?


If Flash isn't used the you can try to disable the HTML5 media player by setting these prefs to false on the about:config page.

  • media.directshow.enabled
  • media.windows-media-foundation.enabled
more options

As I said before, I tried safe mode ,but no use. FredMcD, can you play some videos on that website ?

more options

The problem is like that :

more options

@ cor-el : I set it to false :media.windows-media-foundation.enabled and it works. Thank you much . I'll try to understand it in this topic https://support.mozilla.org/en-US/questions/982753