X
Tryk her for at gå til webstedets mobilversion.

Supportforum

I had Google as the default search engine when I used the address bar to search, but Yahoo has hijacked this function and I can't reset Google as default.

Skrevet

Firefox 29.0.01 Windows 8.1

There doesn't appear to be an easy way to reset the default search engine to be used in searches in the address bar. Am I missing something?

And also, why can Yahoo hijack this function, making itself the default search engine?

Firefox 29.0.01 Windows 8.1 There doesn't appear to be an easy way to reset the default search engine to be used in searches in the address bar. Am I missing something? And also, why can Yahoo hijack this function, making itself the default search engine?

Valgt løsning

Hi gcraighammond, I just noticed you had a problem right-clicking. To change the search engine, click with the left button directly on the icon and a list of search engine options should drop down.

Again, it doesn't work until you move the search box back to the toolbar AND exit out of customize mode.

Læs dette svar i sammenhæng 2

Yderligere systemdetaljer

Installerede plugins

  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Shockwave Flash 13.0 r0
  • Google Update
  • McAfee MSC FF plugin DLL
  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • 5.1.30214.0
  • VLC media player Web Plugin 2.1.3
  • McAfee MSS+ NPAPI Plugin
  • GEPlugin
  • McAfee Virtual Technician plugin
  • Intel web components updater - Installs and updates the Intel web components
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • NPWLPG

Program

  • Firefox 29.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
  • Support-URL: https://support.mozilla.org/1/firefox/29.0.1/WINNT/en-US/

Udvidelser

  • BetterPrivacy 1.68 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • Disconnect 3.14.0 (2.0@disconnect.me)
  • HTTPS-Everywhere 3.5.1 (https-everywhere@eff.org)
  • McAfee SiteAdvisor 3.6.6 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92})
  • NoScript 2.6.8.26 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • NoSquint 2.1.9 (nosquint@urandom.ca)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adblock Plus 2.6 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Grafik

  • adapterDescription: NVIDIA GeForce GTX 645
  • adapterDescription2:
  • adapterDeviceID: 0x11c4
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 5-19-2014
  • driverDate2:
  • driverVersion: 9.18.13.3788
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 645 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Ændrede indstillinger

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 6
  • browser.privatebrowsing.autostart: True
  • browser.sessionstore.restore_on_demand: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140506152807
  • browser.startup.homepage_override.buildID: 20140506152807
  • browser.startup.homepage_override.mstone: 29.0.1
  • browser.zoom.siteSpecific: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 29.0.1
  • font.internaluseonly.changed: True
  • font.size.variable.x-western: 20
  • gfx.direct3d.last_used_feature_level_idx: 0
  • keyword.URL: http://search.yahoo.com/search?fr=mcafee&type=A111US977&p=
  • mousewheel.withcontrolkey.action: 3
  • network.cookie.cookieBehavior: 1
  • network.cookie.lifetimePolicy: 1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1401319050
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npdeployjava: 0
  • plugin.state.npmcffplg: 2
  • privacy.clearOnShutdown.cookies: False
  • privacy.cpd.extensions-nosquint: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1399337208

Diverse

  • User JS: Nej
  • Tilgængelighed: Nej
Luk
jscher2000
  • Top 10 Contributor
8758 løsninger 71655 svar

Usually the address bar follows the search bar, using the search engine indicated by the icon at the left (typically Google's "g" icon). If the address bar diverges, there are two possible scenarios:

(1) DNS Service Provider diversion.

One word searches (e.g., chocolate, mozilla.org) are checked with your DNS service provider, usually your ISP, as possible server names. Some DNS providers honestly inform Firefox there is no such server, while others send back search results.

(2) Hijacked by an extension.

In your More System Details, I notice the keyword.URL setting includes "fr=mcafee". Could the McAfee SiteAdvisor extension be hijacking your searches??

You can review, configure, disable, and often remove extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions.

Usually the address bar follows the search bar, using the search engine indicated by the icon at the left (typically Google's "g" icon). If the address bar diverges, there are two possible scenarios: (1) DNS Service Provider diversion. One word searches (e.g., chocolate, mozilla.org) are checked with your DNS service provider, usually your ISP, as possible server names. Some DNS providers honestly inform Firefox there is no such server, while others send back search results. (2) Hijacked by an extension. In your More System Details, I notice the keyword.URL setting includes "fr=mcafee". Could the McAfee SiteAdvisor extension be hijacking your searches?? You can review, configure, disable, and often remove extensions on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions.
cor-el
  • Top 10 Contributor
  • Moderator
17519 løsninger 158412 svar

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes If you do not keep changes after a restart or otherwise have problems with preferences, see: *http://kb.mozillazine.org/Preferences_not_saved

Nyttigt svar

Reply to Jscher2000:

First, thank-you for responding.

I do not have a separate search bar. Only the address bar is shown, and using Firefox Customize then Show/Hide Toolbars only offers the Menu and the Bookmarks toolbars.

I have been using the same ISP and McAfee SiteAdvisor for many months now without this problem occurring.

One additional bit of data - I had a Yahoo page open at the same time I did the search that resulted in Yahoo hijacking my search engine. I don't think I have done a search with a Yahoo page open before this.

Reply to Jscher2000: First, thank-you for responding. I do not have a separate search bar. Only the address bar is shown, and using Firefox Customize then Show/Hide Toolbars only offers the Menu and the Bookmarks toolbars. I have been using the same ISP and McAfee SiteAdvisor for many months now without this problem occurring. One additional bit of data - I had a Yahoo page open at the same time I did the search that resulted in Yahoo hijacking my search engine. I don't think I have done a search with a Yahoo page open before this.
Hossain Al Ikram 4 løsninger 22 svar

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions and some Preferences.

  • Open websites will not be saved in Firefox versions lower than 25.

To Reset Firefox do the following:

For Firefox versions previous to 29.0:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" Button reset button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

For Firefox 29.0 and above:

  1. Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information.

Now, a new tab containing your troubleshooting information should open.

  1. At the top right corner of the page, you should see a button that says "Reset Firefox" Button reset . Click on it.
  2. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  3. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

Hello, The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. <br> '''Note''': ''This will cause you to lose any Extensions and some Preferences.'' *Open websites will not be saved in Firefox versions lower than 25. To Reset Firefox do the following: '''For Firefox versions previous to 29.0:''' #Go to Firefox > Help > Troubleshooting Information. #Click the "Reset Firefox"[[Image:Button reset]] button. #Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish. #Firefox will open with all factory defaults applied. '''For Firefox 29.0 and above:''' #Click the menu button [[Image:New Fx Menu]], click help [[Image:Help-29]] and select ''Troubleshooting Information''. Now, a new tab containing your troubleshooting information should open. #At the top right corner of the page, you should see a button that says "Reset Firefox"[[Image:Button reset]]. Click on it. #Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish. #Firefox will open with all factory defaults applied. Further information can be found in the [[Reset Firefox – easily fix most problems]] article. Did this fix your problems? Please report back to us! Thank you.
jscher2000
  • Top 10 Contributor
8758 løsninger 71655 svar

Hi gcraighammond, maybe I should call it the search box instead of the search bar. I have attached a screen shot showing what I mean.

Hi gcraighammond, maybe I should call it the search box instead of the search bar. I have attached a screen shot showing what I mean.

Nyttigt svar

Thank-you all for your responses.

cor-el your fix is a bit beyond my skill as computer user. I may try to wrap my mind around it again later, but for now it's like kryptonite to me.  :-)

jscher2000 thank-you for clarifying. It is what I figured you meant. I am attaching a screen shot of my Firefox options. I don't seem to be able to obtain that search bar. I CAN put the specialized McAfee safe search bar up there, but when I use it to search I get Yahoo results. Right clicking on it does not present a way to change the search engine provider. Am I missing the correct way to implement this field?

Hossain Al Ikram I'll probably bite the bullet and reset Firefox and then set up the extensions and preferences again. Unless someone can explain how to implement the search field described by jscher2000.

Too bad that Yahoo has decided to employ underhanded techniques to boost its search engine usage. I hope Mozilla can find a way to fix this, and to punish Yahoo.

Thank-you all for your responses. cor-el your fix is a bit beyond my skill as computer user. I may try to wrap my mind around it again later, but for now it's like kryptonite to me. :-) jscher2000 thank-you for clarifying. It is what I figured you meant. I am attaching a screen shot of my Firefox options. I don't seem to be able to obtain that search bar. I CAN put the specialized McAfee safe search bar up there, but when I use it to search I get Yahoo results. Right clicking on it does not present a way to change the search engine provider. Am I missing the correct way to implement this field? Hossain Al Ikram I'll probably bite the bullet and reset Firefox and then set up the extensions and preferences again. Unless someone can explain how to implement the search field described by jscher2000. Too bad that Yahoo has decided to employ underhanded techniques to boost its search engine usage. I hope Mozilla can find a way to fix this, and to punish Yahoo.
cor-el
  • Top 10 Contributor
  • Moderator
17519 løsninger 158412 svar

Try to click the Restore Defaults button at the bottom right corner of the Customize palette window.

Try to click the Restore Defaults button at the bottom right corner of the Customize palette window.
jscher2000
  • Top 10 Contributor
8758 løsninger 71655 svar

Hi gcraighammond, even though the search bar shows the McAfee icon, that most likely can be changed after you move it back to the toolbar and exit customize. Assuming it is Firefox's built-in search box, it simply shows the last search engine selected. Please give it a try.

Hi gcraighammond, even though the search bar shows the McAfee icon, that most likely can be changed after you move it back to the toolbar and exit customize. Assuming it is Firefox's built-in search box, it simply shows the last search engine selected. Please give it a try.
jscher2000
  • Top 10 Contributor
8758 løsninger 71655 svar

Valgt løsning

Hi gcraighammond, I just noticed you had a problem right-clicking. To change the search engine, click with the left button directly on the icon and a list of search engine options should drop down.

Again, it doesn't work until you move the search box back to the toolbar AND exit out of customize mode.

Hi gcraighammond, I just noticed you had a problem right-clicking. To change the search engine, click with the left button directly on the icon and a list of search engine options should drop down. Again, it doesn't work until you move the search box back to the toolbar AND exit out of customize mode.

Spørgsmålsstiller

Thank-you jscher2000 for continuing to clarify.

I have moved the McAfee search box to the toolbar (and closed the customize screen).

It maintains the McAfee logo and has no browser logo. Right and left clicking offer no options to change the browser. So this appears to be a McAfee product, and not the search field you are discussing.

Doing a search in this McAfee field brings up results in the Yahoo search engine, so it does not provide a fix to this situation.

I assume part of Yahoo's hack is to remove the specialized search field option from Firefox.

I am going to use the Restore Defaults process recommended by cor-el and Hossain Al Ikram. If this works I will mark the problem as solved (although there should be a cleaner, easier fix, and Yahoo should not be able to hijack the search function in the first place).

Thank-you jscher2000 for continuing to clarify. I have moved the McAfee search box to the toolbar (and closed the customize screen). It maintains the McAfee logo and has no browser logo. Right and left clicking offer no options to change the browser. So this appears to be a McAfee product, and not the search field you are discussing. Doing a search in this McAfee field brings up results in the Yahoo search engine, so it does not provide a fix to this situation. I assume part of Yahoo's hack is to remove the specialized search field option from Firefox. I am going to use the Restore Defaults process recommended by cor-el and Hossain Al Ikram. If this works I will mark the problem as solved (although there should be a cleaner, easier fix, and Yahoo should not be able to hijack the search function in the first place).
Mitch 0 løsninger 23 svar

Simple, Here's Something Google Created To Help! Here

Simple, Here's Something Google Created To Help! [http://www.google.com.au/intl/en/homepage/search/sp-firefox.html#instructions Here]

Ændret af Mitch den

Spørgsmålsstiller

Thank-you Mitch for responding to my question.

Unfortunately the Yahoo hack has made the search field the Google site references unavailable to me. It no longer exists on my Firefox. So I cannot use it to choose a search engine.

Thank-you Mitch for responding to my question. Unfortunately the Yahoo hack has made the search field the Google site references unavailable to me. It no longer exists on my Firefox. So I cannot use it to choose a search engine.
cor-el
  • Top 10 Contributor
  • Moderator
17519 løsninger 158412 svar

You can check if you have the XML files of the default search engines including Google in the browser\searchplugins folder in the Firefox program.

If not then you need to reinstall Firefox.

Do a clean reinstall and delete the Firefox program before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.

If you keep having problems then also create a new profile.


You can check if you have the XML files of the default search engines including Google in the browser\searchplugins folder in the Firefox program. *http://kb.mozillazine.org/Unable_to_search_or_add_new_engines *https://support.mozilla.org/kb/remove-toolbar-has-taken-over-your-firefox-search- If not then you need to reinstall Firefox. Do a clean reinstall and delete the Firefox program before (re)installing a fresh copy of the current Firefox release. *Download the full Firefox installer and save the file to the desktop<br>http://www.mozilla.org/en-US/firefox/all.html If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software. *Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions. Remove the Firefox program before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *It is important to delete the Firefox program to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox. If you keep having problems then also create a new profile. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

Spørgsmålsstiller

I finally found a procedure suitable to my rather low computer skill.

I found my solution in jscher 2000's post on 5/29/14 7:42 PM

1. Open the 3 line menu at the top right of the Firefox screen 2. Choose 'Customize' at the bottom 3. Find the search box in this menu (for me it was in the right side area.) It's a wide, 1 line tall box. 4. Move this box up to the bar at the top of the Firefox screen (the one with the address field and the 3 line menu icon). 5. Close the customize screen. 6. LEFT click on the icon at the left of this search box. 7. Choose a search engine from the menu that drops down. 8. You can then reopen the customize screen and move the search box back to it, removing it from the bar at the top of the Firefox screen if you don't want it there.

Now when I enter a search in the URL address box at the top of the Firefox screen it automatically uses the search engine I chose.

Easy once I understood what to do.

Thank-you jscher 2000 for continuing to provide suggestions that took into account my confusion as I tried and failed.

Thank-you all for your input.

I finally found a procedure suitable to my rather low computer skill. I found my solution in jscher 2000's post on 5/29/14 7:42 PM 1. Open the 3 line menu at the top right of the Firefox screen 2. Choose 'Customize' at the bottom 3. Find the search box in this menu (for me it was in the right side area.) It's a wide, 1 line tall box. 4. Move this box up to the bar at the top of the Firefox screen (the one with the address field and the 3 line menu icon). 5. Close the customize screen. 6. LEFT click on the icon at the left of this search box. 7. Choose a search engine from the menu that drops down. 8. You can then reopen the customize screen and move the search box back to it, removing it from the bar at the top of the Firefox screen if you don't want it there. Now when I enter a search in the URL address box at the top of the Firefox screen it automatically uses the search engine I chose. Easy once I understood what to do. Thank-you jscher 2000 for continuing to provide suggestions that took into account my confusion as I tried and failed. Thank-you all for your input.

Ændret af gcraighammond den