X
Tryk her for at gå til webstedets mobilversion.

Supportforum

There is no key icon on my tool bar - how do I save passwords for sites I visit frequently

Skrevet

I changed my password for an account I visit frequently and removed the old password from my saved password file. When I signed in using my new password, I was not given the opportunity to save it — how do I get the key icon to show itself so I can save my new password

I changed my password for an account I visit frequently and removed the old password from my saved password file. When I signed in using my new password, I was not given the opportunity to save it — how do I get the key icon to show itself so I can save my new password

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 13.0 r0
  • detect the version of extension manager
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • 5.1.30317.0
  • Reader Applicaiton Detector Plugin
  • Garmin Communicator Plug-in Version 4.1.0.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Office Live Update v1.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • npmnqmp 071101000050

Program

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:29.0) Gecko/20100101 Firefox/29.0

Yderligere information

Luk
Jakub Mareda 4 løsninger 39 svar

I'm afraid the firefox must've failed to detect, that a new password is being entered. Is it possible to tell us, on which site this problem occurs?

I'm afraid the firefox must've failed to detect, that a new password is being entered. Is it possible to tell us, on which site this problem occurs?
cor-el
  • Top 10 Contributor
  • Moderator
17538 løsninger 158577 svar

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"
Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history). *https://support.mozilla.org/kb/Private+Browsing *Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use private browsing mode"

Spørgsmålsstiller

It is set to remember history

It is set to remember history
cor-el
  • Top 10 Contributor
  • Moderator
17538 løsninger 158577 svar

The website might be using autocomplete=off to prevent Firefox from saving form data like name and password.

Note that Firefox won't auto-fill saved form data automatically when autocomplete=off is used, so double-click the empty name field to get a drop-down list.

The website might be using autocomplete=off to prevent Firefox from saving form data like name and password. *You can toggle the signon.overrideAutocomplete pref to true on the <b>about:config</b> page. *You can remove autocomplete=off with a bookmarklet to make Firefox store form data like names and passwords. *http://kb.mozillazine.org/User_name_and_password_not_remembered Note that Firefox won't auto-fill saved form data automatically when autocomplete=off is used, so double-click the empty name field to get a drop-down list.

Spørgsmålsstiller

Autocomplete works for my user name

In addition when I log in with Safari - everything works

Autocomplete works for my user name In addition when I log in with Safari - everything works
cor-el
  • Top 10 Contributor
  • Moderator
17538 løsninger 158577 svar

If autocomplete only works for the user name then is likely done via the regular form autocomplete and not by the Password Manager as that would fill a password as well.

You can right-click the name input field and open the built-in Inspector via Inspect Element. You can see if there is an autocomplete=off attribute and click the "off" text to edit this value and change it "off" to "on", so you get autocomplete="on". Repeat this for the password input field, so both fields have an autocomplete="on" attribute.

Note that autocomplete="off" can be an attribute of the form tag that contains the log in input fields.

If autocomplete only works for the user name then is likely done via the regular form autocomplete and not by the Password Manager as that would fill a password as well. You can right-click the name input field and open the built-in Inspector via Inspect Element. You can see if there is an autocomplete=off attribute and click the "off" text to edit this value and change it "off" to "on", so you get autocomplete="on". Repeat this for the password input field, so both fields have an autocomplete="on" attribute. Note that autocomplete="off" can be an attribute of the form tag that contains the log in input fields.

Ændret af cor-el den

Spørgsmålsstiller

That's ridiculous. I am not a programmer and allmI get is a bunch of code.

Everything worked fine until I changed my password and now it will not allow me to remember my new password. The key icon is not displayed when I try to sign on.

That's ridiculous. I am not a programmer and allmI get is a bunch of code. Everything worked fine until I changed my password and now it will not allow me to remember my new password. The key icon is not displayed when I try to sign on.
cor-el
  • Top 10 Contributor
  • Moderator
17538 løsninger 158577 svar

If you could post a link to the web page with this log in form then we can check the code to see if autocomplete=off is present.

If you could post a link to the web page with this log in form then we can check the code to see if autocomplete=off is present.