Prohledat stránky podpory

Vyhněte se podvodům. Za účelem poskytnutí podpory vás nikdy nežádáme, abyste zavolali nebo poslali SMS na nějaké telefonní číslo nebo abyste sdělili své osobní údaje. Jakékoliv podezřelé chování nám prosím nahlaste pomocí odkazu „Nahlásit zneužití“.

Learn More

firefox 4: spell check spellchecker not working

  • 3 odpovědi
  • 93 má tento problém
  • 3 zobrazení
  • Poslední odpověď od derekr

more options

Since Firefox 4 update my Firefox built-in spellchecker underlines misspelled words but there are no menu options and no spelling suggestions/corrections -- the entire menu part of the spellchecker feature is absent.

I've tried everything to get this working without results. Please some help!

Všechny odpovědi (3)

more options

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.

You can open the "Add Dictionaries" link to install a dictionary if you do not have one.
Make sure that [X] "Check Spelling" in the right-click context menu has a tick.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Appearance/Themes).

  • Don't make any changes on the Safe mode start window.

See:

more options

Hi,

Right-clicking in a text area does not produce a menu (like I mentioned). Of course I have the US-EN dictionary addon installed and confirmed ok in about:config.

All I get in the underline action on misspelled words, but no dictionary menu options (no menu) and no spelling suggestions/corrections (no menus).

The spellchecker obviously isn't working right, yet still kinda working. Attached is a screenshot of this text area while I right-click on a misspelling.

more options

Hello, I've found the problem.

The extension "Menu Editor" appears to have disabled the Firefox spellchecker menus despite having them previously enabled before upgrading to FF4. (I guess FF4 changed what Menu Editor had previously had identified).

So, I went into Menu Editor addon and enabled the Spellchecker menus to be visible. e voilà

Thank you.