X
Klepněte zde pro přechod na mobilní verzi webu.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Fórum podpory

how do i stop ad-aware security search from being my search engine?

Přidáno

every time i launch Firefox,my search engine changes to ad-aware security search. If i open another tab google will be default again. I have even deleted ad-aware from the search engines in the settings

every time i launch Firefox,my search engine changes to ad-aware security search. If i open another tab google will be default again. I have even deleted ad-aware from the search engines in the settings
Citovat

Další informace o systému

Aplikace

  • Identifikace prohlížeče: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Více informací

FredMcD
  • Top 10 Contributor
4072 řešení 56821 odpovědí
Přidáno

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ ad-aware “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''(<Control> ''[Mac=<Command>]'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Remove “ ad-aware “ '''Anything. ''' Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine Now do the same in the computer’s '''Programs Folder. ''' '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the '''Applications''' folder. '''Linux:''' Check your user manual.
Bylo to pro vás srozumitelné?
Citovat

Autor otázky

Thank you, but none of these programs or extensions exist on my pc

Thank you, but none of these programs or extensions exist on my pc
Bylo to pro vás srozumitelné?
Citovat
jscher2000
  • Top 10 Contributor
8312 řešení 68040 odpovědí
Přidáno

If the problem is not caused by one of your extensions -- if you don't remember installing any of them or why, disable or remove -- here are two other things you could check:

(1) Connection Settings

You can check on those here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Any difference?

(2) Program Folder Infection

Could you check for alien script files in your Firefox program folder? In particular, in these locations (varies for 32-bit / 64-bit):

  • C:\Program Files\Mozilla Firefox\defaults\pref
  • C:\Program Files (x86)\Mozilla Firefox\defaults\pref

Caution: Do not double-click script files! The default action for a script file it to execute as a Windows system script. (Typically this would just not work, but why risk it.)

Make sure Windows is showing hidden files: https://support.microsoft.com/en-us/help/14201/windows-show-hidden-files

A file named channel-prefs.js is normal. Any other file in this folder is suspicious -- for example, dsengine.js (added by Lavasoft/AdAware Web Companion). Remove any such files to a neutral location for further analysis at your leisure.

If the problem is not caused by one of your extensions -- if you don't remember installing any of them or why, disable or remove -- here are two other things you could check: (1) Connection Settings You can check on those here: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''proxy'' and Firefox should filter to the "Settings" button, which you can click. The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy". Any difference? (2) Program Folder Infection Could you check for alien script files in your Firefox program folder? In particular, in these locations (varies for 32-bit / 64-bit): * C:\Program Files\Mozilla Firefox\defaults\pref * C:\Program Files (x86)\Mozilla Firefox\defaults\pref Caution: ''Do not double-click script files!'' The default action for a script file it to execute as a Windows system script. (Typically this would just not work, but why risk it.) Make sure Windows is showing hidden files: https://support.microsoft.com/en-us/help/14201/windows-show-hidden-files A file named '''channel-prefs.js''' is normal. '''Any other file''' in this folder is suspicious -- for example, dsengine.js (added by Lavasoft/AdAware Web Companion). Remove any such files to a neutral location for further analysis at your leisure.
Bylo to pro vás srozumitelné? 0
Citovat
McCoy
  • Top 10 Contributor
396 řešení 3420 odpovědí
Přidáno

JohnMentz said

every time i launch Firefox,my search engine changes to ad-aware security search.

Hello JohnMentz,

Am I right assuming that you're talking about "Ad-Aware Secure Search"  ? If so, would you please take a look at this article :

https://www.bugsfighter.com/remove-adaware-secure-search/

And also :

http://www.free-uninstall.org/how-to-uninstall-remove-adaware-secure-search/

In addition : it might be wise to run all malware scans that are mentioned in this article (what one doesn't pick up, the other might) :

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware

(edit : typo ... )

''JohnMentz [[#question-1253373|said]]'' <blockquote> every time i launch Firefox,my search engine changes to ad-aware security search. </blockquote> Hello JohnMentz, Am I right assuming that you're talking about "Ad-Aware Secure Search" ? If so, would you please take a look at this article : https://www.bugsfighter.com/remove-adaware-secure-search/ And also : http://www.free-uninstall.org/how-to-uninstall-remove-adaware-secure-search/ In addition : it might be wise to run all malware scans that are mentioned in this article (what one doesn't pick up, the other might) : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware (edit : typo ... )

Upravil uživatel McCoy dne

Bylo to pro vás srozumitelné?
Citovat

Autor otázky

thank yo all, i have tried everything you said and it still launches at my first tab on firefox... its like a ghost program i cant find it nowhere...

thank yo all, i have tried everything you said and it still launches at my first tab on firefox... its like a ghost program i cant find it nowhere...
Bylo to pro vás srozumitelné?
Citovat
McCoy
  • Top 10 Contributor
396 řešení 3420 odpovědí

JohnMentz said

I have even deleted ad-aware from the search engines in the settings

I overlooked this .....

Does this mean that you found it in Options => Search, under "One-Click Search Engines" (and removed it)  ?


As it still opens at startup (when your home page should open), would you please go over this article :

https://support.mozilla.org/en-US/kb/wrong-home-page-opens-when-i-start-firefox-how-fix

By the way : did you run those malware scans  ?

''JohnMentz [[#question-1253373|said]]'' <blockquote> I have even deleted ad-aware from the search engines in the settings </blockquote> I overlooked this ..... Does this mean that you found it in Options => Search, under "One-Click Search Engines" (and removed it) ? --------------------------------------------------------------------------------------------- As it still opens at startup (when your home page should open), would you please go over this article : https://support.mozilla.org/en-US/kb/wrong-home-page-opens-when-i-start-firefox-how-fix By the way : did you run those malware scans ?
Bylo to pro vás srozumitelné?
Citovat

Autor otázky

There was nothing to delete... I run antivirus scans, should i do malware scans too?

There was nothing to delete... I run antivirus scans, should i do malware scans too?
Bylo to pro vás srozumitelné?
Citovat
FredMcD
  • Top 10 Contributor
4072 řešení 56821 odpovědí

Malware is different from viruses. Some anti-virus can detect some malware, but they might miss something.

Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Malware is different from viruses. Some anti-virus can detect some malware, but they might miss something. Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.
Bylo to pro vás srozumitelné?
Citovat
McCoy
  • Top 10 Contributor
396 řešení 3420 odpovědí

JohnMentz said

There was nothing to delete...

In your original post you say :

"I have even deleted ad-aware from the search engines in the settings "

''JohnMentz [[#answer-1205927|said]]'' <blockquote> There was nothing to delete... </blockquote> In your original post you say : "''I have even deleted ad-aware from the search engines in the settings '' "
Bylo to pro vás srozumitelné?
Citovat
Položit otázku

Pro přidání odpovědi se musíte přihlásit ke svému účtu. Pokud dosud nemáte účet, položte novou otázku.