Prohledat stránky podpory

Vyhněte se podvodům. Za účelem poskytnutí podpory vás nikdy nežádáme, abyste zavolali nebo poslali SMS na nějaké telefonní číslo nebo abyste sdělili své osobní údaje. Jakékoliv podezřelé chování nám prosím nahlaste pomocí odkazu „Nahlásit zneužití“.

Learn More

Top Bars on Javascript-Based Sites

  • 8 odpovědí
  • 1 má tento problém
  • 8 zobrazení
  • Poslední odpověď od cor-el

more options

Including this one, the Internet Archive, and Apple's new support site. An extra bar appears at the top of the screen as I scroll down. I have sensory processing issues, and animation triggers my migraines. Are there any ways to either:

have these bars appear during loading instead of while scrolling?

keep these bars from appearing while scrolling?

block the top of any javascript-based page?

Zvolené řešení

For this website you can add this code to the userContent.css file.


@-moz-document domain(support.mozilla.org){
 body.scroll-header{padding-top:45px!important}
 body.scroll-header>header{visibility:collapse!important; opacity:0;}
}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

  • create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • use a plain text editor like Notepad to create a (new) userContent.css file in the chrome folder (file name is case sensitive)
  • paste the code in the userContent.css file in the editor window
  • make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userContent.css.
    otherwise Windows may add a hidden .txt file extension and you end up with a not working userContent.css.txt file
Přečíst dotaz v kontextu 👍 0

Všechny odpovědi (8)

more options

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options
  • shields eyes while scrolling down*

I can't make a screenshot of animation. Screenshots are still. Animation is not. I won't post animation anyway. Animation is pain.

more options

Please post a public link to the web page.

more options

To this web page? (Top bar appears when I scroll.)

https://support.mozilla.org/en-US/questions/1126740

To the Internet Archive? (Top bar shrinks, painfully, when I enter text i the lower search bar.)

https://archive.org/

To Apple's support site? (Top bar appeared when I scroll; however other users pointed me to a site-specific hack.)

https://discussions.apple.com/message/30326904

more options

Do you mean the fixed bar in the attached screen shot? This bar should just appear at a certain point and be fixed in place and not animate or quiver or anything odd like that. If yours moves as you scroll, there might be a compatibility issue with your graphics card.

more options

"This bar should just appear at a certain point and be fixed in place"

It shouldn't do that. That is animation. That does hurt.

more options
.persist-question.persist {
  top: 0;
  opacity: 1;
  -webkit-transition: all 0.5s ease-in-out;
  -moz-transition: all 0.5s ease-in-out;
  -ms-transition: all 0.5s ease-in-out;
  -o-transition: all 0.5s ease-in-out;
  transition: all 0.5s ease-in-out;
}

There is a close button that removes the persist class name: $j('.persist-question').removeClass('persist'); This code in userContent.css should remove this bar.

@-moz-document domain(discussions.apple.com){
 .persist-question {opacity: 0!important; display:none!important;}
}

For Stylish you would probably need a @namespace line.

@namespace url(http://www.w3.org/1999/xhtml);

Upravil uživatel cor-el dne

more options

Zvolené řešení

For this website you can add this code to the userContent.css file.


@-moz-document domain(support.mozilla.org){
 body.scroll-header{padding-top:45px!important}
 body.scroll-header>header{visibility:collapse!important; opacity:0;}
}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

  • create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • use a plain text editor like Notepad to create a (new) userContent.css file in the chrome folder (file name is case sensitive)
  • paste the code in the userContent.css file in the editor window
  • make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userContent.css.
    otherwise Windows may add a hidden .txt file extension and you end up with a not working userContent.css.txt file