Otevírání souborů PDF v okně Firefoxu | Jak

Otevírání souborů PDF v okně Firefoxu

K zobrazení souborů PDF v okně Firefoxu můžete použít integrovaný PDF prohlížeč nebo zásuvný modul prohlížeče PDF souborů. Tento článek se zabývá oběma způsoby a přináší řešení obvyklých problémů, se kterými byste se mohli setkat.

K zobrazení souborů PDF v okně Firefoxu můžete použít rozšíření s názvem PDF Viewer nebo zásuvný modul prohlížeče PDF souborů. Tento článek se zabývá oběma způsoby a přináší řešení obvyklých problémů, se kterými byste se mohli setkat.

Poznámka: PDF prohlížeč je nyní zabudován do Firefoxu. Chcete-li jej používat, aktualizujte Firefox.

Použití integrovaného PDF prohlížeče

Firefox nyní obsahuje integrovaný PDF prohlížeč, který umožňuje zobrazit téměř všechny soubory PDF nacházející se na webu, bez nutnosti mít nainstalovaný zásuvný modul. Je to výchozí prohlížeč PDF souborů.

Jak používat rozšíření PDF Viewer

PDF Viewer (nebo také pdf.js) je nové revoluční rozšíření využívající technologie webových standardů, které umožňuje zobrazit v okně Firefoxu téměř všechny soubory PDF nacházející se na webu, i když není nainstalován zásuvný modul.

PDF JS

Máte-li nainstalován zásuvný modul prohlížeče PDF souborů, jako třeba Adobe Reader, budete jej muset zakázat (a jakýkoli další zásuvný modul prohlížeče PDF souborů), aby bylo možné k otevírání PDF souborů používat rozšíření PDF Viewer.

  1. V horní části okna Firefoxu klepněte na tlačítko Firefox Na liště s nabídkou klepněte na nabídku NástrojeV horní části okna Firefoxu klepněte na nabídku Nástroje a poté na položku Správce doplňků. Otevře se panel Správce doplňků. Zobrazte nabídku klepnutím na tlačítko New Fx Menu a zvolte Správce doplňků. Otevře se panel Správce doplňků.

  2. Ve Správci doplňků přejděte do sekce Zásuvné moduly.
  3. Vyberte každý zásuvný modul prohlížeče PDF souborů a klepněte na tlačítko Zakázat.

Ovládání rozšíření PDF Viewer

Ovládání integrovaného PDF prohlížeče

  • Zobrazení náhledů nebo osnovy dokumentu - Tlačítkem nacházejícím se zcela vlevo přepínáte mezi zobrazením a nezobrazením postranní lišty s náhledy stránek dokumentu. U některých dokumentů bude dostupné i zobrazení jejich osnovy. Postranní lišta vám usnadní orientaci a pohyb v rozsáhlých dokumentech.

    PDF-postranni-lista
  • Další a předchozí stránka nebo skok přímo na stránku - Tlačítky se šipkami nahoru a dolů listujete dokumentem. Také můžete zadat přímo číslo stránky, na kterou chcete přejít.

    PDF-cislo-stranky
  • Změna velikosti dokumentu - Pomocí tlačítek + a – zvětšujete a zmenšujete velikost dokumentu. Jeho velikost můžete nastavit i z rozbalovací nabídky hned napravo.

    PDF-velikost-dokumentu
  • Režim prezentace nebo celé obrazovky - Klepnutím na tlačítko režimu celé obrazovky se dokument zobrazí přes celou obrazovku. Stisknutím klávesy ESC režim celé obrazovky opustíte.

    PDF Fullscreen
  • Tisk dokumentu - Klepnutím na tlačítko tiskárny vyvoláte dialogové okno s nastavením tisku.

    PDF Print
  • Stažení dokumentu - Klepnutím na tlačítko stažení dokumentu se PDF dokument uloží do počítače nebo se otevře v externím programu pro prohlížení souborů PDF.

    PDF Download
  • Kopie aktuálně zobrazeného - Klepnutím pravým tlačítkem myši na tlačítko Aktuální pohled můžete dokument otevřít v dalším panelu či okně, a to na stránce, kterou máte aktuálně zobrazenou.

    PDF Copy

Klávesové zkratky

Příkaz Klávesová zkratka
Další stránka n nebo k nebo
Předchozí stránka p nebo j nebo
Zvětšit velikost Ctrl + +command + +
Zmenšit velikost Ctrl + -command + -
Zpět na skutečnou velikost Ctrl + 0command + 0
Otočit dokument o 90° doprava r
Otočit dokument o 90° doleva shift + r

Řešení problémů s rozšířením PDF Viewer

Řešení problémů s integrovaným PDF prohlížečem

Některé soubory PDF se nezobrazují správně nebo se zobrazí pouze prázdné stránky

U určitých typů souborů PDF může mít PDF prohlížeč problémy se zobrazením fontů, barev nebo celého dokumentu. Abyste tyto soubory řádně zobrazil:

  • Klepněte na tlačítko stahování v pravém horním rohu dokumentu a otevřete jej ve vašem výchozím systémovém PDF prohlížeči.

Nemohu otevřít žádný soubor PDF

Je možné, že ve funkčnosti PDF prohlížeče brání některá rozšíření blokující JavaScript. Můžete je zakázat a umožnit tak PDF prohlížeči řádně fungovat:

  1. V horní části okna Firefoxu klepněte na tlačítko Firefox Na liště s nabídkou klepněte na nabídku NástrojeV horní části okna Firefoxu klepněte na nabídku Nástroje a poté na položku Správce doplňků. Otevře se panel Správce doplňků. Zobrazte nabídku klepnutím na tlačítko New Fx Menu a zvolte Správce doplňků. Otevře se panel Správce doplňků.

  2. Ve Správci doplňků přejděte do sekce Extensions.
  3. U každého rozšíření blokujícího JavaScript klepněte na tlačítko Zakázat.

Více informací se dozvíte v článku Řešení problémů s rozšířeními a motivy vzhledu.

Použití zásuvného modulu prohlížeče PDF

Nechcete-li integrovaný PDF prohlížeč používatNechcete-li PDF Viewer používat, můžete místo něj použít nějaký zásuvný modul prohlížeče PDF souborů, jako třeba Adobe Reader, Nitro PDF Reader nebo Sumatra PDFAdobe Reader, MozPlugger, nebo KParts pluginSchubert|it PDF Browser Plugin na Mac OS X 10.6 a novějším.

Změnu prohlížeče PDF souborů z integrovaného PDF prohlížeče na zásuvný modul vašeho prohlížeče PDF souborů provedete následovně:

  1. V horní části okna Firefoxu klepněte na tlačítko Firefox a poté na položku MožnostiV horní části okna Firefoxu klepněte na nabídku Nástroje a v ní zvolte položku MožnostiNa liště s nabídkou klepněte na nabídku Firefox a v ní na položku Předvolby...V horní části okna Firefoxu klepněte na nabídku Úpravy a v ní zvolte položku Předvolby.

    Zobrazte nabídku klepnutím na tlačítko New Fx Menu a zvolte MožnostiPředvolby.

  2. Přejděte do sekce Aplikace.
  3. V seznamu najděte položku Přenositelný formát dokumentu (PDF) a klepnutím na ni ji označte.
  4. Klepněte na šipku ve sloupci Akce u této položky a z nabídky zvolte Použít název PDF prohlížeče.


moznosti-aplikace-fx19

Jestliže se soubory PDF místo svého otevření stahují, zkuste tato řešení

Jestliže se soubory PDF místo svého otevření stahují, zkontrolujte nastavení

  1. V horní části okna Firefoxu klepněte na tlačítko Firefox a poté na položku MožnostiV horní části okna Firefoxu klepněte na nabídku Nástroje a v ní zvolte položku MožnostiNa liště s nabídkou klepněte na nabídku Firefox a v ní na položku Předvolby...V horní části okna Firefoxu klepněte na nabídku Úpravy a v ní zvolte položku Předvolby.

    Zobrazte nabídku klepnutím na tlačítko New Fx Menu a zvolte MožnostiPředvolby.

  2. Zvolte sekci Aplikace.
  3. V seznamu najděte položku Adobe Acrobat Document (jestliže používáte Adobe Reader) nebo soubor PDF (pro ostatní PDF prohlížeče) a klepnutím na ni ji označte.
  4. Z vysouvací nabídky v pravém sloupci Akce zvolte Použít název PDF prohlížeče (v aplikaci Firefox).


Opening PDF - Win

    • Není-li položka Použít název PDF prohlížeče (v aplikaci Firefox) uvedena v seznamu, přečtěte si Obnovte nabídku akcí níže a poté zopakujte postup v této kapitole.
  1. Klepnutím na tlačítko OK zavřete dialogové okno MožnostiKlepnutím na tlačítko Zavřít zavřete dialogové okno PředvolbyZavřete dialogové okno Předvolby.

Další řešení

Obnovte nabídku akcí

  1. Otevřete svou složku s profilem:

    V horní části okna Firefoxu klepněte na tlačítko Firefox, přejeďte do nabídky NápovědaNa liště s nabídkou klepněte na nabídku NápovědaV horní části okna Firefoxu klepněte na nabídku Nápověda a zvolte položku Technické informace.... Otevře se panel Technické informace.Zobrazte nabídku klepnutím na tlačítko New Fx Menu , v ní klepněte na Help-29 a zvolte Technické informace. Otevře se panel Technické informace.

  2. V sekci Stručně o aplikaci klepněte na tlačítko Zobrazit složkuZobrazit ve FinderuOtevřít adresář. Otevře se okno se soubory vašeho profilusložkou s vaším profilem.
  3. Poznámka: Pokud nemůžete spustit či použít Firefox, postupujte dle instrukcí v článku Nalezní profilu bez otevření Firefoxu.

  4. V horní části okna Firefoxu klepněte na tlačítko Firefox, kde zvolte položku UkončitV horní části okna Firefoxu klepněte na nabídku Soubor, kde zvolte položku UkončitNa liště s hlavní nabídkou klepněte na nabídku Firefox, kde zvolte položku Ukončit FirefoxV horní části okna Firefoxu klepněte na nabídku Soubor, kde zvolte položku Ukončit.

    Zobrazte nabídku klepnutím na tlačítko New Fx Menu a v ní klepněte na Ukončit Close 29 .

  5. Smažte soubor mimetypes.rdf

Zkontrolujte nastavení aplikace

Je-li zásuvný modul prohlížeče PDF svázán s jeho nativní aplikací, prověřte nastavení zásuvného modulu v této aplikaci, pokud to aplikace umožňuje.

  • Adobe Reader:
    1. Spusťte aplikaci Adobe Reader.
    2. V liště s nabídkami klepněte na nabídku Úpravy a pak na nabidku Předvolby.... Zobrazí se okno Předvolby.
    3. V sekci Kategorie klepněte na položku Internet.
    4. Ujistěte se, že první volba, Zobrazit PDF v prohlížeči, je zaškrtnutá.
    5. Klepněte na tlačítko OK a ukončete aplikaci Adobe Reader.

Pokud stále nemůžete soubor PDF ve Firefoxu prohlížet, pokračujte dále následujícím postupem.

Proveďte opětovnou inicializaci databáze zásuvných modulů

Následujte pokyny obsažené v kapitole Opětovná inicializace databáze zásuvných modulů v článku Řešení problémů se zásuvnými moduly.

Tento postup přinutí Firefox, aby si znovu vytvořil databázi zásuvných modulů. Pokud stále nemůžete soubor PDF ve Firefoxu prohlížet, pokračujte dále následujícím postupem.

Přeinstalujte aplikaci

Je-li zásuvný modul prohlížeče PDF svázán s jeho nativní aplikací a výše popsané postupy nevedli k odstranění potíží, přeinstalujte prohlížeč PDF souborů.

Pokud stále nemůžete soubor PDF ve Firefoxu prohlížet, pokračujte dále následujícím postupem.

Další informace pro Adobe Reader

Jestliže žádný z výše uvedených postupů nevedl k vyřešení problému, podívejte se na stránku Can't view PDF on the web, kde získáte další instrukce.

Byl tento článek srozumitelný?

Počkejte prosím...

Tito lidé pomohli se sepsáním tohoto článku: JasnaPaka, soucet. Můžete též pomoci - přečtěte si jak.
Získat podporu pro další platformu:
Přizpůsobení článku

Firefox