Novinky v Thunderbirdu 60

Tento článek popisuje hlavní změny, kterých si uživatelé povšimnou ve verzi Thunderbirdu 60.0. Všechny změny jsou k nalezení v poznámkách k vydání Thunderbirdu 60.

Některé doplňky nemusejí fungovat

Kvůli nezbytným významným změnám nebude verze 60 automaticky načítat doplňky, jestliže svým autorem nebyly označeny jako kompatibilní. Doposud bylo svými autory učiněno kompatibilními více než 130 doplňků a každý týden jich několik přibývá. Pokud váš doplněk není kompatibilní, kontaktujte prosím jeho autora skrze jeho stránky podpory nebo e-mailem, který naleznete na webu doplňků.

(Rozhodnutí vypnout automatickou kompatibilitu nebylo snadné, ale současný stav je pro uživatele výhodnější, protože nefungujícím doplňkům je zabráněno, aby rozbily Thunderbird. A aby se autorům doplňků usnadnila jejich aktualizace, bylo významně vylepšeno plánování a kód Thunderbirdu, aby se snížil dopad změn zděděných z Firefoxu.)

Změna přístupu k nastavení doplňků

Nastavení doplňků již není spravováno z panelu Správce doplňků. V nabídce Nástroje je za tím účelem k dispozici nová položka Nastavení doplňku (či Předvolby doplňku).

MainMenuBarOptions

Nebo pokud používáte nabídku aplikace na nástrojové liště, umístění ukazatele myši nad položku Doplňky či kliknutí na znak > zobrazí seznam nastavitelných doplňků.

AppmenuShowingADDOnOptions

Změny v nastavení data a času

Thunderbird má nyní možnost určit, jestli se má formát data a času používaný v programu řídit nastavením operačního systému nebo jazykem nainstalované verze Thunderbirdu. Jinými slovy český Thunderbird může používat např. anglické formáty.

  1. V horní části okna Thunderbirdu klikněte na nabídku Nástroje a zvolte MožnostiNa liště s nabídkou klikněte na nabídku Thunderbird a zvolte PředvolbyV horní části okna Thunderbirdu klikněte na nabídku Úpravy a zvolte Předvolby, nebo klikněte na tlačítko nabídky New Fx Menu fx57menu a zvolte MožnostiPředvolby.
  2. Přejděte do sekce Rozšířené a na kartu Obecné.
  3. V části Formátování data a času zaškrtněte buď možnost Jazyk aplikace nebo Nastavení místního jazyka.
  4. Klikněte na tlačítko OK pro zavření dialogového okna Možnosti.Klikněte na tlačítko Zavřít pro zavření dialogového okna Předvolby.Zavřete dialogové okno Předvolby.

Date and Time

Změny v okně pro psaní zprávy

Tlačítko Smazat umožňuje odstranit příjemce

Při umístění ukazatele myši nad popisky adresních polí (Odpovědět:, Komu:, Kopie:, Skrytá kopie:, Diskusní skupina:) se nyní zobrazí tlačítko X umožňující vymazat dané pole.

Demonstration of the delete button

Řada vylepšení ohledně příloh

Nyní je možné změnit pořadí příloh pomocí dialogu, klávesové zkratky nebo přetažením myši. Tlačítko "Připojit" se přesunulo doprava, aby bylo nad lištou příloh. Přístupová klávesa lišty příloh (např. Alt+M, může se lišit podle jazykového prostředí, Ctrl+M na Macu) nyní také lištu zobrazuje/skrývá. Lišta doplňků se také může zobrazit automaticky při psaní nové zprávy. Nastavit to lze kliknutím pravým tlačítkem na jeho záhlaví. Při skrytí neprázdné lišty příloh se nyní na jejím místě zobrazí kancelářská sponka, která má indikovat přítomnost příloh a předejít jejich nechtěnému odeslání.

AttachmentReordering

Tučné zobrazení shodující se části adresy při zápisu adresy

Aby bylo jasnější, proč byla konkrétní adresa zařazena do seznamu automatického dokončování, se nyní část adresy shodující se se zadaným textem zobrazuje tučně. Nastavení předvolby mail.autoComplete.commentColumn na hodnotu 1 umožňuje zobrazit složku kontaktů, v níž je adresa uložena.

Kontakty

Nyní je možné nastavit výchozí složku kontaktů, která bude vybrána po otevření Kontaktů. Nastavení se provede kliknutím pravým tlačítkem myši na nějakou složku a zvolením položky Výchozí spouštěcí složka.

Set Default address book Windows

Statické motivy vzhledu

Nyní jsou podporovány statické motivy vzhledu používající technologii WebExtensions API [1]. Tyto jsou srovnatelné s odlehčenými motivy vzhledu. Plné a odlehčené motivy vzhledu jsou stále podporovány. (Doplňky založené na WebExtensions a speciálním API jsou plánovány pro nějakou z následných minoritních aktualizací Thunderbirdu 60.)

[1] https://developer.mozilla.org/cs/docs/Mozilla/Add-ons/Themes/Theme_concepts

Kalendář

Možnost zobrazovat u událostí místa

Události kalendáře mohou nyní zobrazovat místo i název události. Calendar:Location Display

Příslušná volba se nachází v nastavení aplikace v sekci Kalendář > Pohledy. Location of Display location option

Zkopírování, vyjmutí a vložení opakovaných událostí a úkolů

Tak jako dříve pro smazání nebo úpravu se nyní objevuje výzva, zda zkopírování nebo vyjmutí použít jen na vybrané výskyty nebo na celou sérii opakující se události nebo úkolu.

Lightning Copy Occurrence Prompt

Je-li k dispozici více než jeden místní nebo odebíraný kalendář, cílový kalendář pro vložení kalendářních položek může být nyní vybrán ze seznamu všech kalendářů, do nichž lze zapisovat.

Lightning Paste Target Selection

Možnost pro odeslání/neodeslání pozvání na schůzku přímo

Při manipulaci se schůzkami se už – s výjimkou přetažení myší – neobjevuje vyskakovací okno s dotazem, zda uvědomit ostatní účastníky o vašich změnách. Místo toho se toto nastavuje přímo v jednotlivých dialozích nebo místních nabídkách.

Spolu s touto změnou byla odstraněna podpora pro vytváření e-mailových pozvání kompatibilních s aplikací Outlook 2002.

Možnost vynutit si použití e-mailového pozvání na schůzku uživatelů kalendářů CalDAV

Některé servery CalDAV jsou nakonfigurovány tak, aby se při zařizování schůzky postaraly o pozvání ostatních uživatelů na stejném kalendářním serveru. To by při zařizování schůzky zabránilo poslat ostatním účastníkům e-mailové pozvání z Thunderbirdu. Pro tyto kalendáře lze nyní použití e-mailových pozvání vynutit bez ohledu na konfiguraci serveru.

Připomenutí lze zrušit i pro kalendáře pouze pro čtení

Když se objeví připomenutí (upozornění) pro událost nebo úkol, jež je uložen v kalendáři pouze pro čtení, lze ho nyní zrušit (zavřít). Na rozdíl od zapisovatelných kalendářů není stále možné připomenutí odložit.

Lightning Reminder Dialog RO

Spolu s touto změnou byla volba pro zobrazování zmeškaných připomenutí omezena pouze na zapisovatelné kalendáře.

Show Missed Reminders Options

Experimentální funkce Maildir

Konverze složek z formátu mbox do formátu maildir a opačně

V souladu s dlouhodobým cílem implementovat maildir jakožto úložný systém Thunderbirdu, jsou v tomto vydání obsaženy nástroje pro konverzi stávajících složek do a z formátu maildir. Bližší informace o této implementaci obecně lze najít zde. Každý, kdo používá maildir, si musí být vědom faktu, že se stále jedná o experimentální funkci a jeho používání může odhalit další neznámé chyby vedoucí ke ztrátě dat.

Konec podpory systémů Windows XP a Vista

Ve shodě s odstraněním podpory pro systémy Windows XP a Vista ve Firefoxu 60 již Thunderbird tyto dva zastaralé operační systémy nepodporuje. Thunderbird 52 je poslední verzí Thunderbirdu, která je pro tyto dva systémy dostupná.

// Tito lidé pomohli se sepsáním tohoto článku:soucet. Také můžete pomoci.

Byl tento článek srozumitelný? Počkejte prosím...

Pomáhejte s Mozillou