Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Accessing online classwork in video format with Firefox until yesterday. Why isn't it working?

  • 1 reply
  • 1 has this problem
  • 2 views
  • Last reply by guigs

more options

I have Windows 7, using Internet Explorer, and also Firefox. I have been using Firefox to access my online classwork since December. I have HughesNet Satellite internet, and just last week, upgraded that system to their higher speed Gen4, Because the videos were stalling, stopping, and basically not playing, but since the upgrade, they were great, until yesterday, when they stopped altogether. I can access them through Internet Explorer. Was there an update that could have caused this? I've looked in my control panel, and don't want to Uninstall Firefox, thinking that it does show an update yesterday, but it says if I remove it I will lose all my accesses with it. I do not have Firefox set as default, and it always asks me that question when I open it, and there was a second question, which as of yesterday, also disappeared. I have spoken with Hughes, and they said check for an update, contact you, so that is what I'm doing. Thank you for your help! I look forward to continued use of Firefox!

All Replies (1)

more options

Hi Varmit00,

Yes! Let's keep using Firefox. And it sounds like you are handy, please feel free to start answering questions and hanging out in the forum. We could use the help!

It sounds like you may need to update the drivers in firefox and turn of hardware acceleration.

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.