On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Browser

more options

It is so annoying that when I open Firefox and type in what I am looking for that my typing goes right to the upper Top of the Page. I have tried to fix this problem but cannot seem to fix it. I want my typing to stay in the middle of the page, but my typing goes right to address bar. I started using Flashpeak, Slimjet browser for this reason. I just cannot get use to what Firefox has done with its browser. Firefox needs to fix this problem, a lot of us do not like it.

It is so annoying that when I open Firefox and type in what I am looking for that my typing goes right to the upper Top of the Page. I have tried to fix this problem but cannot seem to fix it. I want my typing to stay in the middle of the page, but my typing goes right to address bar. I started using Flashpeak, Slimjet browser for this reason. I just cannot get use to what Firefox has done with its browser. Firefox needs to fix this problem, a lot of us do not like it.

All Replies (4)

more options

Can you show a screenshot of this error when it occurs? Not sure where your typing in or what url site when this happens.

Helpful?

more options

Your reply is confusing. When searching in Firefox, when typing in the Search bar, it automatically goes to the URL address bar on top. This is common not for Firefox. I do not like my searching going up to the URL address bar. I want to use the middle search for my searching and not the URL address bar. I dislike it so much, I have switched to Flashpeak Slimjet Browser.

Helpful?

more options

Do you mean: you open a new tab, you click in the search bar in the middle of the page, and the moment you type a letter, your cursor leaps up to the address bar and your typing is entered there? Yes, this started in Firefox 89.

That update also included a preference to switch that off. The hardest part is learning its name:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since I use this one myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Success?

Helpful?

more options

Bravo: It worked, thank you so much!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.