Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Favicons in tabs always turn into a weird N icon after a few minutes

  • 6 replies
  • 1 has this problem
  • 69 views
  • Last reply by cor-el

more options

I've just installed Firefox and every tab loses it's favicon after a few minutes. It isn't consistent, and some tabs can hold their icon longer than others. I don't know what other info to provide, they just disappear and convert to this N icon until I reload the page... It makes it super hard to tell which tabs are which.

I'll attach an image. Any ideas?

Attached screenshots

Chosen solution

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

  • make sure your extensions and filters are updated to the latest version

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 👍 1

All Replies (6)

more options

Specifically have 82.0.2 (64-bit) installed for Mac

Modified by zacharyholland

more options

Chosen Solution

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

  • make sure your extensions and filters are updated to the latest version

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Ahh I am using ABP but this was never an issue with other browsers. It shouldn't be blocking favicons? I shouldn't have to whitelist every single website I navigate too just to have the favicon save in the tab right?

I am using default theme.

Extensions are all up to date. Currently installed addons: ABP - 3.9.5 Okta - 5.41.1 Hebrew Tooltip Translation - 3.0.1

I will try safe mode debugging now

Modified by zacharyholland

more options

The problem did not persist in safe mode and I've disabled one of my Addons to try troubleshooting. Specifcally this addon which I suspect https://addons.mozilla.org/en-US/firefox/addon/hebrew-tooltip-translation/

Modified by zacharyholland

more options

can confirm, that was the issue. thank you

more options

You're welcome.

Thanks for confirming what extension caused your issue. It helps others who stumble on this thread.