Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't access my Google profile

  • 3 replies
  • 1 has this problem
  • 3 views
  • Last reply by FredMcD

more options

Firefox won't load my Google profile on a Blogspot site I read, so I cannot leave comments, which I used to be able to do. I can go to this site via Internet Explorer, and that does work -- my google profile loads right up and I can post comments. What do I need to change in Firefox so that my google profile can be seen by this site?

Chosen solution

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Content Blocking. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature:

https://support.mozilla.org/en-US/kb/content-blocking

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Content Blocking. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature:

https://support.mozilla.org/en-US/kb/content-blocking

more options

Thank you. Safe Mode worked. After fiddling around with several content blocking icons I discovered, I found "Privacy Badger" was blocking my Google profile. Fixed! Thanks very much indeed

more options

Glad to help. Safe Surfing.