Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Web code being displayed

  • 4 replies
  • 3 have this problem
  • 3 views
  • Last reply by Grendor

more options

Hey Guys & Gals,

I have a issue with web/html code being displayed on several sites. I tried refreshing firefox but it did not help so i re-added my add-ons.

I have attached a screen shot of me on ebay.ca (Ebay Canada but happens on .com as well.)and as you will see it shows some web code. Not the whole site but a bit of code on every page. It also happens on some websites but not as often. I tried chrome and a few other browsers and it is only happening with firefox. I blanked out page of the picture for privacy reason.

I am running latest version of FireFox 53.0 (32bit) and it is running on my Windows 8.1 64bit system if that matters. Since a refresh of firefox did not help is there a Fix for something like I listed above.

Please let me know. Thanks in advance Gren

Attached screenshots

All Replies (4)

more options

Load the web page. Once loaded, hold down the <shift> key and reload the page.


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe websites. Are there any problems?

Then restart.

more options

Hello FredMcD,

Well I have done all you said to do and it did not help.

Back on Ebay almost all the windows with html/web code are all JavaScript it seems.

For example just in one page it shows "script type "text/javascript" src "text (lots of text) /script> "

This has only been an issue lately or the last two or three firefox updates i think. I guess I will live with it as I had hopped it was a Firefox bug tide to the changes with javascript.

Anyways thanks for the help. Have a great day. Gren

more options

Do you use any security software that pre-filters web pages before you receive them, or a proxy server? Examples of software with this feature include Avast, Bitdefender, ESET, and Kaspersky. The filter/proxy may be modifying certain elements of the page to prevent them from being executed by Firefox -- for your protection, but somehow making a mess of it.

more options

Hey jscher2000,

Thanks for the fast reply to my issue. Yes I use Kaspersky Total Security 2017, I will recheck settings there and reply tomorrow as it is almost 3:00 am here.

Thanks in advance Gren