Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I found anti-phishing on our two PCs with Firefox (now 31) was NOT turned on by default, (I did not turn it off). Discovered this bug after a phishing attack.

  • 5 replies
  • 2 have this problem
  • 11 views
  • Last reply by user633449

more options

Hi

I posted this more as an FYI. I'm using Firefox 31 on two PCs. and had a phishing incident today. I read your article on Firefox's ant-phishing / anti-malware protection, and using the two test pages you provided I found the phishing test page wasn't blocked. I followed your instructions and successfully activated it. For whatever reason on my two PCs (one is Windows 8.1 Update 1 and the other an ancient XP machine) only the anti-malware was running. Both computers were updated to version 31 in the last few days. I don't know if the failure to have anti-phishing turned on by default is a bug in this version, or was a setting copied from an earlier version of Firefox. I had never changed those security settings myself on any version of Firefox.

Modified by NoahSUMO

Chosen solution

That's not really phishing, that sounds like malware rather. Try running some scans. Troubleshoot Firefox issues caused by malware

Read this answer in context 👍 1

All Replies (5)

more options

I once had the same problem. A program had gotten into my computer, and shut down my anti-virus. I had a lot of fun trying to stop it ( NOT ! ). Once I found the program, I sent it to the anti-virus people, and a few days later the program was updated.

more options

BTW, this is the page the user was talking about.

https://support.mozilla.org/en-US/kb/how-does-phishing-and-malware-protection-work {web link} How does built-in Phishing and Malware Protection work?

Modified by FredMcD

more options

It's more likely this setting was carried over from an earlier version of Firefox. Some people disable one type of protection in favor of the other. Or disable the malware & phishing protection when troubleshooting other issues. Like to reach sites that Google says are bad but really are false positives.

You may have forgotten fooling with that setting or unchecked it by accident. For example, go back to the Security section in the Options. Move your mouse all the way over to the right underneath the "Exceptions" button and click your mouse along that area for each setting. You see how easily they could be changed by a misclick?

But since you say this happened on 2 computers, I'll ask a few people to test this out and see what happens.


You also said you had a anti-phishing incident? Could you elaborate a little more on that. I'm guessing you were in your email and opened a email you thought to be legitimate?

You'd only have been safe in that case if Google's database had been updated with info to block that exact phishing attack. Did you try revisiting the actual phishing attack after activating the protection? I'm curious to know if it was blocked.

Modified by NoahSUMO

more options

Hi

Thanks to all for the assistance. I have the anti-phishing on now and it seems to be working. Perhaps the setting was carried over from an early version of Firefox, also possible some other software interfered with proper installation. Unfortunately I can't retest it. Perhaps my terminology of phishing was incorrect; what happened was that a notification appeared on screen (on the Windows 8.1 PC) while reading a news article thru Google News. It looked like an official Microsoft/ Flash Player update notification telling me an urgent security update needed to be installed; it was really from a company impersonating Adobe. I aborted the download and checked the official Adobe site; I already had the latest version – I reported the company to Adobe. My bad for breaking my rule of never clicking “yes” on a pop-up message while browsing the web.

more options

Chosen Solution

That's not really phishing, that sounds like malware rather. Try running some scans. Troubleshoot Firefox issues caused by malware