X
Pritisnite ovdje da biste otišli na mobilnu verziju stranice.

Forum podrške

can't delete message

Objavljeno

For the last few days, Thunderbird stops moving messages to the trash or junk. Also when I send a message, it can't move the message to the Sent box.

If I quit and reopen Thunderbird, it will work again for a while.

I tried "Repair Folder" on the Inbox, Trash, and Junk folders.

Using Thunderbird 24.3.0 on Mac OS X 10.7.5.

For the last few days, Thunderbird stops moving messages to the trash or junk. Also when I send a message, it can't move the message to the Sent box. If I quit and reopen Thunderbird, it will work again for a while. I tried "Repair Folder" on the Inbox, Trash, and Junk folders. Using Thunderbird 24.3.0 on Mac OS X 10.7.5.

Dodatni detalji o sistemu

Aplikacija

  • Korisnički agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.117 Safari/537.36

Više informacija

Diego Victor 658 rješenja 4175 odgovora
Objavljeno

Try compact your folders:

Also:

Try compact your folders: *[https://support.mozilla.org/en-US/kb/compacting-folders CompactFOlders] Also: *[https://support.mozilla.org/en-US/kb/safe-mode Safe Mode]

Vlasnik pitanja

OK, I tried compacting folders and it didn't help. By the way, the docs say that if you use File > Compact Folders, you'll see a progress bar in the status bar, but I don't. Maybe it's really fast? I tried compacting some folders individually too.

The problem still happens in Safe Mode.

I don't know if it's relevant, but the Error Console shows a lot of messages like:

Warning: Found unclosed string '"publicly>'. Unexpected end of file while searching for closing } of invalid rule set. Source File: about:blank Line: 1007, Column: 4 Source Code: <id="publicly>

OK, I tried compacting folders and it didn't help. By the way, the docs say that if you use File > Compact Folders, you'll see a progress bar in the status bar, but I don't. Maybe it's really fast? I tried compacting some folders individually too. The problem still happens in Safe Mode. I don't know if it's relevant, but the Error Console shows a lot of messages like: Warning: Found unclosed string '"publicly>'. Unexpected end of file while searching for closing } of invalid rule set. Source File: about:blank Line: 1007, Column: 4 Source Code: <id="publicly>
Diego Victor 658 rješenja 4175 odgovora
Objavljeno

Yes, is very fast the compacting.

Hmmm, i think this will solve the problem, first unhide the hidden files and folders:

Then go to your profile:

Enter in the ImapMail or Pop3Mail folder >>Enter in imap.xxxxx or pop3.xxxxx >> Enter in [Webemail].sbd >> Delete all .msf archives

Yes, is very fast the compacting. Hmmm, i think this will solve the problem, first unhide the hidden files and folders: *[http://kb.mozillazine.org/Show_hidden_files_and_folders] Then go to your profile: *[https://support.mozilla.org/en-US/kb/profiles-tb#w_how-to-find-your-profile How do i find my profile?] Enter in the ImapMail or Pop3Mail folder >>Enter in imap.xxxxx or pop3.xxxxx >> Enter in [Webemail].sbd >> Delete all ''' .msf''' archives

Vlasnik pitanja

Thanks for trying, but deleting all the .msf files did not fix it the problem.

Thanks for trying, but deleting all the .msf files did not fix it the problem.
christ1
  • Top 25 Contributor
2224 rješenja 16259 odgovora
Objavljeno

What is your anti-virus s/w?

What is your anti-virus s/w?

Vlasnik pitanja

No anti-virus software.

No anti-virus software.

Vlasnik pitanja

Since deleting all the .msf files, I have a new symptom: Warnings like

"The messages could not be filtered to folder 'Xcode' because writing to folder failed. Verify that you have enough disk space, and that you have write privileges to the file system, then try again."

I do have around 10 GB of disk space, and can't find anything wrong with the ownership or permissions. I note that the folders giving me this error are ones where the .msf file has not been recreated.

Since deleting all the .msf files, I have a new symptom: Warnings like "The messages could not be filtered to folder 'Xcode' because writing to folder failed. Verify that you have enough disk space, and that you have write privileges to the file system, then try again." I do have around 10 GB of disk space, and can't find anything wrong with the ownership or permissions. I note that the folders giving me this error are ones where the .msf file has not been recreated.

Vlasnik pitanja

I suspect I may be affected by this bug.

I suspect I may be affected by [https://bugzilla.mozilla.org/show_bug.cgi?id=931303 this bug].
Diego Victor 658 rješenja 4175 odgovora
Objavljeno

This error message can be solved if you repair the folder.

This error message can be solved if you repair the folder.

Vlasnik pitanja

OK, thanks, repairing affected folders did get rid of the messages about inability to filter.

OK, thanks, repairing affected folders did get rid of the messages about inability to filter.
Diego Victor 658 rješenja 4175 odgovora
Objavljeno

Try reinstall the Thunderbird:

Try reinstall the Thunderbird: *http://www.mozilla.org/en-US/thunderbird

Vlasnik pitanja

Already tried removing and reinstalling Thunderbird.

Already tried removing and reinstalling Thunderbird.
christ1
  • Top 25 Contributor
2224 rješenja 16259 odgovora
Objavljeno
Try these steps. http://kb.mozillazine.org/Compacting_folders#Real_fix

Vlasnik pitanja

christ1, the trouble is, it's not just the Inbox that's having a problem. For instance when I'm composing a reply, TB is unable to copy the message to Drafts. And if I select a message in some random folder and try to move it to some other random folder, TB does nothing.

christ1, the trouble is, it's not just the Inbox that's having a problem. For instance when I'm composing a reply, TB is unable to copy the message to Drafts. And if I select a message in some random folder and try to move it to some other random folder, TB does nothing.
christ1
  • Top 25 Contributor
2224 rješenja 16259 odgovora
Objavljeno

Just to rule this out as a potential cause of the problem, can you try to start Thunderbird in safe mode?

http://support.mozillamessaging.com/en-US/kb/safe-mode

The suggestions given so far were more or less assuming a local problem with your profile, or some sort of corruption. May be this assumption was wrong.

What is your account type, POP or IMAP?

Just to rule this out as a potential cause of the problem, can you try to start Thunderbird in safe mode? http://support.mozillamessaging.com/en-US/kb/safe-mode The suggestions given so far were more or less assuming a local problem with your profile, or some sort of corruption. May be this assumption was wrong. What is your account type, POP or IMAP?

Vlasnik pitanja

christ1, the first reply I got suggested Safe Mode, and as I said above, I tried it and the problem still happened.

I have 4 POP accounts and one IMAP.

christ1, the first reply I got suggested Safe Mode, and as I said above, I tried it and the problem still happened. I have 4 POP accounts and one IMAP.
christ1
  • Top 25 Contributor
2224 rješenja 16259 odgovora
Objavljeno

With which of those 5 accounts do you see the problem?

With which of those 5 accounts do you see the problem?

Vlasnik pitanja

I see the problem in all of the accounts.

I see the problem in all of the accounts.
christ1
  • Top 25 Contributor
2224 rješenja 16259 odgovora
Objavljeno

I have no other ideas than trying with a new profile. Create a new profile using profile manager, and set-up one account at a time. Verify if you still see problems after setting up each account.

https://support.mozilla.org/en-US/kb/using-multiple-profiles

Also use profile manager to start Thunderbird with the new profile.

I have no other ideas than trying with a new profile. Create a new profile using profile manager, and set-up one account at a time. Verify if you still see problems after setting up each account. https://support.mozilla.org/en-US/kb/using-multiple-profiles Also use profile manager to start Thunderbird with the new profile.
ec91066 0 rješenja 2 odgovora
Objavljeno

I can delete messagen in safe mode. Don't know if this can help, I got these warnings:

(process:14159): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(thunderbird:14159): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(thunderbird:14159): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(thunderbird:14159): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(thunderbird:14159): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised

Then I started Thunderbird in safe mode with these options: - Disable all add-ons; - Reset all toolbars and controls.

It's working fine, but extensions and themes are disabled. Enabled extensions one by one and no problem.

I can delete messagen in safe mode. Don't know if this can help, I got these warnings: (process:14159): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed (thunderbird:14159): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised (thunderbird:14159): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised (thunderbird:14159): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised (thunderbird:14159): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised Then I started Thunderbird in safe mode with these options: - Disable all add-ons; - Reset all toolbars and controls. It's working fine, but extensions and themes are disabled. Enabled extensions one by one and no problem.

Izmjenjeno od strane ec91066