Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

not secure settings

  • 13 odgovori
  • 88 ima ovaj problem
  • 46 views
  • Posljednji odgovor poslao Earwiggherd

more options

Hello,

I tried using Google Translate to translate several asian websites in the past but every time I try to get them translated it says; This page was not retrieved from its original location over a secure connection.

These sites are not related or anything and I found it very strange. So I tried using the google translate in IE and it work fine. So I figured well maybe it is the site itself but even obvious secure websites such as news pages do not get translated with the same message.

I remember in IE when I first used it it asked me for some permission thing; if it could translate anything or just secure bits. So perhaps I pressed it wrong in FF in the past and that somehow even secure is seen as insecure.

How can I fix this problem? I looked at the about:permissions site but google translate is not amongst the list nor is any of the sites I want to have translated.

Resetting might be an option but I will lose all my add ons then as well I guess and cannot back them up I am guessing here.

I am using windows 7 and my FF is completely up to date.

Hello, I tried using Google Translate to translate several asian websites in the past but every time I try to get them translated it says; This page was not retrieved from its original location over a secure connection. These sites are not related or anything and I found it very strange. So I tried using the google translate in IE and it work fine. So I figured well maybe it is the site itself but even obvious secure websites such as news pages do not get translated with the same message. I remember in IE when I first used it it asked me for some permission thing; if it could translate anything or just secure bits. So perhaps I pressed it wrong in FF in the past and that somehow even secure is seen as insecure. How can I fix this problem? I looked at the about:permissions site but google translate is not amongst the list nor is any of the sites I want to have translated. Resetting might be an option but I will lose all my add ons then as well I guess and cannot back them up I am guessing here. I am using windows 7 and my FF is completely up to date.

Izabrano rješenje

Okay I have found a solution. There is also a google translate tool in the addons and somehow that one manages to work fine. So I will be using that one in the future which is also what I recommend other people to if they have the same problem.

Pročitajte ovaj odgovor sa objašnjenjem 👍 1

All Replies (13)

more options

Just to update this problem:

I tried resetting Firefox with the Help -> Troubleshooting Information.

But that doesn't solve the problem.

more options

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

more options

And just so that other people can try it for themselves; http://www.nu.nl/

Which is a basic news website in the netherlands for example does not load.

Neither does: http://www.bbc.com/news/

Perhaps because it will only do https. But how do I fix that?

more options

I think not so i enter in the two links that you said and i translate normal.

http://translate.google.com.br/translate?hl=pt-BR&sl=nl&tl=en&u=http%3A%2F%2Fwww.nu.nl%2F

Izmjenjeno od strane Diego Victor

more options

oh man I clicked the solved button int he mail by accident.

If I click your link then it also works for me which makes no sense. Perhaps because I did a full reinstall of firefox just now but also the other links seem to work.

more options

Hmm if I go to the site normally from google.com the usual english version and then to translate then it repeats all over again. Perhaps it is a google problem after all; as I noticed you use the .br version. But sometimes it fails if I use the usual navigational route then as well. Such a strange problem.

more options

No problem, Now you can use the translator or still not? Try translate more websites, then tell us if you have any problem again,

but if the problem was the google i also was with the problem!

Please post the link of addon, if you still want solve the problem try check your plugins: Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

Izmjenjeno od strane Diego Victor

more options

Odabrano rješenje

Okay I have found a solution. There is also a google translate tool in the addons and somehow that one manages to work fine. So I will be using that one in the future which is also what I recommend other people to if they have the same problem.

more options

Last one thank you Diego for the quick responses and have a nice day. You really helped me out here.

more options

I've found EXACTLY why you have this problem. I could even reproduce the effect in ANY browser, so this is NOT a Firefox problem, it's a Google problem. In fact, the error message "This page was not retrieved from its original location over a secure connection" is actually issued by the Google web page, not the browser. The culprit is the "S" in the HTTPS web address, which stand for "secure".

If you click on "translate" from HTTPS://google.XXX, any website that DOESN'T have an HTTPS equivalent (many don't) WILL NOT translate for security reason. That's why the Google error message mention "over a secure connection". That's also why the test page provided by Diego Victor ( http://translate.google.com.br/translate?hl=pt-BR&sl=nl&tl=en&u=http%3A%2F%2Fwww.nu.nl%2F ) did work, because it's NOT an HTTPS Google translate address.

To solve your problem, you must initiate a translation from the non-secure HTTP://google.XXX address and it will work with ANY website and ANY browser.

NOTE: Google should really clarify this cryptic error message "This page was not retrieved from its original location over a secure connection" and mention that it could work from a non-HTTPS address... BAD GOOGLE!!!

Regards,

Ramon

more options

Many people consider it a Firefox bug. It's called Mixed Content blocking, and it started in Firefox 23.

https://blog.mozilla.org/tanvi/2013/04/10/mixed-content-blocking-enabled-in-firefox-23/ https://bugzilla.mozilla.org/show_bug.cgi?id=873349

Google is strongly pushing all of its services to HTTPS default, and soon it won't be possible to fall back to a non-HTTPS version. This is a serious problem Mozilla needs to fix, and they need your input on how it's affecting you.

more options

Good detective work, Ramon! And good follow-up Silverbacknet!

I have Google as my Firefox home page and in order to get it to work how I want, I have to be logged in, so the URL is indeed the secure version: https://www.google.co.uk/.

I often get caught out when I try to type in a web address manually and just edit the Google one. I doesn't work and then I remember I should have removed the "s" from "https" as well. Really annoying!

I've just come across this problem with Google Translate today, and I would never have found your solution by myself.

So, in order to report this as a bug to Mozilla, can either of you please suggest how best to describe the problem and where to file it?

Izmjenjeno od strane Andy_P

more options

Hey, I'm a computer dummy, but after reading the above posts, I just solved the Google Translation problem by back-spacing out the "s" in "https."

I went to Google Translate. Copied the website address into the to-be-translated box. Clicked "translate." Got the message: "This page was not retrieved from its original location over a secure connection."

Then I went up to the address bar and got rid of the "s" in "https://translate". Then I hit "Enter". The French website I entered came up immediately, translated into English.

At the top of the page was this message: "Translated in Safe Mode. This may cause problems with some websites, especially those that use plugins like Flash." I didn't notice any problems in the particular website Google translated for me.