Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My Firefox keeps on saying This Connection is untrusted

  • 32 odgovori
  • 1080 ima ovaj problem
  • Posljednji odgovor poslao Fox_1923

more options

Whenever I try to go to google, Facebook, YouTube, the Firefox customize website, or any website it keeps on saying this connection is untrusted. Before it was working fine and not it's not, I tried uninstalling and stalling it again and nothing. I tried resetting it and nothing. Nothing I do seems to work. Anyone please help?

All Replies (20)

more options

In order to be able to find the correct solution to your problem, we require some more non-personal information from you. Please do the following:

  • Click the Firefox button at the top left, then click the Help menu and select Troubleshooting Information from the submenu. If you don't have a Firefox button, click the Help menu at the top and select Troubleshooting Information from the menu.

Now, a new tab containing your troubleshooting information should open.

  • At the top of the page, you should see a button that says "Copy text to clipboard". Click it.
  • Now, go back to your forum post and click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

Thanks in advance for your help!

more options

Application Basics

Name: Firefox Version: 24.0 User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0


Name: McAfee SiteAdvisor Version: 3.6.3 Enabled: false ID: {4ED1F68A-5463-4931-9384-8FFF5ED91D92}

Name: TopArcadeHits Version: 1.0 Enabled: false ID: {0113D088-8ED1-468C-B225-585A9C53B5E3}

Name: Wajam Version: 1.26 Enabled: false ID: {5a95a9e0-59dd-4314-bd84-4d18ca83a0e2}

Important Modified Preferences

browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.disk.smart_size_cached_value: 358400 browser.places.smartBookmarksVersion: 4 browser.startup.homepage_override.buildID: 20130910160258 browser.startup.homepage_override.mstone: 24.0 extensions.lastAppVersion: 24.0 gfx.direct3d.last_used_feature_level_idx: 0 network.cookie.prefsMigrated: true places.database.lastMaintenance: 1382170620 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf privacy.cpd.downloads: false privacy.cpd.formdata: false privacy.cpd.history: false privacy.cpd.sessions: false privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.timeSpan: 0 storage.vacuum.last.index: 0 storage.vacuum.last.places.sqlite: 1382170620


Adapter Description: AMD Radeon HD 7640G Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64 Adapter RAM: 512 Device ID: 0x9903 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.16581) Driver Date: 12-19-2012 Driver Version: GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 10 Vendor ID: 0x1002 WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 7640G Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: false AzureCanvasBackend: direct2d AzureContentBackend: direct2d AzureFallbackCanvasBackend: cairo


Incremental GC: true


Activated: false Prevent Accessibility: 0

Library Versions

NSPR Expected minimum version: 4.10 Version in use: 4.10

NSS Expected minimum version: 3.15.1 Basic ECC Version in use: 3.15.1 Basic ECC

NSSSMIME Expected minimum version: 3.15.1 Basic ECC Version in use: 3.15.1 Basic ECC

NSSSSL Expected minimum version: 3.15.1 Basic ECC Version in use: 3.15.1 Basic ECC

NSSUTIL Expected minimum version: 3.15.1 Version in use: 3.15.1

more options

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.


Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Check out why the site is untrusted (click "Technical Details to expand that section) and if this is caused by a missing intermediate certificate then see if you can install this intermediate certificate from another source.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer of the certificate.

You can see more Details like intermediate certificates that are used in the Details pane.

If "I Understand the Risks" is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab".

Note that some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.
Also if you are using a proxy then this proxy can send its own certificate.

more options

I've tried safe mode and still having the same problems and I only have three extensions. I don't know what's causing this cause it was working just an hour ago or so.

more options

hello, first please make sure that the date & time is set correctly on your system.
if this doesn't solve the issue (or it is already set properly), could you tell us which error code is shown under technical details on the error message and when you inspect the certificate which issuer information it does contain (see screenshot)?

"This Connection is Untrusted" error message appears - What to do

in addition, probably two of your installed addons (toparcadehits, wajam) are adware, please remove them or keep them disabled and run a full scan of your system with different security tools like the free version of malwarebytes and adwcleaner.

more options

The date and time are set right. Wajam and toparcadehits are disable

more options

Did you check who is the issuer of the certificates?

You can also check the connection settings.

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

more options

How do I check the issuer of the certificates?

more options

You can look at my above reply:

more options

this problem when i change my motherbord , Happened. i solved this , by set the time & date in windows & mainbord time in bois . it's fixed.

more options

Check and see if your internal clock is right. I just encounted this problem again and it did it cross browser. Its because the system time doesnt match the time issued on the security certificates which are current.

more options

I have this issue too. Firefox is keep saying untrusted connection to Google and Facebook!

I formatted my computer but nothing changed!

Also some websited doesn't shown properly.

Please help'

more options

My firefox,


 "application": {
   "name": "Firefox",
   "version": "27.0",
   "userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0",
   "supportURL": ""
 "crashes": {
   "submitted": [],
   "pending": 0
 "modifiedPreferences": {
   "accessibility.typeaheadfind": true,
   "browser.cache.disk.capacity": 358400,
   "browser.cache.disk.smart_size.first_run": false,
   "browser.cache.disk.smart_size.use_old_max": false,
   "browser.cache.disk.smart_size_cached_value": 358400,
   "browser.places.smartBookmarksVersion": 4,
   "browser.sessionstore.upgradeBackup.latestBuildID": "20140109165205",
   "browser.startup.homepage_override.mstone": "27.0",
   "browser.startup.homepage": "",
   "browser.startup.homepage_override.buildID": "20140109165205",
   "browser.tabs.warnOnOpen": false,
   "dom.mozApps.used": true,
   "extensions.lastAppVersion": "27.0",
   "font.internaluseonly.changed": true,
   "gfx.direct3d.last_used_feature_level_idx": 0,
   "network.cookie.prefsMigrated": true,
   "places.database.lastMaintenance": 1389444820,
   "places.history.expiration.transient_current_max_pages": 104858,
   "plugin.importedState": true,
   "plugin.state.npitunes": 0,
   "plugin.disable_full_page_plugin_for_types": "application/pdf",
   "plugin.state.npwlpg": 1,
   "plugin.state.npgoogleupdate": 0,
   "plugin.state.npgeplugin": 1,
   "privacy.donottrackheader.enabled": true,
   "privacy.sanitize.migrateFx3Prefs": true,
   "storage.vacuum.last.places.sqlite": 1389444819,
   "storage.vacuum.last.index": 0
 "graphics": {
   "numTotalWindows": 1,
   "numAcceleratedWindows": 1,
   "windowLayerManagerType": "Direct3D 10",
   "windowLayerManagerRemote": false,
   "adapterDescription": "AMD Radeon HD 5800 Series",
   "adapterVendorID": "0x1002",
   "adapterDeviceID": "0x689e",
   "adapterRAM": "1024",
   "adapterDrivers": "aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64",
   "driverVersion": "",
   "driverDate": "12-6-2013",
   "adapterDescription2": "",
   "adapterVendorID2": "",
   "adapterDeviceID2": "",
   "adapterRAM2": "",
   "adapterDrivers2": "",
   "driverVersion2": "",
   "driverDate2": "",
   "isGPU2Active": false,
   "direct2DEnabled": true,
   "directWriteEnabled": true,
   "directWriteVersion": "6.2.9200.16492",
   "webglRenderer": "Google Inc. -- ANGLE (AMD Radeon HD 5800 Series Direct3D9Ex vs_3_0 ps_3_0)",
   "info": {
     "AzureCanvasBackend": "direct2d",
     "AzureSkiaAccelerated": 0,
     "AzureFallbackCanvasBackend": "cairo",
     "AzureContentBackend": "direct2d"
 "javaScript": {
   "incrementalGCEnabled": true
 "accessibility": {
   "isActive": false,
   "forceDisabled": 0
 "libraryVersions": {
   "NSPR": {
     "minVersion": "4.10.2",
     "version": "4.10.2"
   "NSS": {
     "minVersion": "3.15.4 Basic ECC",
     "version": "3.15.4 Basic ECC"
   "NSSUTIL": {
     "minVersion": "3.15.4",
     "version": "3.15.4"
   "NSSSSL": {
     "minVersion": "3.15.4 Basic ECC",
     "version": "3.15.4 Basic ECC"
   "NSSSMIME": {
     "minVersion": "3.15.4 Basic ECC",
     "version": "3.15.4 Basic ECC"
 "userJS": {
   "exists": false
 "extensions": [
     "name": "Anti-Banner",
     "version": "",
     "isActive": true,
     "id": ""
     "name": "DownloadHelper",
     "version": "4.9.21",
     "isActive": true,
     "id": "{b9db16a4-6edc-47ec-a1f4-b86292ed211d}"
     "name": "Forecastfox",
     "version": "2.2.2",
     "isActive": true,
     "id": "{0538E3E3-7E9B-4d49-8831-A227C80A7AD3}"
     "name": "Content Blocker",
     "version": "",
     "isActive": false,
     "id": ""
     "name": "Kaspersky URL Advisor",
     "version": "",
     "isActive": false,
     "id": ""
     "name": "Safe Money",
     "version": "",
     "isActive": false,
     "id": ""
     "name": "Virtual Keyboard",
     "version": "",
     "isActive": false,
     "id": ""


more options

Check the date and time on your pc. If its right, then idk what else it could be. If the time, especially the year/month/day is off, then none of the security certificates will be valid in your computers eyes, causing all of thse errors. Could be that your internal clock battery is dead or something.

What is the current time and date on your pc?

more options

My pc's clock is fine, it's syncronized with microsoft's.

more options

this is how I see this page by the way. as I said, I formatted my computer, plus I tried aurora and FF 26 (I was on 27 beta) Nothing changed...

note: also I cant see the image that I upload... Its pathetic... note 2: I realized I couldn't upload the image, here it is:

Izmjenjeno od strane Fox_1923

more options

@Fox_1923 chrome or IE works?

more options

yes IE works.

by the way, no one mentioned error code, its: sec_error_untrusted_issuer

Izmjenjeno od strane Fox_1923

more options

Hi Fox_1923, have you added any exceptions? If so, please look up the issuer on one or two of them to learn more about the source of this issue.

orange Firefox button (or Tools menu) > Options > Advanced > Certificates mini-tab > "View Certificates" button > Servers tab

Click a certificate and use the View button. The kind of issuer you might find is:

  • Name associated with your security software, such as ESET, BitDefender, etc.
  • Sendori (indicates unwanted software from Sendori)
  • FiddlerRoot (indicates unwanted software named similarly to BrowserSafeguard, BrowserSafe, SafeGuard)
  • Something else
  1. 1
  2. 2