Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YouTube videos will not load in Firefox

  • 3 odgovori
  • 20 ima ovaj problem
  • 19679 views
  • Posljednji odgovor poslao JHW_71

more options

Hi,

I cannot get YouTube videos to play in my desktop's Firefox browser. I'm running Windows 7 64-bit with Firefox 24.0.

I have searched for solutions to the problem, and tried all of these:

-Completely clearing my cache -Disabling ad blocking software on youtube.com -Installing the latest version of RealPlayer -Installing the latest version of Flash Player

None of these have worked. Every YouTube video I load just displays a large black rectangle.

What should I do?

Izabrano rješenje

First, update your YouTube Center extension, which got two releases last month since the version you have installed. That might work using the built-in update check, or you may need to visit the Add-ons site:

  • Built-in: orange Firefox button (or Tools menu) > Add-ons > "gear" button > Check for Updates

Does that fix it?


Although the latest RealPlayer / RealDownloader should work with current Flash players, you may want to test with those disabled. You can do that on these two tabs:

orange Firefox button (or Tools menu) > Add-ons > Plugins category
orange Firefox button (or Tools menu) > Add-ons > Extensions category

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that make any difference?


Other standard steps for resolving Flash issues are as follows:

(1) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(2) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Pročitajte ovaj odgovor sa objašnjenjem 👍 0

All Replies (3)

more options

Odabrano rješenje

First, update your YouTube Center extension, which got two releases last month since the version you have installed. That might work using the built-in update check, or you may need to visit the Add-ons site:

  • Built-in: orange Firefox button (or Tools menu) > Add-ons > "gear" button > Check for Updates

Does that fix it?


Although the latest RealPlayer / RealDownloader should work with current Flash players, you may want to test with those disabled. You can do that on these two tabs:

orange Firefox button (or Tools menu) > Add-ons > Plugins category
orange Firefox button (or Tools menu) > Add-ons > Extensions category

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that make any difference?


Other standard steps for resolving Flash issues are as follows:

(1) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(2) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

more options

Updating Youtube Center seems to have solved the problem, at least for now. Thank you!

more options

In the upper left corner of the URL link bar - there is a little gray shield.

LEFT CLICK IT and a drop down menu will appear - click on the selection that is marked KEEP BLOCKING - and choose - DISABLE PROTECTION ON THIS PAGE.

The videos should work now. It's a security feature that must be manually set by the user.

Hope it works!