Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't open PDF files in the browser. I've tried every fix mentioned and it still doesn't work!!!

  • 4 odgovori
  • 10 ima ovaj problem
  • 27957 views
  • Posljednji odgovor poslao naidipuz

more options

I have Windows XP. Using firefox as my browser. Suddenly, I can't open PDF files in the browser. I've tried all the fixes mentioned. Nothing works!!! Checked the plugin settings, checked Adobe Reader settings.

Izabrano rješenje

Is the problem that Firefox opens a blank tab, or that it forces you to download the file?

I assume you've tried switching viewers between the internal viewer and the Adobe plugin. If not, this article has the steps: View PDF files in Firefox or choose another viewer. Sometimes switching back and forth will correct an error in the settings file.

You also can rename or delete the settings file that stores these associations and have Firefox regenerate it. If the file is corrupted, this might be the only option that works. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Leaving that window open, make any Firefox window active and Exit the program (e.g., File menu > Exit or Firefox menu > Exit)

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Restart Firefox. Your PDF preference likely will be reset to the internal PDF viewer, but you can switch it to the Adobe plugin as described in the above-linked article.

Any improvement?

Pročitajte ovaj odgovor sa objašnjenjem 👍 4

All Replies (4)

more options

Odabrano rješenje

Is the problem that Firefox opens a blank tab, or that it forces you to download the file?

I assume you've tried switching viewers between the internal viewer and the Adobe plugin. If not, this article has the steps: View PDF files in Firefox or choose another viewer. Sometimes switching back and forth will correct an error in the settings file.

You also can rename or delete the settings file that stores these associations and have Firefox regenerate it. If the file is corrupted, this might be the only option that works. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Leaving that window open, make any Firefox window active and Exit the program (e.g., File menu > Exit or Firefox menu > Exit)

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Restart Firefox. Your PDF preference likely will be reset to the internal PDF viewer, but you can switch it to the Adobe plugin as described in the above-linked article.

Any improvement?

more options

I thought I got rid of the mime file the first time. However, I never exited out of Firefox first. When I properly exited out of Firefox and then deleted the mime file, it fixed the problem of downloading instead of displaying. Thanks for your help!

more options

Thanks for posting back that you fixed the problem. I marked jscher2000's reply as the solution.

more options

I already fixed it. I never exited out of Firefox before deleting the mime file. it works now.