Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox does not recognize jpgs for download to harddrives

  • 7 odgovori
  • 1 ima ovaj problem
  • 3 views
  • Posljednji odgovor poslao zeesmuse

more options

I have used Firefox for some years and have NEVER had this problem. Sometime yesterday, Mozilla on my laptop decide it no longer recognized jpgs. If I try to save a picture from the internet and it's a jpg - most are - it simply doens't save it. In the type file box, it's empty. It will save gifs, bmps, etc. I was curious if it was my laptop so I opened IE (cries) and I had no problem saving them. I can drag them to my desktop and then cut and paste where I want them to go, but I find that extremely inconvenient and a waste of time. I have dumped my cache and cookies, uninstalled and reinstalled to no avail. I mean, uninstall completely and rebooted - to nada. I hate IE with a passion and my forays with Chrome have been short-lived, but I really need a fix for this. Oh. And I'm computer illiterate so... My OS is Windows 7.

I have used Firefox for some years and have NEVER had this problem. Sometime yesterday, Mozilla on my laptop decide it no longer recognized jpgs. If I try to save a picture from the internet and it's a jpg - most are - it simply doens't save it. In the type file box, it's empty. It will save gifs, bmps, etc. I was curious if it was my laptop so I opened IE (cries) and I had no problem saving them. I can drag them to my desktop and then cut and paste where I want them to go, but I find that extremely inconvenient and a waste of time. I have dumped my cache and cookies, uninstalled and reinstalled to no avail. I mean, uninstall completely and rebooted - to nada. I hate IE with a passion and my forays with Chrome have been short-lived, but I really need a fix for this. Oh. And I'm computer illiterate so... My OS is Windows 7.

All Replies (7)

more options

Try to delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

more options

Where would I find this folder? I'm not seeing 'tools' on the version of Firefox that I have (not that that means it's not there - I'm simply stupid when it comes to software...)

more options

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

Nope. Didn't work.

more options

You can Inspect the MIME database with the registry editor (regedit.exe) and do a search for that MIME type (file extension) via Ctrl+F.
Be careful with editing the registry as there is NO UNDO possible: all changes are applied immediately.
You can export key(s) in the registry editor before making changes.

You can check specific file extension keys (e.g. .jpg) in the registry with the registry editor.

  • HKEY_CLASSES_ROOT\.xxx

You can check the linked MIME type in the MIME Database.

  • HKEY_CLASSES_ROOT\MIME\Database\Content Type
more options

This is too much work for something that worked just fine yesterday and in all honesty, is beyond my meager capabilities. I guess I get to give Chrome another shot. Bleh.

more options

And thank you for your time....