Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I go back to Google search results page, it takes me to a blank Google screen

  • 91 odgovor
  • 758 ima ovaj problem
  • 218027 views
  • Posljednji odgovor poslao dkcrotty

more options

For example, I click on one link after doing a Google search, then I decide to go back & check one of the other links. When I go back instead of seeing my Google results screen again, I have a blank Google screen. Then I have to put my search terms in all over again. This does not happen using Internet Explorer. Thanks for any help

Izabrano rješenje

I've been having the same problem, and looked for help on the Mozillazine.org site. No help there either, but I have found that when you get the blank screen, clicking on REFRESH, brings back the page you want.

Another solution for this issue is available here: https://support.mozilla.org/questions/970863?page=2#answer-485663

Added 'another solution' as per the request of jscher2000

Pročitajte ovaj odgovor sa objašnjenjem 👍 6

All Replies (20)

more options

Hi 05Glide, if you are getting the blank page, did you try the workarounds in this post: https://support.mozilla.org/questions/970863?page=2#answer-485663

The redirect from HTTP to HTTPS is the new normal for Google search. You do not need to sign in.

Google's interception of your clicking a result has been in place for several years. Usually it's too fast to notice, but at times the intermediate page/script is so slow that it becomes very obvious and annoying.

There are some anti-tracking add-ons that modify the Google results page so that the links go directly to the sites without the intermediate page. However, some anti-tracking add-ons can be too ambitious and prevent some sites from working correctly, so finding one that's "just right" could require some comparison shopping.

more options

Thanks jscher2000 -- I may just risk doing that because when I say this is an utter nuisance I mean it's a **nuisance**!!! It's not just happening daily...it happens all the time. As I move about in a site, if I click on something at a site, if I go back in a site, I am constantly having to change the setting to unprotect. While the blurb assures me that I can visit & leave the blocked setting, that's not entirely true. It affects any apps or interactive things within a site.

more options

Hey mungo17, and others, when it happens to me, I just LEFT CLICK on the BACK button and scroll down to the Google Saerch Result page I want. I sort of got used to this when going further and further away from my original Google start search. Used to hit the back button 3, 4, and 5 times to get back. But the good ole LEFT CLICK works. "Try it. You'll Like It."

more options

1. Open Safari 2. Do a Google search 3. Click on a link 4. Click back button 5. close Safari 6. Do steps 2-4 on Firefox.

more options

I had the same problem. Changing the setting from -1 to 0 for browser.sessionhistory.max_total_viewers seems to have fixed the problem. One difference for me is that I am using Ubuntu 13.10 rather than Windows. Just wanted to share that.

So glad to get that fixed. Pain in the derriere ;)

more options

How do I do that FreeBrrd? I'm not the savviest of computer users...

more options

Hi GingerH, FreeBrrd is referring to the about:config change to make sure that Google results are not blank when you go "Back." The detailed steps are described in this thread: https://support.mozilla.org/questions/970863?page=2#answer-485663

more options

GingerH - They could have made that just a tiny bit easier.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sessionhistory and pause while the list is filtered

(3) Double-click the browser.sessionhistory.max_total_viewers preference and change it to 0 (that's a zero).

more options

Thank FreeBrrd - It just gets worser & worser! LOL! When I typed in about.config it switched me to a Yahoo search first (??) & on the second attempt I ended up with this message?

The page you requested cannot be found or is not available right now. This can be due to temporary connectivity issues or a misspelled URL. Please check the spelling or try again later.

To disable Domain Advisor, uninstall Anti-phishing Domain Advisor (Powered by Panda Security) in your Control Panel -> Add/Remove Programs. Warning: This will also remove your anti-phishing protection against phishing and malware sites.

more options

Did you type . or : ?

about:config colon not period

more options

GingerH -

Better if you cut and paste rather than type so you do not make any errors. Like 05Glide wrote: "Did you type . or : ? about:config colon not period"

highlight it and then press control c or highlight and select edit copy.

Keep trying. It works. Keep asking if you have problems.

more options

GingerH -

I made a page where it is easier to select the text to copy. I hope this helps. Just click in the green box and the text will be highlighted. You still need to select edit / copy.

http://www.DekatoDesigns.net/stuff/google_blank_fix.html

more options

Thanks Ginger, it worked for me!

more options

OMG! Thanks again but you are not going to believe this...or maybe you are. I got in with the config: this time but when I searched for 'searchhistory, I don't have one!!! My list jumps from services.sync.userURL to signed.applets.codebase_principal_support

Maybe I have more problems than I thought?

more options

Ginger H

You have to copy what is in the text. It's not "searchhistory". It's browser.sessionhistory.max_total_viewers or at least sessionhistory. You have to have it exactly as typed here.

Use this link, click on the green box, click on edit / copy and paste the exact thing into the search.

http://www.dekatodesigns.net/stuff/google_blank_fix.html

Izmjenjeno od strane FreeBrrd

more options

I HAD the same problem.. disappearing search page, once returning from a link on the page. I UPDATED my copy of Malwarebytes and ran it (quick scan), whereupon it found 4 'episodes', all "pup" type occurrences in the registry ..had it remove all 4, and now google seems to perform as it used to in Firefox... You don't HAVE Malewarebytes?? It's a free download if you google: "download malwarebytes free cnet" install, update, and in the "Settings" tab, set it to always MARK all occurrences of "PUP" when found. You'll not regret it!

more options

I fixed this problem by going to Help --> Troubleshooting Information and running "Reset Firefox...". This kept my profile (bookmarks, toolbars, etc) intact.

more options

Hi jernest1 and others reading, some toolbars will NOT survive a Reset. In particular, the extensions that are installed specifically into your current Firefox profile will not be retained after Reset. The ones installed by external software, like your security software, will be retained.

To know in more detail what you keep and what you lose, please see this support article: Refresh Firefox - reset add-ons and settings.

And if you hate the results of a Reset, look for a folder on your desktop named Old Firefox Data and try the recovery steps in this post: https://support.mozilla.org/en-US/que.../981788#answer-516935.

more options

Thanks for the ...viewers fix:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionhistory.max_total_viewers preference and change it to 0 (that's a zero).

What an annoying bug this was. As some noted, it had to do with the zoom (ctrl +). Silly that we had to go thru this to fix a major bug in a major browser. Hello Mozilla? Anybody home? I almost switched to Chrome over this ...

Izmjenjeno od strane tvmccorm

more options

Thanks TVMCCORM -- Yes, it is MOST annoying & YES, I too almost switched to Chrome which I hate with a passion...showing you just where Firefox is standing on my 'favorites' list right about now. I'm hanging in here but one more of these "you fix it, we can't be bothered" sessions & I'm out of here!

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5