Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I'm only getting one quarter of a screen on Flash Player on Firefox.

  • 60 odgovori
  • 105 ima ovaj problem
  • 35394 views
  • Posljednji odgovor poslao forrie

more options

Only the upper left quadrant of the Flash Player screen has content. The rest of the screen is either blank or the original static image. This occurs on YouTube and any website that has Flash Player content. Computer is a Macbook Pro Retina using OSX 10.8.4. I've uninstalled and reinstalled Flash Player (twice) and uninstalled and reinstalled Firefox. The problem doesn't occur when I'm using Safari.

Izabrano rješenje

This solved it for me. After selecting "Use hardware acceleration when available" in Firefox Advanced preferences, reboot Firefox - and viola - now see the other three quarters...

Pročitajte ovaj odgovor sa objašnjenjem 👍 11

All Replies (20)

more options

Hi davebesag, the bug I linked to in this post had development activity this past Friday. If it's fixed in the next couple of weeks, it could make it into Firefox 24 (due out mid-September).

more options

Exactly the same issue (Retina screen and suddenly quarter-screen on Flash videos). No issue on Safari and Chrome. I did everything including updating Adobe Flash, but there was no luck. Finally, I have downgraded to v22.0b6 and worked fine!

more options

Hi analysisman, if you visit the other first page of this thread using the link above, you can find information on how to "vote" for the bug to be fixed. According to the last post in the bug, it may be fixed in Firefox 26. Sometimes this can be moved up.

Also, just a note that Firefox 22.0 was the final release, and 22.0b6 was the 6th beta test release, which preceded the final release. Probably not a big difference in functionality or reliability. However, Firefox betas will try to upgrade to a new beta, which would be Firefox 24.

Izmjenjeno od strane jscher2000

more options

I also have the same problem - OSX 10.8.4 on a Retina Pro My solution is just to load up Safari...rather than downgrading. Annoying since it also affects my banking access. Don't see where to elevate the fix priority.

Izmjenjeno od strane alport

more options

Are Firefox 'Jumping the Shark'? I'm getting e-mail updates on this topic despite my email preferences all being unchecked on 'Change your email preferences'. I've now gone for 'Unsubscribe from these emails'. Am I missing something or are Firefox losing the plot?

more options

Hi davebesag, if you reply in a thread, you are subscribed to email updates for that thread. Changing your global settings after the fact doesn't undo that.

To ensure removal from this thread, visit the first page next to the original question, and look for Question Tools > Stop Email Updates.

Or maybe I'm wrong and you'll never see this??

Izmjenjeno od strane jscher2000

more options

I tried enabling 'Hardware acceleration' and it solved the issue.

more options

Odabrano rješenje

This solved it for me. After selecting "Use hardware acceleration when available" in Firefox Advanced preferences, reboot Firefox - and viola - now see the other three quarters...

more options

Thanks to all for your help with this. Checking "hardware acceleration" in Firefox advanced preferences solved it.

more options

Guys, What FF version are you using with "hardware acceleration"?

more options

Analysisman - I'm using FF 23.0.1.

more options

Checking "hardware acceleration" in Firefox advanced preferences solved this issue. Thanks to all for your help.

more options

The tip about hardware acceleration was a great lead. There are some bug reports specifically on that issue, in particular: 903296 – With hardware acceleration off, Flash displayed only in the top left quarter on Mac OSX. But no indication yet of when it will be fixed for those who can't enable hardware acceleration due to graphics card driver incompatibilities.

more options

Wow, thanks for the hardware acc. tip, works for me!

more options

I have had this same problem and replicated both the cause and the solution several times over the past few days.

The specs: 15" retina Mac Book Pro running OS 10.8.3.

The problem: Only the top quarter of Flash videos are shown, both when static and playing. They can play back, though obviously, any controls on the bottom half of the video are obscured. This happens when running FF 23. And it only occurs in Firefox; I do not have similar problems in Safari.

The solution: Downgrade to FF 22. Every time I've switched back to Firefox 22.0 from 23, it's worked perfectly. Every time I'm upgraded to 23, the problem recurs.

Hope this helps others. It took me lots of searching and trying false fixes before I got the answer. (Edited to add: Ftr, hardware acceleration changes did not help me at all).

Jen.

Izmjenjeno od strane reporterjen

more options

Does Firefox 24 work, released today?

more options

It is also fixable by setting gfx.hidpi.enabled pref to -1. Which is related to hardware acceleration.

more options

Hi all,

no, I have ff 24.0 and still the same problem. HW acc also did not solve it for me.

more options

Hi reporterjen and mr_drlove, it's possible to turn on hardware acceleration but for Firefox not to support that feature with your graphics card drivers. Can you check whether you have any accelerated windows on the following page (either):

  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Graphics section and check the line "GPU Accelerated Windows" to see if you have 0 or more.

more options

I'm not able to post the output from about:config, I got the message:

"Please keep the length of your content to 10,000 characters or less. It is currently 14,920 characters."

Do you have a work a round for that?

ciao mr_drlove

  1. 1
  2. 2
  3. 3