Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Embedded images not displayed in Gmail

  • 27 odgovori
  • 42 ima ovaj problem
  • 17377 views
  • Posljednji odgovor poslao moz101mo

more options

I use Gmail and occasionally receive emails which contain embedded images rather than attachments. These images do not appear when I use Gmail from Firefox, but they do appear when I use Gmail from Chrome or IE. If I forward the mail then the images appear in the forward mail window. Have tried all of the recommended actions but with no success.

All Replies (7)

more options

Hi All, I think I can shed *some* light.

I have a business website, and for some reason Firefox won't display the images of my site.

Furthermore, when in GMail on Firefox I try to view an email with an image hosted on the same company website, then it won't display. Yet, if I use IE from the same computer then it works.

If I use a different install of Firefox on a different PC (same network) then it works.

So it appears that a specific install of Firefox doesn't like displaying images from a specific URL, whether linked in an email or directly viewing the website.

I have a feeling if I flush my Cookies etc, then it might start working again. Haven't tried it yet.

Try my variations and feedback.

Regards James

more options

Hi strewth_uk, issues when directly viewing your website usually have a different origin than issues with images embedded in email messages. However, perhaps your problems have the same underlying cause, whether related to image permissions or an extension. Please check out these articles:

more options

I wonder if the newly changed (in 25) mixed content security default and code is causing this.

Open a tab or launch FF, and type in about:config Agree. In the box, type mixed The setting for active content is probably true. Or maybe the one that says display content.

You can try clicking once on one of the other, to make it false, and see if it helps. I'm having trouble with this also on google search results with images.

Anyway, I don't know if you have to shut down all Firefox instances, but it would be good to try if just changing the setting has no effect.

Be careful, and remember what you change, so you can put it back.

more options

Hi moz101mo,

I tried as you suggested and it made no difference to the images being displayed.

Cheers

more options

I have a possibly similar problem with certain images in google search results, and since google is showing your images on its web page displaying your email, maybe it is related... https://support.mozilla.org/en-US/questions/977249#answer-501288

more options

Note that such images might be embedded using cid: (Content-ID) type links that do not work in Firefox and need to be converted to proper HTML code by the mail service.

Do you see proper links to such images if you look in Tools > Page Info > Media?

more options

FF 25.0.01 came oua few days ago, and it seems to have fixed MY image display problems, but note that some others say it caused them some display issues on certain sports related websites. I'm still running 25.0.01 without problems, though.

  1. 1
  2. 2