X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how to force firefox to start with home page and not page(S) that crashed afer rebooting PC?

Posted

So I go to some page. and everything locks up. I have to hard reboot, but when I restart my PC it tries to open all the pages (including what is causing the issue) when I restart the pc. How do I force firefox to start with the home page? Please note I have the home page it set to mail.yahoo.com; but it is not working; it tries to open all the pages that were open when I had to hard reboot.

Please help ! Thanks!

Chosen solution

There are two settings you could consider changing. If you change both, the second overrides the first.

  • When restarting after a crash, present a screen listing earlier windows and tabs so you can choose which ones to restore, if any: set browser.sessionstore.max_resumed_crashes to 0 (zero)
  • Never try to resume previous session after a crash; always go to the home page(s): set browser.sessionstore.resume_from_crash to false

Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box in that tab, type or paste sessions and pause while the list is filtered

(3) Double-click the preference you want to change. In the first case, change the 1 to a 0 (a zero) and OK that. In the second case, double-clicking automatically toggles its value from true to false.

(4) You can close this tab now.

Hopefully Firefox will now behave as desired. Any luck?

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • 5.1.20125.0
  • iTunes Detector Plug-in
  • HP Product Detection Plugin
  • HP Active Check Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Proširenja

  • HP Detect 1.0.15.0 ({ab91efd4-6975-4081-8552-1b3922ed79e2})
  • Norton Toolbar 2013.3.3.19 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Norton Vulnerability Protection 11.3.0.9 - 5 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) 82945G Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2772
  • adapterDeviceID2:
  • adapterDrivers: igdumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 9-23-2009
  • driverDate2:
  • driverVersion: 8.15.10.1930
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) 82945G Express Chipset Family)
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.history_expire_days.mirror: 180
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://mail.yahoo.com/
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.urlbar.autocomplete.enabled: False
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • network.cookie.cookieBehavior: 1
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1367004702
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 53461
  • places.last_vacuum: 1301531400
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.siteSettings: True
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.promptOnSanitize: False
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.disable_button.openCertManager: False
  • security.disable_button.openDeviceManager: False
  • security.OCSP.disable_button.managecrl: False
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
2367 solutions 20953 answers

Chosen Solution

There are two settings you could consider changing. If you change both, the second overrides the first.

  • When restarting after a crash, present a screen listing earlier windows and tabs so you can choose which ones to restore, if any: set browser.sessionstore.max_resumed_crashes to 0 (zero)
  • Never try to resume previous session after a crash; always go to the home page(s): set browser.sessionstore.resume_from_crash to false

Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box in that tab, type or paste sessions and pause while the list is filtered

(3) Double-click the preference you want to change. In the first case, change the 1 to a 0 (a zero) and OK that. In the second case, double-clicking automatically toggles its value from true to false.

(4) You can close this tab now.

Hopefully Firefox will now behave as desired. Any luck?

jscher2000
  • Top 10 Contributor
2367 solutions 20953 answers

Now... why is Firefox locking up often enough for you to post this question? Do you see any pattern to it (e.g., Flash games)?

Depending on how Firefox is crashing, it might be recording some data about the crashes that you can view by typing about:crashes in the address bar and pressing Enter. Check out the "Get help fixing this crash" section of the following article for tips on how to use that information: Firefox crashes - Troubleshoot, prevent and get help fixing crashes.

Helpful Reply

THANKS!!! This will fix it I hope, it was exactly what I wanted! I changed setbrowser.sessionstore.resume_from_crash to false. (it was set to true)

To answer your second question... I have not figured out WHY it is doing this - it has happened twice this year only - but when it does I get into this look where some page makes it crash, then it restarts and tries to open the same page which again makes it crash... annoying enough for me to post this question to figure out how to prevent it!

Thank you, thank you, thank you!