Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to fix bookmark icons from reappearing in new browser windows despite having bookmark deiconizer enabled (Mac Snow Leopard/Firefox 20.0).

  • 39 odgovori
  • 14 ima ovaj problem
  • 3243 views
  • Posljednji odgovor poslao mcintyre89

more options

Ever since Firefox upgraded to 20.0, my enabled deiconizer doesn't work when I open a new browser window. Using Mac/Snow Leopard. I want those bookmark toolbar icons to disappear permanently! They are nothing but clutter.

All Replies (19)

more options

cor-el

It worked!

I tried to use your advice and created the initial file in Microsoft Word for Mac 2004, instead of TextEdit. It gave me a choice to save in "Text Only". All other steps were the same, except that resulting "userChrome.css" file is in "text" format (before it was with Safari icon and in Safari format (I do not know why).

ICONS IN FIREFOX 22 ARE GONE.

THANK YOU EVERYBODY WHO CONTRIBUTED TO THIS LINK.
more options

cor-el

It worked!

I tried to use your advice and created the initial file in Microsoft Word for Mac 2004, instead of TextEdit. It gave me a choice to save in "Text Only". All other steps were the same, except that resulting "userChrome.css" file is in "text" format (before it was with Safari icon and in Safari format (I do not know why).

ICONS IN FIREFOX 22 ARE GONE.

THANK YOU EVERYBODY WHO CONTRIBUTED TO THIS LINK.

more options

Good news! Managed to track down https://addons.mozilla.org/en-us/firefox/addon/roomy-bookmarks-toolbar/. If you go into preferences you can show labels, remove icons, and make the spacing normal. The spacing is still tighter than Deiconizer, but the icons bother me so much I don't care at all, and you can modify the labels if you want to space it out further.

Deiconizer worked fine for me until Firefox 22, but it's now permanently disabled and I'm unable to reinstall. Such a relief to find a solution.

more options

Thought I'd share this, I added this to userChrome.css

scrollbox#PlacesToolbarItems > toolbarbutton.bookmark-item > .toolbarbutton-icon {

 visibility:hidden; max-width:5px;

}

The icons are there but not visible, and thus are used to space out the bookmark labels. Max-width value can be adjusted depending on your spacing preference.

more options

I have no userChrome.css file to edit. I tried googling "how to create userChrome.css file" and didn't find a link to a Mozilla page with that information. It s extremely frustrating having to spend all this time trying to rid my bookmarks toolbar of these space-wasting icons. Why can't there just be a preference that the user can choose to turn on or off? This is ridiculous.

How can I create a userChrome.css file from scratch that I can then edit as described here? (Without then creating some other problem I have to waste time fixing...)

Thanks.

more options

Add code to the userChrome.css file below the default @namespace line.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

The customization files userChrome.css (interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

more options

Unfortunately, this doesn't help because I don't have a userChrome.css file. And I have checked the links that purport to show how to edit the userChrome.css files but they don't seem to tell me what to do if I don't have one to begin with. I did go to this page:

http://lxr.mozilla.org/seamonkey/source/suite/locales/en-US/profile/chrome/userChrome-example.css

But it didn't really seem to be what I need. I need a file to edit.

Of course, it is ridiculous that Mozilla makes one go through all this rigamarole when all that is needed is a preference in Appearances that would allow users to turn off the space-wasting icons.

more options

Hi FirefoxFrustration, Firefox doesn't include a userChrome.css file. You always have to create one if you want one.

One way to create the file is to create a new file in a text editor and save it to the desired location.

Another way is to create a blank file in that location then open and edit it. (I don't know how this works on Mac, but on Windows, when you are viewing the folder where you want the file, you right-click > New > Text Document and then change the name to the desired file name.)

more options

Hi jscher2000. But my question is, how do I create the userChrome.css file? Do I just open a blank text document in Text Edit in Mac and call it that? Or does that text document have to have certain code in it that I can then edit? And if the latter, where do I get that code in a format I can copy and paste, and then edit?

Thanks.

more options

Make sure that you create a text file and save it as such and not in rich text format (.rtf) or otherwise formatted.

The userChrome.css file only works as a plain text file.

more options

Hi FirefoxFrustration, yes, you open a blank text document in Text Edit in Mac and save as userChrome.css in a new chrome folder in your Firefox profile folder. Try this code:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
/* Hide icons for FOLDERS */
#PlacesToolbarItems .bookmark-item[type="menu"] .toolbarbutton-icon {
  display:none !important
}
/* Hide icons for SITES */
#PlacesToolbarItems .bookmark-item:not([type="menu"]) .toolbarbutton-icon {
  display:none !important
}
/* Add a bit of spacing */
#PlacesToolbarItems .bookmark-item {
  margin-left:3px !important; 
}
more options

Thanks, jscher2000. I did that, then quit Firefox , restarted my computer and reopened Firefox but the icons are still there.

Very frustrating. What are the programmers thinking? There is limited real estate there and it doesn't occur to them that some of us won't want to use it up with icons? Do the programmers not use these browsers themselves?

more options

Hi FirefoxFrustration, I'm not going to speculate on what others think is useful. I personally leave the favicons there since they provide a quick visual indication of the site -- except when they are just dotted outlines, but that's a different problem. To address the space issue, I create folders on the bar and put the less frequently used bookmarks in those folders.

Speaking of folders...

Can you check the folder location? The userChrome.css file needs to be in a chrome subfolder in your profile folder.

If that is correct, try to drag and drop the file onto an open Firefox tab and make sure it has a nice clean text layout and doesn't contain formatting codes.

more options

Hi jscher2000. My userChrome.css file is in the directory Macintosh HD/Users/*my user name*/Library/Application Support/Firefox/Profiles/chrome

I dropped the .css file on an empty open Firefox tab and it looks normal to me--I don't see any odd formatting (other than the oddness of computer code formatting generally). This is how it looks:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); /* Hide icons for FOLDERS */

  1. PlacesToolbarItems .bookmark-item[type="menu"] .toolbarbutton-icon {
 display:none 

} /* Hide icons for SITES */

  1. PlacesToolbarItems .bookmark-item:not([type="menu"]) .toolbarbutton-icon {
 display:none 

} /* Add a bit of spacing */

  1. PlacesToolbarItems .bookmark-item {
 margin-left:3px ; 

}

Thanks for your efforts in this, by the way.

more options

Your chrome folder is up a level from where it needs to be. To find your currently active profile folder use

Help > Troubleshooting Information > "Show in Finder" button

That's the folder where you want your chrome folder.

more options

Bingo! That did it. Thanks so much.

more options

Hey guys. I have tried all of the solutions here but nothing seems to be working for me.

Would somebody be able to help me with this? I need a step by step guide of what to do, as a complete lay person with no knowledge of coding or anything.


I got up to the stage where I have all of the code in a userChrome.css file inside a Chrome subfolder after clicking Help/TroubleShoot/Show in finder.

Every time I restart Firefox, the icons are still there and I'm not sure what I'm doing wrong.

Please help!

more options

Did you make sure to save the userChrome.css file as a plain text file and not as a .rtf (rich text file) or otherwise formatted?

more options

Yep, did everything the right way round, and scrutinised the thread for exactly what I should do.

It works now. I didn't change anything, but when I double clicked on the .css file, it opened up as a Microsoft Communicator file. I deleted Microsoft Communicator.

Now I have no icons.

RELIEF!

  1. 1
  2. 2