Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

the latest upgrade is not compatible. it says error run platform 17.0.1 is not compatible with min version >17.0 max version <17.0

  • 1 odgovor
  • 9 ima ovaj problem
  • 17 views
  • Posljednji odgovor poslao philipp

more options

the latest upgrade is not compatible and is not allowing me to open firefox. the error message says run error platform 17.0.1 is not compatible with min version >17.0 max version <17.0

the latest upgrade is not compatible and is not allowing me to open firefox. the error message says run error platform 17.0.1 is not compatible with min version >17.0 max version <17.0

All Replies (1)

more options

hello paisley157, this error might be caused by security programs such as zone alarm - please temporarily disable those programs for the following procedure:

  • download the full firefox setup file from getfirefox.com
  • uninstall firefox on the machine (but don't chose to delete your custom files & settings in the uninstaller!)
  • manually delete all remaining files in the firefox program folder, which usually resides in C:\Program Files (x86)\Mozilla Firefox\
  • reinstall firefox