Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After 4.0 upgrade cannot connect but IE8 can. Not a firewall issue.

  • 15 odgovori
  • 2 ima ovaj problem
  • 1 view
  • Posljednji odgovor poslao Xircal

more options

Immediately after upgrading to 4.0 (from the lastest 3.o version) I have not been able to connect to any addresses. The message is: "Firefox can't establish a connection to the server at www.yahoo.com." Despite this, IE8 still works.

Izabrano rješenje

It looks like our posts got crossed.

Anyway, I'll glad to hear you're up and running now.

Pročitajte ovaj odgovor sa objašnjenjem 👍 0

All Replies (15)

more options

It most likely is a firewall problem if you still can connect using IE8. See Fix problems connecting to websites after updating Firefox

more options

Xircal, I have gone through removing and re-selecting Mozilla in Windows Firewall, and that did not work. I turned off the firewall and that did not work.

???

I'm on a satellite connection (HughesNet) and we recently upgraded our service plan. Do you think the router has some issue similar to a firewall issue? The service guy never told us that there was a firewall on the router. If I don't have a firewall issue on the box running Mozilla then what else could there be?

Thanks ...

more options

Can you try doing the following please.

  • Open a Command Prompt (Run as Administrator) and then type: ipconfig /flushdns and hit Enter.

If it still doesn't work, click the Firefox button, go to Options | Options | Advanced | Network (tab) | Offline Storage menu, click the Clear Now button.

In the Advanced menu, General tab, uncheck the option "Tell web sites I do not want to be tracked". Some routers won't allow access to the menu if this option is enabled. That may possibly be the same for your satellite connection.

more options

Xircal, here's what I tried: 1. As admin: C:\Windows\system32>ipconfig /flushdns Successfully flushed the DNS Resolver Cache.

2. Offline Storage menu, click the Clear Now button

3. Check option Tell Websites I do not want to be tracked.

Still blocked though.

I downloaded Opera and it's having the same problem. I had never had an installation of Opera on this box before. So two of three browsers are blocked, and only IE8 gets a connection.

Any thoughts? Any Registry values that might be helpful?

more options

Can you do the following please.

  1. Use IE8 or 9 to Download Firefox 4.0.1. When you see the prompt, choose "Save" and save it to your desktop (do not choose "Run").

  2. Then go to Add/Remove Programs, scroll down to "Mozilla Firefox" and remove it, choosing to keep your bookmarks, customizations etc., (don't checkmark the box).

  3. Then reboot and delete the folder called "Mozilla Firefox" at this location: C:\Program Files\Mozilla Firefox

  4. Finally run the installation file you downloaded to the desktop earlier.

Your bookmarks, customizations etc., are maintained in a different location and will become available to you again once you complete the installation.

Then try and connect again.

more options

Thanks for hanging with me. This is a strange issue.

1. Uninstalled 4.0.0

2. Removed Program Files\Mozilla

3. Restarted

4. Installed 4.0.1

"Firefox can't establish a connection to the server at www.mozilla.com."

Izmjenjeno od strane pleblanc

more options

Xircal, I just tested my box on another network and found that the problem persisted. I guess that eliminates my router from the equation. Whatever it is seems to be local to the box itself.

Also the message I get from Opera is interesting:

"Connection closed by remote server"

Indeed, if this were a local block on port 80 there would be no chance to have the remote server close the connection. It's as if the remote listener is not receiving the request packets and so it decides to close the connection.

Izmjenjeno od strane pleblanc

more options

Go to Options | Options | Advanced | General tab | Accessibility menu and remove the checkmark from "Warn me when websites try to redirect or reload the page". This setting when enabled prevents Firefox from redirecting to another page or automatically reloading.

If the problem persists, try running Firefox in Diagnose Firefox issues using Troubleshoot Mode. If it functions properly in that configuration, then one of your add-ons is the culprit.

more options

Hi Xircal. I did the following:

1. Remove check mark from "Warn me when websistes try to redirect ...."

2. Start in Safe Mode.

Same result though.

more options

Xircal, I see "Checking for updates" when I go to Help | About Firefox. Doesn't that require a connection? It appears to get a connection and then it confirms that "Firefox is up to date".

This doesn't happen each time though. Sometimes it just says "Firefox is up to date" without checking. I don't know how it does that unless it's using time stamps to determine when it should check.

more options

I was trying to glean some info from Opera's explanation of the error you're seeing which is documented here: Connection closed by remote server, but that doesn't really explain why you can still connect using IE.

Which firewall or security software suite do you use?

more options

Firewall=Windows (but it's turned off)

Security Software=Malwarebytes' Anti-Malware, but I don't use it in real time mode (just scan occasionally.)

I just did a full scan but without incident.

Can you let me download a debug version? At this point it wouldn't be much of a bother compared to fishing blind.

more options

Xircal, I found the problem: The service for Norton 360 was not started. I started it and suddenly everything worked for FF.  ??? I have no functioning Norton on this machine. It was in demo form and installed when I bought the machine long ago, and I uninstalled it a long time ago. It left a service installed though, and the service was not getting turned on.

I have NO IDEA why this ignorant service exists after an uninstall or why it's needed for certain browsers. All I know is that if it's not started, certain browsers cannot create connections properly.

Thanks for all your help. I'm sorry to have bothered you for this. It's one of those ones that has very strange symptoms.

Thanks again. Let me know if you want me to test anything. I wonder if this is in a database anywhere because this is a major headache for a techie that has to start from scratch.

Paul

more options

I don't know if a debug would serve any useful purpose since I don't think anybody here would understand it, myself included. You might be better off submitting that to the satellite ISP.

Could you do the following please.

  1. In the location bar, type about:config and hit Enter.

  2. In the filter at the top, copy/paste the following: network.dns.disableIPv6

  3. Double click it to change it from False to True.

Close the tab and then try and connect again.

  1. If that doesn't make any difference, open about:config again and in the filter at the top, copy/paste the following: network.dns.disablePrefetch This will result in a blank page appearing, but this is intentional.

  2. Right click anywhere and choose New then Boolean.

  3. In the dialog box which appears, paste: network.dns.disablePrefetch again.

  4. Click OK and then in the next dialog box which appears, choose "true".

  5. Click OK and then close the tab.

Then try and connect again.

more options

Odabrano rješenje

It looks like our posts got crossed.

Anyway, I'll glad to hear you're up and running now.