X
Pritisnite ovdje da biste otišli na mobilnu verziju stranice.

Forum podrške

Firefox 4 beta is making unexpected use of swash characters in a font

Objavljeno

This appears to be new behaviour in the Firefox 4 beta; Firefox 3.6 is unaffected.

I've designed a site that makes use of the Adobe Warnock Pro font if it happens to be installed on the user's system. (Warnock Pro is a font family that Adobe supplied with Creative Suite 3.) It's obviously optional, and most visitors won't have it, but if it's present and enabled, it'll be used in preference to other alternatives (as specified in the CSS).

The site is here:

<http://occds.org>

The unexpected behaviour of Firefox 4 is that the OpenType alternative glyphs of this font are suddenly enabled! For example, an 'e' at the end of a word will have a little tail sticking out of it, whereas an 'e' within the same word does not: alternative glyphs with swashes appear all over the place. It's all very typographically clever, I'm sure, but I don't actually want this behaviour because it's distracting. It'd be one thing if it only happened in headings, but it also happens in the body text, where it's pretty unwelcome.

Does this constitute a bug? Is there some way of disabling this OpenType feature in the CSS for the site? I want Firefox 4 to display like Firefox 3 and every other browser in this respect.

This appears to be new behaviour in the Firefox 4 beta; Firefox 3.6 is unaffected. I've designed a site that makes use of the Adobe Warnock Pro font if it happens to be installed on the user's system. (Warnock Pro is a font family that Adobe supplied with Creative Suite 3.) It's obviously optional, and most visitors won't have it, but if it's present and enabled, it'll be used in preference to other alternatives (as specified in the CSS). The site is here: <http://occds.org> The unexpected behaviour of Firefox 4 is that the OpenType alternative glyphs of this font are suddenly enabled! For example, an 'e' at the end of a word will have a little tail sticking out of it, whereas an 'e' within the same word does not: alternative glyphs with swashes appear all over the place. It's all very typographically clever, I'm sure, but I don't actually want this behaviour because it's distracting. It'd be one thing if it only happened in headings, but it also happens in the body text, where it's pretty unwelcome. Does this constitute a bug? Is there some way of disabling this OpenType feature in the CSS for the site? I want Firefox 4 to display like Firefox 3 and every other browser in this respect.

Dodatni detalji o sistemu

Ovo se desilo

Svaki put kada se Firefox otvori

Ovo je počelo kada...

Affects Firefox 4; latest Firefox 3 is OK.

Instalirani priključci

  • Picasa plugin.
  • iPhoto6
  • Plugin for viewing Sibelius(tm) music scores http://www.sibelius.com
  • Office Live Update v1.0
  • RealPlayer Plugin
  • Java Plug-In 2 for NPAPI Browsers
  • 4.0.50401.0
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Contribute Plug-inInbrowser Editor Plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Shockwave Flash 10.1 r53
  • Speed Download Plugin. Allows downloads to be redirected to Speed Download
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Aplikacija

  • Korisnički agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

Više informacija

Application Basics
Name
Firefox
Version
4.0b6
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
DOM Inspector
2.0.8
true
inspector@mozilla.org
Web Developer
1.1.8
false
{c45c406e-ab73-11d8-be73-000a95be3b12}
Adobe Contribute Toolbar
6.0
true
{01A8CA0A-4C96-465b-A49B-65C46FAD54F9}
1Password extension for Firefox 3
3.4.3.BETA-2
false
firefox3@1password.com
1Password extension for Firefox 4
3.4.3.BETA-2
true
firefox4@1password.com
Firebug
1.5.4
false
firebug@software.joehewitt.com
Feedback
1.0.3
true
testpilot@labs.mozilla.com
Modified Preferences
Name
Value
accessibility.typeaheadfind
true
browser.history_expire_days.mirror
180
browser.link.open_newwindow
2
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage_override.buildID
20100914072643
browser.startup.homepage_override.mstone
rv:2.0b6
browser.tabs.autoHide
true
browser.tabs.warnOnClose
false
browser.zoom.full
false
extensions.lastAppVersion
4.0b6
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
128849
places.last_vacuum
1284189344
print.macosx.pagesetup-2
AAAYDTw/eG1sIHZlcnNpb249IjEuMCIgZW5jb2Rpbmc9IlVURi04Ij8+CjwhRE9DVFlQRSBwbGlzdCBQVUJMSUMgIi0vL0FwcGxlLy9EVEQgUExJU1QgMS4w…
print.print_bgcolor
true
print.print_bgimages
true
print.print_command
print.print_downloadfonts
false
print.print_evenpages
true
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_pagedelay
500
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
57
print.print_unwriteable_margin_left
25
print.print_unwriteable_margin_right
25
print.print_unwriteable_margin_top
25
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics

frboyer 0 rješenja 1 odgovora
Objavljeno

Korisan odgovor

The problem is still present in Firefox 6.0.2. The OpenType feature which is enabled by default in Firefox, and should not normally be, is 'cswh' (contextual swash). To disable it, add ' -moz-font-feature-settings: "cswh=0" ' to your CSS (can be placed in 'body' to disable it on whole page).

The problem is still present in Firefox 6.0.2. The OpenType feature which is enabled by default in Firefox, and should not normally be, is 'cswh' (contextual swash). To disable it, add ' -moz-font-feature-settings: "cswh=0" ' to your CSS (can be placed in 'body' to disable it on whole page).
cor-el
  • Top 10 Contributor
  • Moderator
17267 rješenja 156058 odgovora
Objavljeno

Korisan odgovor

See also: *https://developer.mozilla.org/en/CSS/-moz-font-feature-settings *http://hacks.mozilla.org/2010/11/firefox-4-font-feature-support/

Izmjenjeno od strane cor-el