Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Performing a TLS handshake

  • 6 odgovori
  • 1 ima ovaj problem
  • 1 view
  • Posljednji odgovor poslao pmf_168

more options

Hi.

Ever since I upgraded to version 123.0.1, I am constantly getting slowness on websites stuck in "Performing a TLS handshake..." Eventually the websites load, but it's frustrating. I have read about the various solutions and have tried the following: Disabled IPV6 Refreshed Firefox Reloaded Firefox Disabled and removed all extensions Restart in safe mode Create new profile

This was not happening in version 122 and before. Microsoft Edge does not have this problem, but I prefer to use Firefox. I am running Windows 11 Pro. Any ideas?

Thanks

Hi. Ever since I upgraded to version 123.0.1, I am constantly getting slowness on websites stuck in "Performing a TLS handshake..." Eventually the websites load, but it's frustrating. I have read about the various solutions and have tried the following: Disabled IPV6 Refreshed Firefox Reloaded Firefox Disabled and removed all extensions Restart in safe mode Create new profile This was not happening in version 122 and before. Microsoft Edge does not have this problem, but I prefer to use Firefox. I am running Windows 11 Pro. Any ideas? Thanks

Izabrano rješenje

I have set my DNS over HTTPS setting to OFF from the default and it has fixed the issue. I am using ExpressVPN's DNS servers for my queries. Like I mentioned earlier, this was not an issue for me in earlier versions of Firefox. Only since I upgraded to 123.0.1.

Thanks

Pročitajte ovaj odgovor sa objašnjenjem 👍 0

All Replies (6)

more options

Show the issue. What site(s) are you having issues with? Try this option and see if you have the same issue. https://www.howtogeek.com/399290/how-to-use-windows-10s-new-sandbox-to-safely-test-apps/ Who are you using for DNS What security software are you running?

Helpful?

more options

Hi,

It appears to be related to ExpressVPN. When I disconnect from the VPN, all is ok. Once connected, the issues happen. Is there setting in Firefox under DNS over HTTPS that I should be at. It currently is set at Default Protection.

Thanks

Helpful?

more options

Great detective work! If you have no further questions, mark your above answer as the resolution and have a nice day.

Helpful?

more options

Hi,

Is there setting in Firefox under DNS over HTTPS, or anywhere else that I should have set to allow me to browse while connected to my VPN and not be stuck on "Performing a TLS handshake"? The solution to disconnect defeats the purpose of having a VPN.

Thanks

Helpful?

more options

I don't know the answer to your question but this link may help.

https://support.mozilla.org/en-US/kb/dns-over-https#w_configure-doh-protection-settings

Helpful?

more options

Odabrano rješenje

I have set my DNS over HTTPS setting to OFF from the default and it has fixed the issue. I am using ExpressVPN's DNS servers for my queries. Like I mentioned earlier, this was not an issue for me in earlier versions of Firefox. Only since I upgraded to 123.0.1.

Thanks

Helpful?

Postavite pitanje

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.