Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

TLS 1.0/1.1 support roadmap

  • 1 odgovor
  • 2 ima ovaj problem
  • 340 views
  • Posljednji odgovor poslao Mike Kaply

more options

As Chromium has been announcing, version 98 removed support for TLS 1.0/1.1. I know Mozilla has extended support for TLS 1.0/1.1 due to the Covid-19 pandemic. Other browsers did the same.

I’m curious if there is an official statement on a target end date for TLS 1.0/1.1 in Firefox Extended Support release. While the warnings show up, “Connection not secure. This page uses weak encryption”, can we expect Firefox ESR to stop this displaying websites using TLS 1.0/1.1?

What I’m hoping to avoid is a surprise. Thank you for your time, and I really do appreciate this community!

As Chromium has been announcing, version 98 removed support for TLS 1.0/1.1. I know Mozilla has extended support for TLS 1.0/1.1 due to the Covid-19 pandemic. Other browsers did the same. I’m curious if there is an official statement on a target end date for TLS 1.0/1.1 in Firefox Extended Support release. While the warnings show up, “Connection not secure. This page uses weak encryption”, can we expect Firefox ESR to stop this displaying websites using TLS 1.0/1.1? What I’m hoping to avoid is a surprise. Thank you for your time, and I really do appreciate this community!

Izabrano rješenje

We removed the TLS override UI in Firefox 97 (so you can't easily override).

We will not be removing TLS 1.0/1.1 support from the Firefox 91 ESR at all.

The next ESR is Firefox 102 in June and I don't know yet if that will have TLS 1.0/1.1 support.

Pročitajte ovaj odgovor sa objašnjenjem 👍 0

All Replies (1)

more options

Odabrano rješenje

We removed the TLS override UI in Firefox 97 (so you can't easily override).

We will not be removing TLS 1.0/1.1 support from the Firefox 91 ESR at all.

The next ESR is Firefox 102 in June and I don't know yet if that will have TLS 1.0/1.1 support.