Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox always open my last session

  • 10 odgovori
  • 1 ima ovaj problem
  • 914 views
  • Posljednji odgovor poslao James

more options

Hello. First of all, I warn you that my English is very basic. I am having a issue with the browser since few months and I can't solve it. Every time I open Firefox it opens my last session. Also in sometimes it start with "Sorry, We're having trouble getting your pages back".

  • I don't have enabled "Open previous windows and tabs" in the settings
  • There's not any "user.js " file in my profile folder
  • I have even uninstalled Firefox, delete all "mozilla" folders in my hard disk and run Ccleaner.
  • And I don't find any solution in the internet at all. It keeps happening.

Any idea?

Hello. First of all, I warn you that my English is very basic. I am having a issue with the browser since few months and I can't solve it. Every time I open Firefox it opens my last session. Also in sometimes it start with "Sorry, We're having trouble getting your pages back". * I don't have enabled "Open previous windows and tabs" in the settings * There's not any "user.js " file in my profile folder * I have even uninstalled Firefox, delete all "mozilla" folders in my hard disk and run Ccleaner. * And I don't find any solution in the internet at all. It keeps happening. Any idea?

Izabrano rješenje

Hi everyone. I update my status: Looks like it solved by itself. Today Firefox updated to version 97.0.1 and I don't have that issue again. The problem were a bug of the software. In the update news appears this bug as fixed.

Thanks for trying help me anyway!

Pročitajte ovaj odgovor sa objašnjenjem 👍 0

All Replies (10)

more options

Hi, can you please mention what page does it display when you open Firefox?

more options

henne77ey said

Hi, can you please mention what page does it display when you open Firefox?

Always it starts with the previous opens tabs session no matter what page was.

more options

Hello,

Please go to about:preferences#general and deselect the "Open previous windows and tabs" button under the startup header. It will likely be the top option.

more options

andmagdo dijo

Hello, Please go to about:preferences#general and deselect the "Open previous windows and tabs" button under the startup header. It will likely be the top option.

Hi. I don't have that option selected.

more options

How are you closing the browser? I suggest using the quit command in either menu.

It may help to close all tabs before quitting and to clear history.

more options

terry21 said

How are you closing the browser? I suggest using the quit command in either menu. It may help to close all tabs before quitting and to clear history.

I close it using the close button window, like any other regular program. Also, I don`t want to clear my history every time I close Firefox

more options

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

  • browser.sessionstore.resume_session_once

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

more options

Odabrano rješenje

Hi everyone. I update my status: Looks like it solved by itself. Today Firefox updated to version 97.0.1 and I don't have that issue again. The problem were a bug of the software. In the update news appears this bug as fixed.

Thanks for trying help me anyway!

more options
more options

gabriel-gallo said

I close it using the close button window, like any other regular program.

The X on top right only closes that one window and not all of Firefox that may be open. To make sure Firefox is completely closed before shutting down you should use the File/hamburger menu > Exit/Quit

Izmjenjeno od strane James