Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Gmail[gmail.com] Page not Loading important buttons.

more options

I was using Firefox in my computer and it was working fine. But after I migrated to windows 10 Os and installed Firefox, I am facing some issues with Firefox. First of all, the gmail.com page is not loading correctly (image added). Also some websites like geeksforgeeks and other websites are having trouble to show some images (mainly).

- what I tried doig previously. 1. Doing ctrl + shift + r on those pages 2. Uninstalling and reinstalling firefox with clearing firefox app data folder from windows computer. 3. Doing a refresh from help menu. 4. Tried running in safe mode. (disabling all extensions) 5. Clearing cache and data from firefox settings.

How how to show them perfectly. however they show good in chrome, but I want to use firefox. So a fix will be highly appreciated.

Priloženi snimci ekrana

All Replies (9)

more options

Make sure you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure you allow pages to choose their own colors.

  • Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

Note that this affects background images.


Make sure you allow pages to choose their own fonts.

  • Options/Preferences -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of my selections above"

If you use uBlock Origin make sure not to "block remote fonts". Note that this affects downloadable icon fonts used by a lot of website to show special icons.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.

Helpful?

more options

I checked all the possible options you have mentioned in your answer for any possibility of deviation. But all of them are as expected. And to be noted that, I use Ublock origin, and I have check it's related options to see if anything you mentioned was checked. And everything was just fine. Also I want to grab your attention on the fact that, only 1 icon is visible in the gmail page. why the others are invisible? also here's is the link to the web console for error messages, to see if anything unusual is happening, now if this problem gets fixed I'll be really happy. https://pastebin.com/cwPkiAhW

Izmjenjeno od strane tuhinmitra190221

Helpful?

more options

Now, I discovered something more. The background image for the icons is supposed to come from www.gstatic.com, but the images are not loading because the website is not able to open on firefox. I tried copying the image link from the gmail website. And tried to open it on firefox, but it's not opening with a message: Did not connect: Potential Security Risk (and there's no way to resolve this) I was trying to open the following link, (opens perfectly on other browsers) https://www.gstatic.com/images/icons/material/system/1x/arrow_back_black_20dp.png (attached images for help)

Helpful?

more options

You can check if there are details available about the issuer of the certificate and the certificate chain.

  • click the "Advanced" button on the error page to show more detail
  • click the blue "View Certificate" text to inspect the issuer of the certificate and the certificate chain in the Certificate Viewer

Helpful?

more options

Hey, checked that out got to see the certificates. now what should I do?

Helpful?

more options

You can attach a screenshot of the Certificate Viewer that shows the certificate from a not working website.

Helpful?

more options

I have attached the image of the certificate, also with that, if you want to view th full certificate you can do that from this link: certificate for www.gstatic.com

Helpful?

more options

Try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Helpful?

more options

I tried doing the same thing as you specified. But still no luck! After the closed Firefox from File Menu: Exit, a new database file is created, but still now, this hasn't solved the problem! (attached image)

Helpful?

Postavite pitanje

Morate se prijaviti na račun da biste odgovarali na poruke. Molimo postavite novo pitanje, ako još uvijek nemate račun.