Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Color Management Problem - Wide Gamut Monitor and Firefox 77.01

  • 3 odgovori
  • 1 ima ovaj problem
  • Posljednji odgovor poslao davidmschrader

more options

I recently had an automatic upgrade to Firefox 77.01 and noticed my monitor color saturation changed. I use a NEC P221 wide gamut monitor, and I'm aware of the over-saturation issues with wide gamut monitors. I'm on a 2011 Mac Mini using High Sierra 10.13.6. In the past when this issue has come up, I'd use the about:config command to adjust Firefox's color management settings. When I tried adjusting it for the new upgrade, I haven't been able to correct the problem. I tried using different values for the settings and also tried supplying the exact monitor profile name pathway to replace the "gfx.color_management.display_profile" setting.

I’ve attached a screen shot of my current settings. Any help/advice/suggestions on how to fix this problem will be greatly appreciated!


Priloženi snimci ekrana

All Replies (3)

more options

Hi davidmschrader, please ignore the spam message with a phone number -- that's not official and we don't know what they will do to your system if you engage.

more options


Ignore becky409's post, It's Spam.

In your product, are you assigning a color space?

I think by default Firefox will use the sRGB color space for images, but if a color space is designated, it may behave somewhat differently.

You could try adjusting Firefox's color management settings. This is an old write-up, but I haven't heard about any changes since then:

By default, Firefox will try to color manage tagged images (JPEGs and PNGs). You can review and experiment with the following preferences to see whether one of them is causing the problem:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste gfx.c and pause while the list is filtered

gfx.color_management.mode - governs application of color management to images

  • 0 = off
  • 1 = on for ALL images
  • 2 = on for TAGGED images (default)

I can't recall whether you need to quit/restart Firefox before this change, or changes to the below preferences, takes effect.

gfx.color_management.display_profile - if you have created a custom monitor profile and Firefox is not using it, you can enter the path to it here.

gfx.color_management.enablev4 - double-click to toggle to true if your custom monitor profile is an ICC v4 profile

gfx.color_management.rendering_intent - whether Firefox honors or overrides the intent flag in the ICC profile, by default, overrides to Perceptual

For details, see:

Can you find a combination of settings that gives you the colors you expect? Depending on your results, and whether you are publishing these images on the web, you might need to revise how it deals with color spaces.

Hope it works. Thank You.

more options

Hi Shashank,

Thanks for your reply but I've already tried everything you've suggested. Also, you can see my current management settings by viewing my attachment from my original post. All images that I upload to my Etsy shop have embedded sRGB profiles, so those management settings should work. I read online that there's a bug with 77.01 but I thought my current settings should correct it; perhaps not.