X
Pritisnite ovdje da biste otišli na mobilnu verziju stranice.

Forum podrške

How do I fix "Unrecognized command: ID"

Objavljeno

I get this message for all operations. It does not seem to effect the operation of Thunderbird. I am using version 68.3.1

I get this message for all operations. It does not seem to effect the operation of Thunderbird. I am using version 68.3.1

Izabrano rješenje

So from the log I got.

 2019-12-27 19:34:02.916000 UTC - [(null) 9352: Unnamed thread 1CC96040]: I/IMAP  1BC19000:mail.twc.com:NA:CreateNewLineFromSocket: * CAPABILITY IMAP4rev1 UIDPLUS NAMESPACE QUOTA SORT SORT=DISPLAY ID

The important part of that is that the server identifies itself as supporting the ID command.

So latter Thunderbird send such a command.

2019-12-27 19:34:03.085000 UTC - [(null) 9352: Unnamed thread 19469D60]: I/IMAP 1BC15000:mail.twc.com:A:SendData: 5 ID ("name" "Thunderbird" "version" "68.3.1")

The TWC server responds.

2019-12-27 19:34:03.132000 UTC - [(null) 9352: Unnamed thread 19469D60]: I/IMAP 1BC15000:mail.twc.com:A:CreateNewLineFromSocket: 5 BAD Unrecognized command: ID

That again is Unrecognized command: ID

So I have no doubt at all that the TWC server is not only the problem child, but that is it actually lying as it apparently does not support the ID command. Ironically theID command was created to make tracking issues to particular server/ Client software. It serves no purpose except for humans reading logs to identify the software being used.

Some years ago Thunderbird introduced user preferences to get around sub standard work with the mail server software used by charter (interMail). This was a follow up to bug 1231592 They appear to still be using the same product in production, I would expect nothing much has changed. It is identified in the log as

OK IMAP4 server (InterMail vM.9.01.00.037.1 201-2473-137-122-172)

Searching on Google shows an announcement from last century that IBM would be selling Software.com's Intermail But I can find no references to this software since the turn of the century. But it's sister openwave appears to be owned by Synchross they say

"Provides Operators the back-end framework for branded, white label email service that’s reliable, consistent, and safe with the potential to introduce and promote services that can be monetized."

I wonder how they monetize email?

But I digress, there is a global setting to suppress Thunderbird's use of the ID command. Use the Config Editor to set mail.server.default.send_client_info to false (right click the preference in the Config Editor to get the menu of actions. See Bug 741374 for the source of the pref. I have no idea where it started. )

Pročitajte ovaj odgovor sa objašnjenjem 0
Citiraj

Dodatni detalji o sistemu

Aplikacija

  • Korisnički agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Više informacija

Bibb 5 rješenja 43 odgovora
Objavljeno

Fixed

Fixed

Izmjenjeno od strane Bibb

Je li vam ovo pomoglo?
Citiraj
darrylcady 0 rješenja 3 odgovora
Objavljeno

Changing the IMAP Mail Server Port to 143 worked for me and fixed my problem. See the answer above from sfhowers. Thank you

 Darryl
Changing the IMAP Mail Server Port to 143 worked for me and fixed my problem. See the answer above from sfhowers. Thank you Darryl
Je li vam ovo pomoglo?
Citiraj
brawlman 0 rješenja 3 odgovora
Objavljeno

darrylcady said

Changing the IMAP Mail Server Port to 143 worked for me and fixed my problem. See the answer above from sfhowers. Thank you Darryl

Which Port was this for; Incoming/outgoing?

''darrylcady [[#answer-1285560|said]]'' <blockquote> Changing the IMAP Mail Server Port to 143 worked for me and fixed my problem. See the answer above from sfhowers. Thank you Darryl </blockquote> Which Port was this for; Incoming/outgoing?
Je li vam ovo pomoglo?
Citiraj
Bibb 5 rješenja 43 odgovora
Objavljeno

SOLVED!

SOLVED!
Je li vam ovo pomoglo? 1
Citiraj
brawlman 0 rješenja 3 odgovora
Objavljeno

Bibb said

SOLVED!

Bibb, were you referring to Darylcady reply? If so, saying "solved" and not answering the question I gave means little... Did you use the same port 143 to correct the issue, and if so which server (incoming/outgoing)? Do elaborate, as I'm having the same issues with "...commmand: ID" and intermittent ability to send/receive email with and without VPN use... Thx...

''Bibb [[#answer-1285636|said]]'' <blockquote> SOLVED! </blockquote> Bibb, were you referring to Darylcady reply? If so, saying "solved" and not answering the question I gave means little... Did you use the same port 143 to correct the issue, and if so which server (incoming/outgoing)? Do elaborate, as I'm having the same issues with "...commmand: ID" and intermittent ability to send/receive email with and without VPN use... Thx...
Je li vam ovo pomoglo?
Citiraj
Bibb 5 rješenja 43 odgovora
Objavljeno

I used what Matt provided in detail!

I used what Matt provided in detail!
Je li vam ovo pomoglo?
Citiraj
darrylcady 0 rješenja 3 odgovora
Objavljeno

After changing the IMAPI to Port 143, I stopped getting the Command: ID error had trouble when I launched TB, and new mail did not come in. Changed input server IMAPI back to 993 and they all came in. Then changed back to 143 and mail started working again. A little confused.

After changing the IMAPI to Port 143, I stopped getting the Command: ID error had trouble when I launched TB, and new mail did not come in. Changed input server IMAPI back to 993 and they all came in. Then changed back to 143 and mail started working again. A little confused.

Izmjenjeno od strane darrylcady

Je li vam ovo pomoglo?
Citiraj
brawlman 0 rješenja 3 odgovora
Objavljeno

darrylcady said

After changing the IMAPI to Port 143, I stopped getting the Command: ID error had trouble when I launched TB, and new mail did not come in. Changed input server IMAPI back to 993 and they all came in. Then changed back to 143 and mail started working again. A little confused.

Thank you for the update and responding. Did you happen to notice whether "working again" was after a TB update, or the same Version? Which version are you running? I'm on the latest ver 68.4.2 (32bit) though my system is a 64bit Win7. Hope to upgrade soon to a new system with Win10 64 bit, but am afraid of losing archives of TB email, even though I know about backing it up...

''darrylcady [[#answer-1285831|said]]'' <blockquote> After changing the IMAPI to Port 143, I stopped getting the Command: ID error had trouble when I launched TB, and new mail did not come in. Changed input server IMAPI back to 993 and they all came in. Then changed back to 143 and mail started working again. A little confused. </blockquote> Thank you for the update and responding. Did you happen to notice whether "working again" was after a TB update, or the same Version? Which version are you running? I'm on the latest ver 68.4.2 (32bit) though my system is a 64bit Win7. Hope to upgrade soon to a new system with Win10 64 bit, but am afraid of losing archives of TB email, even though I know about backing it up...
Je li vam ovo pomoglo?
Citiraj
Matt
  • Top 10 Contributor
  • Moderator
3393 rješenja 23501 odgovora
Objavljeno

This thread has a solution, did you miss it or are you determined to just mess around for ever trying random things that will not work.

Changing ports will not work. Changing server names will not work. Making changes by the phase of the moon will not work Hoping for a software update from your mail provider might work, but it has not yet.

Or you could just modify the preference like I said back in December.

There is a global setting to suppress Thunderbird's use of the ID command. Use the Config Editor to set mail.server.default.send_client_info to false (right click the preference in the Config Editor to get the menu of actions.

This thread has a solution, did you miss it or are you determined to just mess around for ever trying random things that will not work. Changing ports will not work. Changing server names will not work. Making changes by the phase of the moon will not work Hoping for a software update from your mail provider might work, but it has not yet. Or you could just modify the preference like I said back in December. There is a global setting to suppress Thunderbird's use of the ID command. Use the [[Config Editor]] to set mail.server.default.send_client_info to false (right click the preference in the Config Editor to get the menu of actions.
Je li vam ovo pomoglo?
Citiraj
Postavite pitanje

Morate se prijaviti na račun da biste odgovarali na poruke. Molimo postavite novo pitanje, ako još uvijek nemate račun.