Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Turned on 2 factor verify in Gmail, turned it off, now Thunderbird will not load that account and keeps asking for password ???

  • 20 odgovori
  • 2 ima ovaj problem
  • 2669 views
  • Posljednji odgovor poslao Dr.M'Bongo

more options

Turned on 2 factor verify in Gmail, turned it off, now Thunderbird will not load that account and keeps asking for password ???

I logged into gmail through browser, turned OFF 2 factor verification. (triple checked its off from different browsers)

Everytime I logged into thunderbird it would pop a browser to ask for gmail credentials, I'd enter, it would ask for permission, I'd approve and then its says authentication failed and keeps popping new window open every few minutes.

I went to security preferences, deleted passwords for that account. restarted thunderbird, same issue.

I removed the account, restarted thunderbird. Went to add account. and same pop up and then it THUNDERBIRD BOX it says alert Configuration can not be verified - is the password or username wrong?

I triple checked the password from multiple devices and browsers and it works fine. None of my other devices, browsers logins are having any issue.

It all started when I turned on 2 factor. I turned it off immediately, but stock here now...

PLEASE HELP, I've been using Thunderbird over 10 years and I'm at a loss...

Izabrano rješenje

THANK YOU THANK YOU THANK YOU! wasted a few hours over last two days and you saved me. Much appreciated :)

Pročitajte ovaj odgovor sa objašnjenjem 👍 1

All Replies (20)

more options

See this bug report:

https://bugzilla.mozilla.org/show_bug.cgi?id=1592407

and comment #22 for the workaround. If you use OAuth2 authentication, it won't matter if 2SV is on or off.

http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite

more options

Thank you sfhowes,

On the 2nd link, I tried the following:

If you created a application specific password, you use it for a while, and later on its rejected, forcing you to create another one, try deleting all google cookies using Tools -> Options -> Privacy -> Show Cookies, exit and restart Thunderbird. [18]

Didnt' work :(


On the first link, comment #22 says:

"setting general.useragent.compatMode.firefox to true allows IMAP access again."

Where do you go to make these changes? I have no idea how to find this setting? In thunderbird? what screen?

more options

Tools/Options(or AppMenu icon/Options/Options)/Advanced/General/Config. editor, double-click the preference general.useragent.compatMode.firefox to true, close Options. If you add a gmail account from File/New/Existing Account, with the default settings, it should proceed without error.

TB 68.2.1: https://www.thunderbird.net/en-US/thunderbird/68.2.1/releasenotes/

Izmjenjeno od strane sfhowes

more options

Odabrano rješenje

THANK YOU THANK YOU THANK YOU! wasted a few hours over last two days and you saved me. Much appreciated :)

more options

Please could someone help - I have this problem where Mozilla asks for me to sign in to my google account and I put in the right password and confirm that Mozilla can have access to email but then it says authentication failed. I cannot work out how to get to the general.useragent bit to make sure it says true. Could someone explain really simply how to get there. My Tools does not have an advanced bit to click...

more options

Not working for me. Maybe because I have Thunderbird portable?

Also, important add ons like gContactsync don't work anymore. In other words: Thunderbird calendar and the addressbook don't sync with Google's calendar / addressbook anymore.

Workaround 1: back to an older version of Thunderbird?

Workaround 2: ditch Thunderbird?


UPDATE November 2: Got it to work using the changed configuration, after I updated all the plugins that didn't work.

Izmjenjeno od strane jan35

more options

Actually I worked it out by going to Preferences under the Thunderbird main menu, then Advanced Configuration. Went to Config Editor. Ignored the Here be Dragons message and found the general.useragent.compatMode.firefox and changed it to true ... and it worked! Magic...

more options

sfhowes said

Tools/Options(or AppMenu icon/Options/Options)/Advanced/General/Config. editor, double-click the preference general.useragent.compatMode.firefox to true, close Options. If you add a gmail account from File/New/Existing Account, with the default settings, it should proceed without error. TB 68.2.1: https://www.thunderbird.net/en-US/thunderbird/68.2.1/releasenotes/

even though: i have 68.2.1, and it was not fixed. The solution worked ....

more options

spjhawley said

Please could someone help - I have this problem where Mozilla asks for me to sign in to my google account and I put in the right password and confirm that Mozilla can have access to email but then it says authentication failed. I cannot work out how to get to the general.useragent bit to make sure it says true. Could someone explain really simply how to get there. My Tools does not have an advanced bit to click...

Are you updated to version 68.2.1 ?

more options

I'm afraid neither 68.2.1 nor the config change have worked for me. even after deleting and reloading my Gmail account, and restarting TB 68.2.1. However, now when I click Synchronize on my Lightning calendar, I no longer get a Gmail login window - nothing happens at all, and I still have a blank calendar.

Colin.

more options

I've been in contact with Google. Hopefully know something soon. (though I know it can't come soon enough)

more options

Thanks for your efforts!

Colin.

more options

Thank you buddy! Worked great. Is it best to change back once a new update has been released?

more options

Okay...this kinda worked, but with a little twist. I followed general.useragent.compatMode.firefox to true option and was able to delete by Gmail and my Google Apps domain emails.

One of them would not authenticate, so I changed connection security manually to none and then back to SSL/TLS and OAuth2 authentication. I was finally able to login to all of my Google Accounts after deleting and re-adding using IMAP. Thanks for the suggestions and they worked for me!

Sorli

more options

If anyone is still having this issue, here is what I ended up doing to resolve after none of the above worked for me.


Started TB in safe mode.

Went to "Tools, Options, Security", then in right screen selected Passwords and then clicked on "Saved Passwords...".


Under saved passwords i found 2x entries for the gmail account, one from the middle of last year and one from about 3 years ago. I deleted both of these, then re-added the gmail account and it started working again.

more options

Thank You Thank You! This worked great. I did as you said Tbird in safe mode found three passed words that were not up to date. Delete them all. Restarted Tbird and put in my email and password and voila! everything back to normal. Can't understand why this fix wasn't posted elsewhere. Thanks again.

more options

pskvjk47 said

Thank You Thank You! This worked great. I did as you said Tbird in safe mode found three passed words that were not up to date. Delete them all. Restarted Tbird and put in my email and password and voila! everything back to normal. Can't understand why this fix wasn't posted elsewhere. Thanks again.

Good to hear this worked. Im surprised deleting thunderbird didn't resolve this for you. That was something I thought about, but this person had 4-5 other accounts that were still working so that was going to be my last resort.

more options

trails136 said

Turned on 2 factor verify in Gmail, turned it off, now Thunderbird will not load that account and keeps asking for password ??? I logged into gmail through browser, turned OFF 2 factor verification. (triple checked its off from different browsers) Everytime I logged into thunderbird it would pop a browser to ask for gmail credentials, I'd enter, it would ask for permission, I'd approve and then its says authentication failed and keeps popping new window open every few minutes. I went to security preferences, deleted passwords for that account. restarted thunderbird, same issue. I removed the account, restarted thunderbird. Went to add account. and same pop up and then it THUNDERBIRD BOX it says alert Configuration can not be verified - is the password or username wrong? I triple checked the password from multiple devices and browsers and it works fine. None of my other devices, browsers logins are having any issue. It all started when I turned on 2 factor. I turned it off immediately, but stock here now... PLEASE HELP, I've been using Thunderbird over 10 years and I'm at a loss...
more options

I used this link from Gmail help

https://support.google.com/mail/answer/185833?hl=en

more options

sfhowes said

Tools/Options(or AppMenu icon/Options/Options)/Advanced/General/Config. editor, double-click the preference general.useragent.compatMode.firefox to true, close Options. If you add a gmail account from File/New/Existing Account, with the default settings, it should proceed without error. TB 68.2.1: https://www.thunderbird.net/en-US/thunderbird/68.2.1/releasenotes/

Yes, this worked for me too. Gmail messages were not getting sent; either the connection to gmail timed out or would drop during a transfer. This started happening overnight without (as far as I can see) any software components having updated on my system.

On my particular system it was NOT a firewall issue as some threads report.

Many thanks!