X
Pritisnite ovdje da biste otišli na mobilnu verziju stranice.

Forum podrške

Google doesn't show up as a default search engine

Objavljeno

I'm using Mac OS X, the most recent version. When I use the search bar (or the tool bar search function), Firefox uses Google Scholar instead of Google. I've gone to the preferences page, and the only default search engine available is Google Scholar. The button to restore default search engines is greyed out. I can't fine a Google search extension anywhere, and you can't add Google as a search engine from the toolbar. Please help!

I'm using Mac OS X, the most recent version. When I use the search bar (or the tool bar search function), Firefox uses Google Scholar instead of Google. I've gone to the preferences page, and the only default search engine available is Google Scholar. The button to restore default search engines is greyed out. I can't fine a Google search extension anywhere, and you can't add Google as a search engine from the toolbar. Please help!

Izabrano rješenje

So, the malware scans didn't help and I went through the steps to manually removed the hijacker file (it wasn't there). However, as I looked back through one of the links you provided, it offered me a "refresh Firefox" option, and that worked like a charm. Yay! Thanks so much.

Pročitajte ovaj odgovor sa objašnjenjem 0
Citiraj

Dodatni detalji o sistemu

Instalirani priključci

  • Shockwave Flash 32.0 r0

Aplikacija

  • Korisnički agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:70.0) Gecko/20100101 Firefox/70.0

Više informacija

McCoy
  • Top 10 Contributor
520 rješenja 4893 odgovora
Objavljeno

Hello joe.bellon,

I assume that you never installed this add-on (which was last updated ten years ago) :

https://addons.mozilla.org/en-US/firefox/addon/google-scholar-10310/

But you're probably dealing with this hijacker, that changes your settings :

https://www.precisesecurity.com/hijacker/how-to-remove-googlescholar-co

Would you please do this :

Go to the Firefox menu (≡) => Options => Add-ons => Extensions and remove anything that looks unfamiliar or suspicious.

Next step is to run malwarescans - further information can be found in this article :

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners. They all work differently - what one program doesn't pick up, the other might.

Especially for Mac : https://www.malwarebytes.com/mac/

Any luck ?

Hello joe.bellon, I assume that you never installed this add-on (which was last updated ''ten'' years ago) : https://addons.mozilla.org/en-US/firefox/addon/google-scholar-10310/ But you're probably dealing with this hijacker, that changes your settings : https://www.precisesecurity.com/hijacker/how-to-remove-googlescholar-co Would you please do this : Go to the Firefox menu (≡) => Options => Add-ons => Extensions and remove anything that looks unfamiliar or suspicious. Next step is to run malwarescans - further information can be found in this article : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no '''Run most or all of the listed malware scanners'''. They all work differently - what one program doesn't pick up, the other might. Especially for Mac : https://www.malwarebytes.com/mac/ Any luck ?
Je li vam ovo pomoglo? 0
Citiraj

Vlasnik pitanja

Hi McCoy, and thanks for the ideas. I have had MalwareBytes installed for quite a while. I went through all the search ideas for locating the offending hijacker and couldn't find it. Any other ideas?

Hi McCoy, and thanks for the ideas. I have had MalwareBytes installed for quite a while. I went through all the search ideas for locating the offending hijacker and couldn't find it. Any other ideas?
Je li vam ovo pomoglo?
Citiraj
McCoy
  • Top 10 Contributor
520 rješenja 4893 odgovora
Objavljeno

Korisan odgovor

joe.bellon said

Any other ideas?

Two questions, actually :

In that second link I posted (about the hijacker), did you scroll down to the section "Manually Remove Googlescholar.co from Mac" ?

And second question : Did you run all malware scans that are listed in the "troubleshoot" article ?

I was hoping you'd find the culprit in Preferences => Add-ons => Extensions, though ....... bummer !

''joe.bellon [[#answer-1250525|said]]'' <blockquote> Any other ideas? </blockquote> Two questions, actually : In that second link I posted (about the hijacker), did you scroll down to the section "Manually Remove Googlescholar''.''co from Mac" ? And second question : Did you run ''all'' malware scans that are listed in the "troubleshoot" article ? I was hoping you'd find the culprit in Preferences => Add-ons => Extensions, though ....... bummer !
Je li vam ovo pomoglo? 1
Citiraj

Odabrano rješenje

So, the malware scans didn't help and I went through the steps to manually removed the hijacker file (it wasn't there). However, as I looked back through one of the links you provided, it offered me a "refresh Firefox" option, and that worked like a charm. Yay! Thanks so much.

So, the malware scans didn't help and I went through the steps to manually removed the hijacker file (it wasn't there). However, as I looked back through one of the links you provided, it offered me a "refresh Firefox" option, and that worked like a charm. Yay! Thanks so much.
Je li vam ovo pomoglo?
Citiraj
McCoy
  • Top 10 Contributor
520 rješenja 4893 odgovora
Objavljeno

I'm glad you got things back to normal - well done !

I'm glad you got things back to normal - well done !
Je li vam ovo pomoglo?
Citiraj
Postavite pitanje

Morate se prijaviti na račun da biste odgovarali na poruke. Molimo postavite novo pitanje, ako još uvijek nemate račun.