X
Pritisnite ovdje da biste otišli na mobilnu verziju stranice.

Forum podrške

email link doesn't work

Objavljeno

Go to file then email link and nothing. I set my mailto to thunderbird.

Go to file then email link and nothing. I set my mailto to thunderbird.
Citiraj

Dodatni detalji o sistemu

Instalirani priključci

Nortons safe web rakuten video downloadhelper plugins OpenH264 Video Codec provided by Cisco Systems, Inc. Widevine Content Decryption Module provided by Google Inc.

Aplikacija

  • Korisnički agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Više informacija

My_Cheese_Is_Slippin'
  • Top 10 Contributor
63 rješenja 751 odgovora
Objavljeno

Hi GeneWo, Check that your file type association is correct.

In Windows Settings, select Apps On the left select Default Apps Just below the reset button select Choose Default Apps By File Type It will take a few seconds for the page to load Scroll down to .eml and make sure that it is set to Thunderbird

Close Settings and try the Email Link again.

Hi GeneWo, Check that your file type association is correct. In Windows Settings, select Apps On the left select Default Apps Just below the reset button select Choose Default Apps By File Type It will take a few seconds for the page to load Scroll down to .eml and make sure that it is set to Thunderbird Close Settings and try the Email Link again.
Je li vam ovo pomoglo? 0
Citiraj

Vlasnik pitanja

Thank you but it didn't fix it?

Thank you but it didn't fix it?
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

Also I updated Firefox to 69.0 and it may have started then??

Also I updated Firefox to 69.0 and it may have started then??
Je li vam ovo pomoglo?
Citiraj
My_Cheese_Is_Slippin'
  • Top 10 Contributor
63 rješenja 751 odgovora
Objavljeno

What is your default Mail app in Windows?

What is your default Mail app in Windows?
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

Thunderbird

Thunderbird
Je li vam ovo pomoglo?
Citiraj
My_Cheese_Is_Slippin'
  • Top 10 Contributor
63 rješenja 751 odgovora
Objavljeno

Maybe I don't quite understand your explanation. Help me clarify.

The 'Email Link' is used to send a link to a website via email.

You mentioned going to a 'file'. What 'file' are you referring to?

Maybe I don't quite understand your explanation. Help me clarify. The 'Email Link' is used to send a link to a website via email. You mentioned going to a 'file'. What 'file' are you referring to?
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

Top left corner of Firefox is file and email link comes down from there. Hope that helps?

Top left corner of Firefox is file and email link comes down from there. Hope that helps?
Je li vam ovo pomoglo?
Citiraj
My_Cheese_Is_Slippin'
  • Top 10 Contributor
63 rješenja 751 odgovora
Objavljeno

OK. Clear as a bell. I thought you meant a file like .pdf or...

There is also an Email Link in the three-dot button at the end of the address bar. And an icon for your toolbar in Customize.

Have you tried setting your default browser to Mail and set mailto for Mail then try Email Link?

I've seen folks simply change their default browser to Mail and back to Thunderbird - like a jump start - then it works.

If all else fails, re-install Thunderbird.

OK. Clear as a bell. I thought you meant a file like .pdf or... There is also an Email Link in the three-dot button at the end of the address bar. And an icon for your toolbar in Customize. Have you tried setting your default browser to Mail and set mailto for Mail then try Email Link? I've seen folks simply change their default browser to Mail and back to Thunderbird - like a jump start - then it works. If all else fails, re-install Thunderbird.
Je li vam ovo pomoglo?
Citiraj
My_Cheese_Is_Slippin'
  • Top 10 Contributor
63 rješenja 751 odgovora
Objavljeno

It took a minute to find it:

Thunderbird https://www.thunderbird.net/en-US/

It took a minute to find it: Thunderbird https://www.thunderbird.net/en-US/
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

Didn't work?? I think uninstalling Firefox and reinstalling?

Didn't work?? I think uninstalling Firefox and reinstalling?
Je li vam ovo pomoglo?
Citiraj
My_Cheese_Is_Slippin'
  • Top 10 Contributor
63 rješenja 751 odgovora
Objavljeno

If there's a problem in your Profile or config entries, uninstalling/reinstalling wont' help.

Try creating a 'Test Profile' first. Type or paste about:profiles in the address bar and press Enter In the upper left click on Create a New Profile Go through the Wizard naming the Profile whatever you want. Then Launch the Profile in a New Window

Try the Email Link

When you close that window be sure to set your Default Profile to Default.

If there's a problem in your Profile or config entries, uninstalling/reinstalling wont' help. Try creating a 'Test Profile' first. Type or paste about:profiles in the address bar and press Enter In the upper left click on Create a New Profile Go through the Wizard naming the Profile whatever you want. Then Launch the Profile in a New Window Try the Email Link When you close that window be sure to set your Default Profile to Default.
Je li vam ovo pomoglo?
Citiraj
jscher2000
  • Top 10 Contributor
8690 rješenja 71037 odgovora
Objavljeno

There's also a Thunderbird forum around the corner here in case the problem is on the receiving end of the connection.

Do mailto links from other programs successfully launch new messages in Thunderbird?

There's also a Thunderbird forum around the corner here in case the problem is on the receiving end of the connection. Do mailto links from other programs successfully launch new messages in Thunderbird?
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

I don't use anything but Firefox. Never tried Edge, not even sure how Edge would do mialto? I uninstalled and reinstalled Thunderbird and used my profile from my main computer which is working?? But it didn't help? Thank you for any help! I will post my problem on Thunderbird support site too.

I don't use anything but Firefox. Never tried Edge, not even sure how Edge would do mialto? I uninstalled and reinstalled Thunderbird and used my profile from my main computer which is working?? But it didn't help? Thank you for any help! I will post my problem on Thunderbird support site too.
Je li vam ovo pomoglo?
Citiraj
My_Cheese_Is_Slippin'
  • Top 10 Contributor
63 rješenja 751 odgovora
Objavljeno

Please Check: Windows Settings -> Apps -> Default Apps -> Choose Default Apps By Protocol MAILTO should be Thunderbird

Please Check: Windows Settings -> Apps -> Default Apps -> Choose Default Apps By Protocol MAILTO should be Thunderbird
Je li vam ovo pomoglo?
Citiraj

Vlasnik pitanja

It is Thunderbird in windows/firefox.

It is Thunderbird in windows/firefox.
Je li vam ovo pomoglo?
Citiraj
NkraM 0 rješenja 6 odgovora
Objavljeno

Also Use Thunderbird (Default) not working, BUT newly created Use Thunderbird DOES?

Both application details are shown as "C:\Program Files\Mozilla Thunderbird\thunderbird.exe"

Use Thunderbird (Default)has NO Thunderbird Icon, Use Thunderbird does.

Both application details entries removed and re-entered.

Both Thunderbird and Firefox are Windows default applications (always check set)

Mailto protocol set to Thunderbird


Firefox Version 70.0b4 Build ID 20190905174512

Thunderbird Version 69.0b4 Build ID 20190827194033

Windows 10 Pro 18362.329

Also Use Thunderbird (Default) not working, BUT newly created Use Thunderbird DOES? Both application details are shown as "C:\Program Files\Mozilla Thunderbird\thunderbird.exe" Use Thunderbird (Default)has NO Thunderbird Icon, Use Thunderbird does. Both application details entries removed and re-entered. Both Thunderbird and Firefox are Windows default applications (always check set) Mailto protocol set to Thunderbird Firefox Version 70.0b4 Build ID 20190905174512 Thunderbird Version 69.0b4 Build ID 20190827194033 Windows 10 Pro 18362.329
Je li vam ovo pomoglo?
Citiraj
My_Cheese_Is_Slippin'
  • Top 10 Contributor
63 rješenja 751 odgovora
Objavljeno

Both mailto -> Thunderbird settings work for me.

Firefox v. 69.0 Thunderbird v. 60.9.0 Windows 10 Pro 16299.1029

There was an issue 3 months ago:

Hyperlinks from any program other than firefox will not open https://support.mozilla.org/en-US/questions/1260781

This was apparently cause by a Windows update and the user ultimately re-installed Windows.

You might want to check your Registry entries.

Both mailto -> Thunderbird settings work for me. Firefox v. 69.0 Thunderbird v. 60.9.0 Windows 10 Pro 16299.1029 There was an issue 3 months ago: Hyperlinks from any program other than firefox will not open https://support.mozilla.org/en-US/questions/1260781 This was apparently cause by a Windows update and the user ultimately re-installed Windows. You might want to check your Registry entries.
Je li vam ovo pomoglo?
Citiraj
NkraM 0 rješenja 6 odgovora
Objavljeno

Thanks

No problems with Hyperlinks, and sorry, I forget to mention that I checked the registry entry is set to Thunderbird.

Also neglected to mention issue only relates to Email link... and the Use Thunderbird (Default) setting

Thanks No problems with Hyperlinks, and sorry, I forget to mention that I checked the registry entry is set to Thunderbird. Also neglected to mention issue only relates to Email link... and the Use Thunderbird (Default) setting
Je li vam ovo pomoglo?
Citiraj
My_Cheese_Is_Slippin'
  • Top 10 Contributor
63 rješenja 751 odgovora
Objavljeno

I was only using the hyperlinks issue to show the possibility of a Registry problem.

I'm also Win 7 legacy, so, I also have Windows Live Mail.

When I set Mail as my default mail in Windows, then set mailto in Firefox to Always Ask, when I use Email Link I get a Launch Application dialog with the 3 choices available (see image).

Mailto has been around for 20 years. It isn't any more complicated than an Open With... command.

You can easily check to see if it's a problem in your Profile by creating a New Profile and see if the problem persists.

I was only using the hyperlinks issue to show the possibility of a Registry problem. I'm also Win 7 legacy, so, I also have Windows Live Mail. When I set Mail as my default mail in Windows, then set mailto in Firefox to Always Ask, when I use Email Link I get a Launch Application dialog with the 3 choices available (see image). Mailto has been around for 20 years. It isn't any more complicated than an Open With... command. You can easily check to see if it's a problem in your Profile by creating a New Profile and see if the problem persists.
Je li vam ovo pomoglo?
Citiraj
My_Cheese_Is_Slippin'
  • Top 10 Contributor
63 rješenja 751 odgovora
Objavljeno

I found this possible solution. This will reset all Applications handlers in Options -> General -> Applications.

Open your current Firefox settings (AKA Firefox profile) folder using either:

--- "3-bar" menu button > "?" Help > Troubleshooting Information --- (menu bar) Help > Troubleshooting Information --- type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

--- "3-bar" menu button > Exit/Quit --- (menu bar) File > Exit (or Firefox > Quit)

Pause while Firefox finishes its cleanup, then rename handlers.json to something like handlersOLD.json. If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf.

Start Firefox back up again.

Check mailto settings and try the Email Link again.

(thanks jscher2000)

I found this possible solution. This will reset all Applications handlers in Options -> General -> Applications. Open your current Firefox settings (AKA Firefox profile) folder using either: --- "3-bar" menu button > "?" Help > Troubleshooting Information --- (menu bar) Help > Troubleshooting Information --- type or paste about:support in the address bar and press Enter In the first table on the page, on the '''Profile Folder''' row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer. Leaving that window open, switch back to Firefox and Exit, either: --- "3-bar" menu button > Exit/Quit --- (menu bar) File > Exit (or Firefox > Quit) Pause while Firefox finishes its cleanup, then rename '''handlers.json''' to something like handlersOLD.json. If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf. Start Firefox back up again. Check mailto settings and try the Email Link again. (thanks jscher2000)
Je li vam ovo pomoglo?
Citiraj
Postavite pitanje

Morate se prijaviti na račun da biste odgovarali na poruke. Molimo postavite novo pitanje, ako još uvijek nemate račun.